Tracking Forums, Newsgroups, Maling Lists
Home Scripts Tutorials Tracker Forums
  Advanced Search
  HOME    TRACKER    Linux


Advertisements:










OpenSUSE :: Yast2 Update - Dependency


For the past several days I have been getting a notice to update but then when I try to, get the following notice of a dependency problem:

I am running 11.4_64 with KDE 4.6.1 update. How do I clear this?


View 9 Replies (Posted: 04-Apr-2011 05:13)

Sponsored Links:

Related Forum Messages For Linux category:
OpenSUSE :: Yast2, Firefox, Thunderbird Don't Work After Update?
Some time ago I did an automatic update and after that firefox, thunderbird and yast2 don't start. It's not that there is an error message or sth. Their icons just start jumping and after a while it stops without anything opened. I tried even removing the zilla directories and so on but it doesn't help. Of course I tried to simply reboot the machine and strangely enough, still does not work. Opera works though and I am ok with that, however yast2 not opening is more annoying. I do all the stuff that I want from the console, but of course that's not the point

Posted: 22-Nov-2010 05:03

View 3 Replies!   View Related
OpenSUSE :: Yast2 Control Center Broken After Update?
About a week ago, I installed all the updates that popped up. I didn't actually look at what was being installed.

Since then, most of the items in the Yast2 Control centre won't run and just pop up an error box with the following (Firewall):

terminate called after throwing an instance of 'std::logic_error'
what(): basic_string::_S_construct NULL not valid
YaST got signal 6 at YCP file /usr/share/YaST2/clients/firewall.ycp:20
/sbin/yast2: line 440: 19436 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
Xlib: extension "RANDR" missing on display "::ffff:127.0.0.1:11.0".

[Code]....

Posted: 04-Mar-2010 07:01

View 2 Replies!   View Related
OpenSUSE :: Yast2 Control Center Update Failed
This is the error message I got today when updating.
patch:yast2-control-center-4200.noarch conflicts with yast2-control-center-qt.i586 < 2.20.2-1.3.1 provided by yast2-control-center-qt-2.19.3-6.1.i586

Posted: 18-Aug-2011 15:47

View 4 Replies!   View Related
OpenSUSE Install :: 11.1 - Yast2 Software Management Not Working After Update
I did a fresh installation of openSUSE 11.1 i586. Everything worked fine. Then I used YaST2 Software Management to add a package. Worked fine. Then I did the Online Update to get the Installation up to date. Worked fine so far. I had to restart the Machine because of the Kernel Bugfix Update. Since then, the YaST2 Software Management is not working any more.

When I do start it, it starts the software manager, shows the "Search Phrase" and so on but when I enter a word and press "RETURN" the software manager immediately closes and takes me back to the YaST2 start screen. No messages, no warnings, nothing. With zypper I am able to install software but no longer within YaST2.

Posted: 09-Jan-2010 06:38

View 9 Replies!   View Related
OpenSUSE Install :: YaST2 Update Conflicts And Inferior Architecture
When I ran YaST | Software Management | Package | Update if newer Package Available this morning I get this message:

Code:
#### YaST2 conflicts list - generated 2011-01-22 09:40:42 ####
libxine1-codecs-1.1.19-2.pm.48.15.i586 requires libpostproc.so.51, but this requirement cannot be provided
uninstallable providers: libpostproc51-0.6.26387svn-1.pm.2.1.i586[ftp.uni-erlangen.de-suse]
[ ] break libxine1-codecs by ignoring some of its dependencies
[ ] Following actions will be done:
install libpostproc51-0.6.26387svn-1.pm.2.1.i586 despite the inferior architecture .....
[ ] do not install libxine1-codecs-1.1.19-2.pm.48.15.i586
#### YaST2 conflicts list END ###

What is it telling me? What should I do? What are the implications?

Posted: 22-Jan-2011 02:51

View 2 Replies!   View Related
OpenSUSE Install :: Update Fails - Loop - Flash Player - Yast2-core
I am trying to update Flash-player and yast2-core as prompted by today's update icon.

I am now faced with a loop that goes like this:
1) click on icon
2) window pops up, "2 packages selected"
3) click on apply, subwindow pops up
4) click on continue, "waiting for authentication"
5) after minutes of waiting, click on cancel, nothing happens
6) click on icon killing subwindow
7) now back to 2)

Aborting the process, starting at 1) again, same mess

Conclusions:
a) No idea what was going on

b) Use Yast instead of clicking update icon

Posted: 27-Aug-2011 03:49

View 2 Replies!   View Related
OpenSUSE :: KDE 4.5.4 Update Broken Dependency
On my opensuse 11.2 pc, the Decmber 3rd KDE 4.5.4 update proceeded to install all updates except libkdecore4 (and maybe others). libkdecore4 now has a dependency on liblzma5 which is not available. The result is an all white desktop with boxes where the widgets should be.

I found this bug report: [url]

But I can't find liblzma5 in the repository that is listed in the 2nd posting.

Code:

opensuse 11.2 64Bit.

Posted: 04-Dec-2010 12:04

View 2 Replies!   View Related
OpenSUSE Install :: Dependency Error During Patch Upgrade Of KDE 4.3.5 Update
I get following error during automatic patch upgrade of my SuSE 11.2 to latest path revision. I assume it is due to the KDE 4.3.5 Update part of the patch set: compiz-kde4-0.7.8-9.14.x86_64 requires libkdecorations.so.4()(64 bit) but there are no providers. The package manager suggest to replace compiz-kde4-0.7.8-9.14.x86_64 with kwin-4.3.5-0.2.1.x86_64 but I don't want to loose compiz-kde. which repository I must add to resolve the dependency.

Posted: 25-Feb-2010 13:55

View 4 Replies!   View Related
OpenSUSE Install :: Update System - Without Having To Download / Install Every Dependency Manually?
how to update my system online (for example my firefox 3.0 to 3.5) but i can't figure out how this possibly works. I tried the "online update" using Yast2 but apparently (according to Yast) there is nothing at all to be patched on my system. I tried to click on the Firefox-3.5.5 rpm in the repository web-interface and open it using "install software" but the process aborts because of unresolved dependencies. Is there an easy way to update software without having to download/install every dependency manually?

Posted: 13-Dec-2009 09:06

View 1 Replies!   View Related
General :: Dependency Errors When Using: Yum -y Update?
I want to Upgrade my system from Fedora 10 to Fedora 11 but when I use: yum -y update, my system comes up with a lot of dependency errors for Fedora 12, Fedora 13, and Fedora 14.

Right now I just want to upgrade to Fedora 11 and dont understand how I have managed to download packages for Fedora 11, 12, 13 and 14.

Posted: 05-13-2010, 10:06 PM

View 9 Replies!   View Related
General :: Missing Dependency When Trying To Update?
Fedora 12 2.6.32.9-67.fc12.i686I have tried doing the recommended as its saids at the bottom. However, that didn't work. So I have to yum upgrade --skip-brokenDoes anyone know how to solve this problem?

nss-3.12.6-1.2.fc12.i686 from updates has depsolving problems
--> Missing Dependency: nspr >= 4.8.4 is needed by package nss-3.12.6-1.2.fc12.i686 (updates)
nss-3.12.6-1.2.fc12.i686 from updates has depsolving problems

[code]....

Posted: Mar 14 10 at 6:52

View 1 Replies!   View Related
CentOS 5 :: Perl Dependency While Using Yum Update
I'm having some perl problems while using yum update... I recently upgraded to 5.3 and have the latest MailScanner.. I do not want to have to remove perl because it will remove a bunch of other things along with it.

[Code]....

Posted: 2009/4/9 3:46

View 2 Replies!   View Related
Ubuntu Installation :: Serious Dependency During Update?
Any clues as to how I got in this state? I allowed something like 100 updates this morning and these packages won't complete:

Code:
[root.bitwise: /home/sean]$ apt-get upgrade
Reading package lists... Done
Building dependency tree

[Code]...

Posted: February 18th, 2011

View 2 Replies!   View Related
OpenSUSE Network :: OpenSuse 11.3, Bind And Yast2-dns-server?
I have to wonder how much testing Opensuse has done with yast-dns-server package. After adding zones to the dns server - the system loses the ability to perform name resolutions. I can copy a named.conf file from a system that does work, except everytime the system is restart the named.conf file is rewritten trashing the updates done and again rendering the system to perform name resolutions.

Anyone have suggestions on how to get yast-dns-server from interferring with the configuration file? I tried just uninstalling the package, but then bind doesn't even start up on boot up.

Posted: 23-Sep-2010 22:33

View 3 Replies!   View Related
Fedora :: Firefox Gone After Update - Missing Dependency
I just recently updated my firefox and now I cannot find it anywhere. I have tried yum reinstall firefox and I get the following:

Code:
Loaded plugins: refresh-packagekit
Setting up Reinstall Process
Resolving Dependencies .....

I have tried the given commands and I can a reply of:
Code:
Setting up yum
Loaded plugins: refresh-packagekit
Reading local RPM database
Processing all local requires
Missing dependencies:
Package java-1.6.0-openjdk-plugin-1.6.0.0-25.b16.fc11.i586 requires libxul.so
Package firefox-3.5.2-2.fc11.i586 requires xulrunner >= 1.9.1.2
Package firefox-3.5.2-2.fc11.i586 requires libxul.so
Package xulrunner-1.9.1.2-1.fc11.i586 requires libxul.so
Package libproxy-mozjs-0.2.3-10.fc11.i586 requires gecko-libs >= 1.9.1

Posted: 20th August 2009, 10:25 PM

View 2 Replies!   View Related
Fedora :: 12 Kde Update - Get Dependency Resolution Errors
I try to update my kde to kde 4.4.1 from updates repository but i get dependency resolution errors:

Code:

Dependency Resolution Errors:

I checked my system:

Code:

It means i have the newest versions. So how to update my kde?

Posted: 26th March 2010, 12:41 PM

View 2 Replies!   View Related
Fedora :: Cannot Update Perl Due To A Missing Dependency
I cannot update perl due to a missing dependency.

Installed perl:
[kbs1@localhost ~]$ rpm -qa | grep perl-5
perl-libwww-perl-5.834-1.fc13.noarch
perl-5.10.1-112.fc13.i686
perl-5.10.1-112.fc13.x86_64

[Code].....

downgrade also does not work. I just updated F12 to F13 using DVD and this occured. Also prevents me from doing "full" yum system update, these packages always fail. I do not understand the problem, it says that perl-libs 5.10.1-112 requires perl-libs 5.10.1-112, but I have that installed.

Posted: 1st November 2010, 02:54 PM

View 1 Replies!   View Related
Fedora Installation :: Yup Update Fails With Dependency
This has been happening on my system the last few days.

$ cat /etc/fedora-release
Fedora release 11 (Leonidas)
$ uname -a
Linux kayvanxw8600.sanjose.ibm.com 2.6.29.6-213.fc11.x86_64 #1 SMP Tue Jul 7 21:02:57 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

[Code].....

Posted: 31st July 2009, 06:56 PM

View 1 Replies!   View Related
Fedora :: YUM Update - Missing Dependency Error
When I try yum update, I get the following error:
abrt-1.0.8-2.fc12.i686 from updates has depsolving problems
--> Missing Dependency: librpm.so.0 is needed by package abrt-1.0.8-2.fc12.i686 (updates)
abrt-1.0.8-2.fc12.i686 from updates has depsolving problems
--> Missing Dependency: librpmio.so.0 is needed by package abrt-1.0.8-2.fc12.i686 (updates)
abrt-1.0.8-2.fc12.i686 from updates has depsolving problems
--> Missing Dependency: librpmio.so.0 is needed by package abrt-1.0.8-2.fc12.i686 (updates)
anaconda-14.2-1.fc14.i686 from rawhide has depsolving problems
--> Missing Dependency: fcoe-utils >= 1.0.12-2.20100323git is needed by package anaconda-14.2-1.fc14.i686 (rawhide)
abrt-1.0.8-2.fc12.i686 from updates has depsolving problems
--> Missing Dependency: librpm.so.0 is needed by package abrt-1.0.8-2.fc12.i686 (updates)
Error: Missing Dependency: librpmio.so.0 is needed by package abrt-1.0.8-2.fc12.i686 (updates)
Error: Missing Dependency: fcoe-utils >= 1.0.12-2.20100323git is needed by package anaconda-14.2-1.fc14.i686 (rawhide)
Error: Missing Dependency: librpm.so.0 is needed by package abrt-1.0.8-2.fc12.i686 (updates)
You could try using --skip-broken to work around the--

I have the following repositories in my /etc/yum.repos.d
fedora-rawhide.repo
fedora-updates-testing.repo rpmfusion-free-updates.repo
rpmfusion-nonfree.repo
fedora.repo
rpmfusion-free-rawhide.repo
rpmfusion-free-updates-testing.repo
rpmfusion-nonfree-updates.repo
fedora-updates.repo rpmfusion-free.repo
rpmfusion-nonfree-rawhide.repo
rpmfusion-nonfree-updates-testing.repo

Posted: 31st March 2010, 06:19 PM

View 5 Replies!   View Related
Fedora :: F12 Update - Dependency Resolution Error
When I try to do the first update tells me "dependency resolution failed" and that I miss "librpm.so.0. I have Fedora 12.

Posted: 13th January 2010, 04:19 PM

View 5 Replies!   View Related
Fedora :: Update With 12 64-bit - Dependency Resolution Errors
I am running Fedora 12 64-bit on a MacBookPro5,1 system. After two weeks of not running Fedora on the system, I boot into it and check for updates with Yum Extender. It only finds a small handful of updates despite the fact that my other system running Fedora 12 32-bit has installed several update over the past two weeks. When I try to apply the available updates I get the following errors: Dependency Resolution Errors:

Missing Dependency: kernel-uname-r = 2.6.32.9-70.fc12.x86_64 is needed by package kmod-wl-2.6.32.9-70.fc12.x86_64-5.60.48.36-1.fc12.3.x86_64 (rpmfusion-nonfree-updates)Missing Dependency: kernel-uname-r = 2.6.32.9-70.fc12.x86_64 is needed by package 1:kmod-nvidia-2.6.32.9-70.fc12.x86_64-190.53-3.fc12.x86_64 (rpmfusion-nonfree-updates)Dependency Resolution Errors:

Missing Dependency: kernel-uname-r = 2.6.32.9-70.fc12.x86_64 is needed by package 1:kmod-nvidia-2.6.32.9-70.fc12.x86_64-190.53-3.fc12.x86_64 (rpmfusion-nonfree-updates)Dependency Resolution Errors:

Missing Dependency: kernel-uname-r = 2.6.32.9-70.fc12.x86_64 is needed by package kmod-wl-2.6.32.9-70.fc12.x86_64-5.60.48.36-1.fc12.3.x86_64 (rpmfusion-nonfree-updates)Missing Dependency: kernel-uname-r = 2.6.32.9-70.fc12.x86_64 is needed by package 1:kmod-nvidia-2.6.32.9-70.fc12.x86_64-190.53-3.fc12.x86_64 (rpmfusion-nonfree-updates)

What is needed to resolve these update issues? Also, I suspect the system is not picking up all the updates that it should. What can I do to determine which updates the system should be getting?

Posted: 15th March 2010, 12:21 AM

View 4 Replies!   View Related
CentOS 5 :: Yum Update Dependency - Kpartx And Lvm2
I'm trying just a generic yum update to bring the machine up to date, I'm running into problems with two packages and their dependencies, kpartx and lvm2

I've removed any additional repositories, and performed a yum clean all

I think my problem comes down to device-mapper, it's asking for 1.02.32-1 to install lvm2 however if I run a yum list device-mapper it only shows 1.02.24-1.el5 as installed, and it is not marked for update. I've tried downloading the rpm directly, If i try to install the rpm with yum I'm told that there is nothing to do, if I try to install directly I run into problems with conflicts with the already installed package.

The kpartx seems dependent on device-mapper-multipath

I'm getting this problem on 2 machines.

Posted: 2010/1/5 23:34

View 11 Replies!   View Related
CentOS 5 :: 5.3 Update Rhythmbox Dependency Failure
Just tried updating 5.2 to 5.3; using both pup and yum, and both get the same error:

Error: Missing Dependency: libgpod.so.0 is needed by package rhythmbox

If I remove rhythmbox (I don't use it on this machine) the upgrade works, but I thought I'd post in case someone wanted to take a look at it.

Posted: 2009/4/1 15:25

View 4 Replies!   View Related
OpenSUSE :: YaST2 Won't Launch In 11.3?
the following message appears after I enter the root password.

/usr/lib/YaST2/bin/y2controlcenter: symbol lookup error: /usr/lib/YaST2/bin/y2controlcenter: undefined symbol: _ZN9QListData11detach_growEPii

It doesn't launch from the root console, either. But, the text-based YaST works fine. I assume that something went wrong after my last system update. which package I need to downgrade, to get things working, again?

Posted: 23-May-2011 01:24

View 1 Replies!   View Related
Copyright 2005-08 www.BigResource.com, All rights reserved