Tracking Forums, Newsgroups, Maling Lists
Home Scripts Tutorials Tracker Forums
  Advanced Search
  HOME    TRACKER    Linux


Advertisements:










Fedora :: Can I Disable PackageKit / How To Do


I want to install the some new packages in the fedora 14 but the PackageKit already starting at boot and this is
the yum error:

Existing lock /var/run/yum.pid: another copy is running as pid 1939.
Another app is currently holding the yum lock; waiting for it to exit...
The other application is: PackageKit

How i can disable the PackageKit?


View 9 Replies (Posted: 6th March 2011, 06:01 PM)

Sponsored Links:

Related Forum Messages For Linux category:
OpenSUSE :: PackageKit Error "The Name Org.freedesktop.PackageKit Was Not Provided By Any .service Files" While Installing RPM
I wanted to install TeamViewer (for Linux). I downloaded the RPM, but when I double-clicked on it to start the installation I got the following error: The name org.freedesktop.PackageKit was not provided by any .service files I Googled around for possible solutions but I couldn't find any. Does anyone know how to fix this error and install TeamViewer? I'm using openSUSE 11.2 with GNOME desktop.

Posted: 30-May-2010 11:17

View 1 Replies!   View Related
Fedora :: Packagekit Gui Not Working?
I resently installed Fedora 11 x86_64 on my Thinkpad T61 laptop. After the installation it updated 415 packages. The problem is that after the update the graphical interface for the packages manager no longer works (i come from Debian so i`m not sure exactly how it is called). Of course i can still use yum (and i probably would use it anyway because i`m used to using apt from the command line) but i don`t like to have something broken on my system.So does anyone have an idea what might be causing the problem? The graphical interface for the packages manager starts and i can search for packages and it shows the results bu as soon as i mark something for instalation and start the installation it hangs up and the window soon turns grey and unresponsive. I`ve tried waiting for some time but nothing seems to happen.

Posted: 9th September 2009, 09:13 AM

View 1 Replies!   View Related
Fedora :: Yum And PackageKit Don't Show Any Updates ?
I noticed that there are some updates (stable) in Bodhi and Fedora Community, but neither yum nor PackageKit have shown any updates available for install since 04.07.2009.

I tried the following in various combinations:
pkcon make-updates
yum clean all
yum check-updates
yum make-cache
yum remove yum-presto
Disabling and re-enabling repos.

When I enable updates-testing then updates from this repo are shown. But I'm positive there are some stable updates avaiable and yum just doesn't show them

yumupdatesd is enabled
Don't get any errors on the command line
Didn't notice any errors in logfiles

I had updated yum-presto to yum-presto-0.5.0-1.fc11.noarch on that day, but have since removed it and still don't get any updates.

Posted: 11th July 2009, 06:33 PM

View 9 Replies!   View Related
Fedora :: PackageKit : How To See Back-end Logs
PackageKit uses yum as a back-end.

Is it possible to view the full logs of what yum has done through packagekit?

I ask this, because if you update your packages, and if a configuration file cannot be automatically merged, you will have two configuration files: /etc/config.rpmnew (or .rpmsav, I don't remember) and /etc/config.code...

Posted: 30th July 2010, 08:01 PM

View 2 Replies!   View Related
Fedora :: 12 RPM Fusion Breaks Yum And PackageKit?
Installing the RPM Fusion repositories brakes Yum and PackageKit.

Both stop working until the offending repo files are deleted and I can't download anything from any repository because "yum.py" or something doesn't release the lock and become a zombie

I don't know how to fix this as I tried to edit the repo and put the "failovermethod=priority" in it and it didn't work. I tried to make a repo file from scratch and it didn't work either.

There are no messages on the "Yum log file" I got this:

Nov 19 17:34:44 Installed: rpmfusion-free-release-10-5.noarch
Nov 19 18:20:10 Erased: rpmfusion-free-release
Nov 19 18:23:35 Installed: rpmfusion-free-release-10-5.noarch
Nov 19 18:38:03 Erased: rpmfusion-free-release

So I'm here now trying to see if anybody else is experiencing this and to ask for directions as I don't know what to do.

ps: Could I copy the repositories and make a local repo? If yes where can I find information about doing that?

Posted: 19th November 2009, 12:45 PM

View 14 Replies!   View Related
Fedora :: Install Up2date Instead Of PackageKit?
this is a kind of strange question but is it possible to use up2date-gnome-applet on Fedora 13? I loved the clean and stable update mechanism used in FC 3 but I am unsure whether it will also work with F 13.For those who can't remember: Take a look at the red icon in the panel:I queried yum for rhn-packages and found the following:

Code:

$ yum search rhn
Geladene Plugins: presto, refresh-packagekit
================================= Matched: rhn =================================
rhn-check.noarch : Check for RHN actions

[code]...

Can I use one or more of the packages to get the old mechanism back? I tried to find some information about yum-rhn-plugin but I was unable to find a way to use the old up2date-applet.

Posted: 23rd July 2010, 12:26 PM

View 3 Replies!   View Related
Fedora :: Install Packages With PackageKit Without Password?
Is there a way to install packages with PackageKit without having to put in the root password every time I want to install a package? I set up sudo so I can install packages in a terminal without having to put in a password but I dont want to go to the terminal every time I want to install a package. And I dont want to become a root user or anything I just want to install packages without having to put in a password.

Posted: 24th August 2010, 12:03 AM

View 4 Replies!   View Related
Fedora :: Yum Install PackageKit - Libchewing Missing Dependency
Im trying to run yum install PackageKit and i keep getting :

Error:"" ""

Posted: 02-17-2009, 02:49 AM

View 1 Replies!   View Related
Fedora :: Get The Following Loaded Plugins: Dellsysidplugin2, Refresh-packagekit [URL]?
I am having trouble updating with Yum.When I open a new terminal and use 'sudo yum update' I get the following Loaded plugins: dellsysidplugin2, refresh-packagekit [URL]: [Errno 4] IOError: <urlopen error [Errno -3] Temporary failure in name resolution> Trying other mirror. Error: Cannot retrieve repository metadata (repomd.xml) for repository: adobe-linux-i386. verify its path and try again

Posted: 9th August 2010, 11:57 PM

View 1 Replies!   View Related
Fedora :: Determine What Packages Depend On PackageKit Components
I tried to remove PackageKit from F15 the other day and it removed, amongst other things GDM. Kind of hosed and I re-installed. I want to remove two components in particular, the command-not-found one and the software updater, (the old add/remove programs). How do I determine what packages would be removed? I thought there was an option in yum, but it doesn't seem to be in the manual.

Posted: 10th March 2011, 05:35 PM

View 2 Replies!   View Related
Fedora :: Install Gnome-commander But Terminal Hangs With Message - Loaded Plugins: Refresh-packagekit
Trying to install gnome-commander, but my terminal hangs with message

Loaded plugins: refresh-packagekit

I tried to google but did not find much info..I am using Fedora 11

Posted: 26th November 2009, 04:23 PM

View 3 Replies!   View Related
Fedora :: Package Manager Hanging At The Line "Loaded Plugins: Refresh-packagekit"
From some time now whenever i start the Package Manager it hangs at the line "Loaded Plugins: refresh-packagekit" I don't know the reason as it doesn't throw up any errors. Even if i reset the terminal. nothing changes. if i force quit then when i start package manager again (in the same boot) it stops and gives the message that other application has yum lock as i cannot auto install any software

Posted: 13th November 2009, 05:06 PM

View 5 Replies!   View Related
OpenSUSE :: Use Zypper To Do Job Of PackageKit?
OpenSuse 11.2 AMD64

My question - how can I use Zypper to do the job of PackageKit ? That is, install security and recommended updates. If possible, I would like to then remove PackageKit. Do you see any problems ?

Posted: 12-Sep-2010 18:28

View 4 Replies!   View Related
OpenSUSE :: Update Kde 4.6.0 In (need Packagekit 0.6.3)
when i try to update to kde 4.6.0 (in opensuse 11.2) i notice that it need packagekit 0.6.3 (while it have 0.5.1) how do solve this problem? i use this repo: [URL]

Posted: 04-Feb-2011 08:55

View 4 Replies!   View Related
OpenSUSE :: Unable To Get Transaction Id From Packagekit
Weird error on 11.1 x86_64 - I get it when I try to do autoupdate from the tray updater. I tried searching the forums for this error but didn't find. I tried rpm --rebuilddb as su, but that didn't fix. I start YaST and chose Software / Online Update and get: Accessing the Package Management Failed - the system management is locked by the application with pid 29603 (/usr/lib/YaST2/bin/y2base). I tried killing the updater tray applet, but to no avail. TYAN2-Linux:/home/patti # ps -al

[code]...

This is an 8-quad-core (32 total cores) tyan Opteron machine with 64 GB memory and has run flawlessly for the last year. Also, I'm using YaST/Proxy to reach the repos.

Posted: 19-Jan-2010 13:40

View 7 Replies!   View Related
OpenSUSE :: Get Packagekit Error While Using My Pc / Resolve This?
I get a "packagekit error" while using my pc. code...

Posted: 09-May-2010 02:09

View 9 Replies!   View Related
OpenSUSE :: PackageKit Authentication Fails Without Asking?
The first time PackageKit Update Applet ran, it asked me for the root passwordI accidentally pressed enter after making a typo, and ever since then Update Appletfails rror:Authorization failedYou have failed to provide correct authentication.Please check any passwords or account settings.Failed to obtain authentication. It never lets me input a new password. Two questions:1) Am I doing something wrong, or is this actually a bug? The possibility has been mentioned in other posts on the topic.2) Where does PackageKit store its files? I'll either change the password myself or delete the file where it's written, hopefully that will trigger PackageKit to ask again.

Posted: 03-Aug-2011 10:37

View 7 Replies!   View Related
OpenSUSE :: PackageKit Messages On The Terminals?
I always get messages like those below in my terminals, that obfuscate my typing.

How can I get rid of them (updated opensuse 11.2)?

I already reconfigured syslog to move PackageKit messags to a separate file (because the messages appeared in /var/log/messages too, and I hoped that was the source).

I'm ok with seeing severe error messages on the console, but not spam like PackageKit started..., stopped...

Message from syslogd@job5 at Mar 14 00:29:46 ...
PackageKit: what-provides transaction /1130_cceaeeed_data from uid 1000 finished with success after 5203ms
Message from syslogd@job5 at Mar 14 00:30:06 ...
PackageKit: daemon quit

[Code]....

Posted: 14-Mar-2010 07:47

View 1 Replies!   View Related
OpenSUSE :: PackageKit Install Broken / Why Is So?
Whenever I try to install an .rpm by double-clicking on it, a window comes up with this error:

'The name org.freedesktop.PackageKit was not provided by any .service files'

There is a file called org.freedesktop.PackageKit.service in /usr/share/dbus-1/system-services, so I know that it exists. Why can't dbus find it?

Running openSuSE 11.2 with GNOME.

Posted: 11-Jul-2010 20:22

View 2 Replies!   View Related
OpenSUSE Install :: PackageKit Error In 11.3 / Get It Installed?
Just installed 11.3 KDE 64bit and I get this error:

PackageKit Error internal-error: Installation aborted by user

I didn't do anything. What does this mean? How can I get Package Kit installed?

Posted: 15-Jul-2010 20:08

View 6 Replies!   View Related
OpenSUSE :: Error : Unable To Get Transaction Id From Packagekit
When i was about to update it came up:

Code: DBus error : Unable to get transaction id from packagekit. Then it asked if i will start YaST and install the updates manual and i then took OK and this came up?

Code:
DBus error : Unable to get transaction id from packagekit.

Posted: 20-May-2010 13:03

View 8 Replies!   View Related
OpenSUSE :: Removing Packagekit : Does It Disturb Zypper
when i turn on my box (opensuse 11.4) i have the apper applet and packagekit trying to update packages, often times it 's not working for dependencies are missing or stuff like that, but this is impeding zypper to work at the same time ( PackageKit is blocking zypper. This happens if you have an updater applet or other software management application using PackageKit running.). Packagekit is busy thus can't be exited ...Is removing packagekit going to disturb zypper or not ?

Posted: 30-Aug-2011 07:30

View 5 Replies!   View Related
OpenSUSE :: DBus Error : Unable To Get Transaction Id From Packagekit
I just installed 11.2 kde 64 bit and I get this error: DBus error : Unable to get transaction id from packagekit. How do I correct this?also: the other updates have been running for a hour and they're still running. is this normal?

Posted: 19-Feb-2010 09:34

View 3 Replies!   View Related
OpenSUSE :: Stop Packagekit Update Applet Using Command Line?
I have a few PCs that are used by average joe's and whenever updates are available the update applet apears indicating there are updates. I usually update all these machines at the same time using zypper so in order to remove additional confusion how can I disable this? I've read in the forum how to stop it from starting up by going to Control Center | Startup Applications and unchecking Packagekit Update Applet. Is there a way to do this using the command line? I'm sure there is, after all this is Linux, I just need to know how. Reason being is I'll be ssh'ing into these machines to disable the update applet and don't want to touch all the machines and click my way to stop it at startup. Figure there has to be an easier way

Posted: 22-Jun-2011 12:08

View 9 Replies!   View Related
Copyright 2005-08 www.BigResource.com, All rights reserved