Ubuntu Servers :: Downgrade Curl - How To Recompile PHP With Current Settings

Feb 13, 2010

I need to downgrade curl (newest version has a bug I can't get around) and I'm not exactly sure how. I have removed curl (sudo apt-get remove php-curl), and downloaded and installed (./configure, make, make install) the version I need and everything looks fine for that. However, my phpinfo page doesn't show curl support anymore, so I assume I need to recompile php with curl support. My question is, how do I recompile php with all the current settings it has now? I used apt-get to install it with a bunch of other packages, so I'm not really sure what arguments to use when I recompile it. Is there a way to print the current settings?

View 7 Replies


Ubuntu Multimedia :: How To Downgrade Back To Nvidia-current

Feb 4, 2011

After running system update my dual monitor (twinview) setup stopped working.I believe this change ruined it: nvidia-current(260.19.29-0ubuntu1~xup-lucid4, 270.18-0ubuntu1~lucid~xup1)I've tried reworking NVIDEA X Server Settings with no success. I've tried some manual manipulation of xorg.conf with no success.I can't seem to figure out how to downgrade back to nvidia-current(260.19.29-0ubuntu1~xup-lucid4).

View 1 Replies View Related

Fedora Servers :: No /usr/src/linux Directory / Recompile A Kernel?

Feb 11, 2009

I need to recompile a kernel and I am wondering why I have a /usr/srckernels directory instead of a /usr/src/linux directory?

I installed all the packages I thought I needed.... kernek-devel, gcc, make...

What am I missing to do this "correctly"?

View 5 Replies View Related

General :: Curl - Curl API To Configure Only The Required Protocol?

Jun 24, 2010

Is there any curl API to configure only the required protocol. If I have proper openssl installed, the installed curl will have all the protocols (like HTTP, HTTPS, FTP, File etc...) supported by default. Is there any way to allow or disallow only some of the protocol at the runtime. Say I need to support only HTTPS, FILE and I dont want to allow HTTP. Is there any way to do this?

View 1 Replies View Related

Ubuntu Servers :: Curl Won't Work On 10.04.1 LTS, But Works On 9.10?

Sep 11, 2010

I've been using curl in a script of mine for a while on Ubuntu 9.10, without problems.

Ubuntu 9.10 got the following curl installed through apt-get:
ii curl 7.19.5-1ubuntu2 Get a file from an HTTP, HTTPS or FTP server


View 1 Replies View Related

Ubuntu Servers :: Seg Fault With Apache2 (SSL) And PHP5-Curl

Jun 3, 2010

I'm trying to run apache2 with mod_ssl and php support and I need curl too. When php5-curl is installed apache doesn't work with ssl and I've got this one in error.log:

[Thu Jun 03 10:00:39 2010] [notice] child pid 26013 exit signal Segmentation fault (11)
[Thu Jun 03 10:00:39 2010] [notice] child pid 26014 exit signal Segmentation fault (11)

It's strange because it works well without ssl. The problem occures only when I'm trying to access and SSl page, doesn't matter if it's a html page or php file. I'm using Ubuntu 10.06 Desktop version which is x64. Below are the packages which I've got installed related to apache php and curl. I successfully compiled php5 from source, but the problem still exists so probably it's somewhere in apache?

View 7 Replies View Related

Ubuntu Servers :: How To Do PHP Downgrade (5.3 -> 5.2)

Jul 3, 2010

I am running 5.3 and there are some issues with it. I want to downgrade to 5.2. I have a TON of PHP handlers I do not want to loose.

View 2 Replies View Related

Ubuntu Servers :: Downgrade From Maverick To Lucid?

Nov 9, 2010

I'm trying to setup a server for my home office, But I heard that using Maverick is not for office purpose and asked me to use Lucid instead.Should I download the Lucid version install it or do direct downgrade to Lucid?

View 4 Replies View Related

Ubuntu :: Save Current Settings To Fstab

Sep 30, 2010

Is there any (command line) utility that can just take current mounted disk settings and write that to fstab?

View 2 Replies View Related

Ubuntu :: Upgrade Without Losing All Current Settings And Applications?

Aug 2, 2011

I am still running Ubuntu 10.04 still on my laptop and would like to upgrade. Is there a way to do this without losing all my current settings and applications? I guess I'm mostly trying to avoid having to do a fresh install. Also, is there a way to setup my update manager to just prompt me for an upgrade any time there is a new stable version of Ubuntu available?

View 8 Replies View Related

Ubuntu Servers :: (SDE) Sense Key - Illegal Request (Current)

Jan 3, 2011

I have an MD3000 storage attached to dell server via sas cables, running ubuntu server.
the kernel keeps throwing these messages every other second on the console, but the drives from MD are fully accessible.

Jan 3 12:04:24 node2 kernel: [71041.035822] sd 5:0:1:0: [sde] Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
Jan 3 12:04:24 node2 kernel: [71041.035828] sd 5:0:1:0: [sde] Sense Key : Illegal Request [current]
Jan 3 12:04:24 node2 kernel: [71041.035833] sd 5:0:1:0: [sde] <<vendor>> ASC=0x94 ASCQ=0x1ASC=0x94 ASCQ=0x1

View 1 Replies View Related

Ubuntu Servers :: Get The Newer Version 1.4.5 Using Apt-get On Current Server?

Feb 9, 2011

I have Ubuntu Server 10.04 Lucid (LTS) installed on my server (EC2 instance). I'd like to install Memcached on it. When I type "sudo apt-get install memcached" I get version 1.4.2-1ubuntu3 installed.

I know there's a newer version 1.4.5 and looking at [URL]..I found it's available in the newer version of Ubuntu (Maverick). Question: is it possible to get the newer version 1.4.5 using apt-get on my current server?

View 1 Replies View Related

Ubuntu Servers :: Drop Current Debian VM Nodes In Favor Of 10.04?

Jun 23, 2010

Now that Ubuntu is at a LTS stage with Lucid and is easier to install PV in XenServer, I have been wanting to drop my current debian VM nodes in favor of Ubuntu 10.04. So far I have DRBD8 and OCFS2 all working nicely as primary/primary and I am on the next stage of my setup by installing ldirectord and heartbeat. Can anyone shed some light on heartbeat-gui (hb_gui) as it no longer seems to be in the repositories (since Jaunty)?[URL].. I understand that Lucid now uses pacemaker as part of a clustering suite but I have no idea if I really need it. I really liked being able to run hb_gui and logging into the heartbeat cluster to manage resources via point and click so if anyone has any hints on replacements or newer preferred methods to accomplish the same tasks via point-n-click,

View 1 Replies View Related

Ubuntu :: Recompile Kernel Tutorial?

Feb 28, 2010

any tutorial which helps in boosting system speed by recompiling the kernel

View 9 Replies View Related

Ubuntu :: Recompile Software File Into An Iso?

Jun 23, 2011

recompile files into an ISO I bought a DVD of reason 4.0 (windows music program), I wanted to back it up but I didn't make an ISO I copied the files. now I have lost the DVD and I want to install reason back to my windows machine but it needs a DVD in the drive, it wont proceed. how can I recompile the files and make them a recognized ISO so my installation can continue.

View 9 Replies View Related

Ubuntu Servers :: Vsftpd And User Specific Settings?

Jan 24, 2010

I just set up my own server and basically my folder is on say /media/disk1/ and my girlfriends is on /media/patato/ is there a way i can set it so that if i log in it goes to my folder and if she does it goes to hers.... I've currently got it set up as /media/ that it goes to but i cant get it to change it for each user (we can also browse each others drive and we dont want that, we want to be tied into /media/ourdirectory and all of its subdirectories) problem is that it is running on a computer that use to be functional (same install because I cant find my disk drive) so it cant use home folders....

View 1 Replies View Related

Ubuntu Servers :: PPTPD Auto Disconnect Settings?

Mar 23, 2010

PPTPD Auto Disconnect Settings?

View 9 Replies View Related

Ubuntu Servers :: Retrieve The Apache Compilation Settings?

Apr 28, 2010

I've been mandated to reinstall a server at a new client.He doesn't have any documentation on it.the Apache seems to be compiled with a lot of modules.Is there a way of retrieving the ./configure options that was used?With PHP, it is possible with the php-info.

View 1 Replies View Related

Ubuntu Servers :: Settings To Backup Files Automatically?

Aug 8, 2010

Does ubuntu server automatically backup files? How can i get to them?

View 1 Replies View Related

Ubuntu Servers :: Settings.json Won't Stay Changed?

May 23, 2011

I'm working on getting transmission-deamon working with remote access.

everything says edit

sudo nano /etc/transmission-daemon/settings.json

specifically "rpc-whitelist

however, as soon as I do. "sudo service transmission-daemon restart" the settings reset.

View 4 Replies View Related

Ubuntu Multimedia :: Recompile Of Loadable Video Driver?

Jun 27, 2010

I have just installed UBUNTU 10.0.4 (32 bit Generic) on a Compaq CQ50 -AMD Athlon 64 X2 1.9GHZ . The install went flalessly, and everything simply worked out of the box. I also Installed the NVIDIA Propriatery graphics driver, and it worked OK. The box has an NVIDIA GeForce 8200M G. When I did a "free" I discovered that UBUBTU was not using all available RAM. After a bit of research I found that to fix this, I needed to change the kernel to a PAE enabled one. I installed 2.6.32-22-generic-pae #36-Ubuntu SMP Thu Jun 3 23:14:23.On reboot the system complained bitterly that it could not start X. With log entry:

I) Loading /usr/lib/xorg/extra-modules/nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation" compiled for 4.0.2, module version = 1.0.0 Module class: X.Org Video Driver (EE) NVIDIA: Failed to load the NVIDIA


So, I selected to boot with the "generic" driver and all was well. I then issued-- nvidia-xconfig command and rebooted again. Same problem, this time I selected to go to shell and did a reboot, thinking that the driver needed to be recompiled for the new kernel, but I got the same result.I believe I am loading an NVIDIA driver into a PAE kernel which is compiled for the non-PAE kernel.I tried to de-Install/Re-Install the propriatery driver while running under the PAE kernel, but the driver still fails to load.

View 1 Replies View Related

Ubuntu Servers :: Check SSH Settings Post Upgrade / Pre Restart?

Aug 30, 2010

I just rented a godaddy dedicated, the ubuntu variety comes loaded with 8.04...(& I need PHP 5.3)Followed the directions here: URL...I did have to change my sources.list, everything after that went as expected (not like i'd know what to expect)At one point it asked if I wanted to update my grub/menu.lst to the release version, or use my old one, I updated it.Once the upgrade completed, I checked the menu.lst again to ensure it was gonna boot 10.04 (as warned by the guide)However once I sent reboot, I couldn't SSH back in, I waited 5m, 15m, tried again, still couldn't SSH then I had the server power cycled via my godaddy control panel, and still nothing, attempts on port 22 timed out & other ports were refused.

I think I overlooked something because, from what I've read here and there this is technically possible, I also just found this guide here:URL...The first user comment (above link/guide) seems to have a tip for what I'm trying.Anyways had the server re-provisioned via my control panel & I'm about to try again, only this time. uh, check the SSH settings post upgrade/pre restart?

View 9 Replies View Related

OpenSUSE Hardware :: How To Recompile A Kernel

Feb 3, 2011

I have a asus M51 Se that not work with 4GB of memory ram, due to a bug of bios. Only work with one slot of 2GB. I find this link https://bugs.launchpad.net/ubuntu/+s...ux/+bug/316079 that help to solve my problem. But for that I have to change a file.

My question is I need to recompile the kernel that I have? if yes, how can i make that without installing other kernel.

View 3 Replies View Related

CentOS 5 :: Recompile PHP With Imap Support?

Jun 17, 2009

I need to recompile PHP with imap support.

Serwer info:
CentOS 5.3 64-bit (Final)
Apache: 2.2.11
PHP Version: 5.2.9
Quote:yum install php-imap

View 4 Replies View Related

CentOS 5 :: Broken Kernel / How To Recompile?

Dec 15, 2009

I tried to run some virtual machine using Virtual Machine Manager but the guest OS (windows server 2003) was not able to "see" the rest of my network. I believe VMM did some NAT-ing (192.168.122.x subnet) so i'm not able to "see" my network. I tried various network setting in VMM but couldnt get it to pull my network IP (192.168.1.x subnet).So i installed VirtualBox as a work around because i know VB work when i tried it on my windows machine. I ran into some issue getting VB to run, i think it was that i need to compile the kernel to "optimize" it for VB. I am fairly new to linux so that the impression that i get when i research for the fix to get VB working. In some of the forum post people suggest few things and it seem to me like it to compile the kernel. After a few hours of working i finally got it to compile but the computer crashed during compilation.

I am guess what happened is that i was trying to optimize the kernel for VB but the version of kernel i was using (2.6.18-164.6.1.el5xen) is already optimized for xen (VMM) so it crashed. I am looking to restore or recompile the 2.6.18-164.6.1.el5xen kernel. I am not sure if this is the right thing to do to fix it. With my limited knowledge of linux that all i can think of.

View 6 Replies View Related

Ubuntu :: Minimal Kernel Recompile- Init Hangs At Plymouth

Dec 23, 2010

I've been playing around in attempt to see how small a usable kernel I can build. The theory is that it should mainly be useful for preparing a recovery disk or some such thing; disk drivers and a few network drivers are what goes in.

I built the kernel with the attached config. It boots, reaches the hdd (if I specify root as /dev/sda5 manually), then dies when it tries to start Plymouth (something about catching a SEGV signal). What needs to be enabled to run Plymouth? Alternatively, has anyone managed to remove plymouth from boot on Maverick?

(That would require a modified mountall version, I know.) I'm using the mainstream kernel sources on Maverick (yes, I know Maverick uses 2.6.35; but this does boot).

Hardware: Wireless-RTL8192SE b/g/n, uses an out-of-tree driver (r8192se_pci, from Realtek; Ubuntu builds in an older version of this driver); r8169 works for ethernet; ATI Radeon Mobility 3200 graphics, AMD Neo X2 cpu; SATA hd in AHCI mode.

View 1 Replies View Related

Ubuntu Servers :: Delete ALL Mail Server Settings And Start From Scratch?

Dec 21, 2010

I've kinda gone hopelessly lost on my mail server install and now want to start from scratch, after having wasted 4 days on this.Basically I have a 95% working postfix installation, a probably 100% working dovecot installation, but am not happy with it as a few things aren't working properly, and I don't know what I did!mail to /var/mail/richard NOT /Maildir - being the main oneBut, also the fact that I don't know where I went wrong, and want to understand why everything is now haywire. I am not certain if my security is working on the mail or the logins either.e to achieve is thefollowing:PostfixDovecotVirtual Users - using IMAP with Security, allowed to send mail from their clientVirtual DomainsPostfix AdminWebmail (Roundmail)Anti-Virus and Spam-filteringI started with this guide How to set up a mail server on a GNU / Linux system), which seems very, very good I might add, but it is for Courier, and when I bumbled along with the Dovecot equivalent ... that is where things broke.

View 5 Replies View Related

Ubuntu Servers :: Configure The Server To Reflect The New Settings Of The New Service Provider?

Jun 4, 2011

I am a newbie to linux and running ubuntu server 10.10 (no gui), I had it configured with a fixed ip address and all was fine till I changed internet poroviders and got issued with a new router.

I am trying to configure the server to reflect the new settings of the new service provider. here are the contents of /etc/network/interfaces

auto eth0
iface eth0 inet static

Just so I got this right can someone tell me if I am right here. address is the IP I wish to give to my server statically. and gateway is the ip of the router. When I try to ping the router I get

Ping ( 56(84) bytes of data.
From icmp_seq=1 Destrination Host unreachable
When I try to ping the internet i get :


Is there anyone that can shed some light on where my problem may be. As i said before I got the new router I had been working with the server no problem.

View 9 Replies View Related

OpenSUSE Hardware :: Recompile The Kernel Module For 190.29?

Jun 2, 2010

I am working with OpenCL (note that is different from OpenGL) and recently upgraded from nvidia driver 190.29 to 195.36.15 . After a bit of experimentation i decided to downgrade back to 190.29

However after i did this X complains that i have nvidia kernel module 190.42 and it does not match with nvidia drive 190.29 . Could some one tell me how to recompile the kernel module for 190.29??

View 2 Replies View Related

Debian :: Recompile Openssh-server With Different Version ?

Dec 26, 2009

I would like to recompile the openssh-server with a different version string. I download and compile the source, but so far I have only been able to compile and run the client. Not the server.

Steps taken:

Is there a flag or option I need to specify to insure that it creates the sshd?

View 1 Replies View Related

Copyrights 2005-15 www.BigResource.com, All rights reserved