General :: Error: Cannot Find GLIB Version >= 2.0: Is Pkg-config In Path?"

Apr 12, 2010

I am trying to install syslog-ng-3.0.2 on Fedora 12 and have run into an issue I don't know how to solve. When runing the "configure --enable-ssl" I get the following "checking for pkg-config... (cached) /usr/bin/pkg-config checking pkg-config is at least version 0.14 checking for GLIB - version >= 2.0... 2.0, bad version string no configure: error: Cannot find GLIB version >= 2.0: is pkg-config in path?" I have glib-2.24.0 installed on this system so I don't understand where this issue is coming from or how to fix it.

Back ground on my system -
[root@syslog-ng]# set PKG_CONFIG=/usr/lib/pkgconfig
[root@syslog-ng]# export PKG_CONFIG

View 8 Replies


ADVERTISEMENT

OpenSUSE Install :: Glib Error - GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: Assertion Failed

Mar 31, 2011

As root, type "zypper update" and get several lines of the following error:

**
GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)
Loading repository data...
Reading installed packages...

Nothing to do. Used zypper dup to upgrade from 11.3. Still have boot problems (will open another thread), but had major problems upgrading timezone. File downloads would reach some percentage of completion, then B/s would slowly reduce, to zero. Upgrade would halt until manually aborted. Solution was to manually download 5 timezone files and install them in a directory repository. File download did not specify just the timezone file, but also a part of the directory. Could this be part of the problem? example: ./rpm/i586/timezone-2011d-0.2.1.i586.rpm instead of just the file name.System is a Dell 3000 (Pentium 4, 512MB memory).

View 5 Replies View Related

SUSE :: Error: No Acceptable C++ Compiler Found In $PATH See `config.log'

Jun 29, 2010

Install problem: no acceptable C++ compiler found in $PATH (Trying to install freeciv, game) ... checking whether we are using the GNU C++ compiler... no checking whether g++ accepts -g... no checking dependency style of g++... none checking whether the C++ compiler works... no configure: error: in /home/peter/Download/freeciv-2.2.1': configure: error: no acceptable C++ compiler found in $PATH See `config.log' for more details. Other threads suggest install gcc which I thought I already did yet it didn't solve the problem!

View 9 Replies View Related

Ubuntu :: Unable To Install Glib-config Script Not Found

Aug 1, 2010

I installed cdroast that came with ubuntu and received the following:Warning: No root configuration file found or not readable!The superuser must start and configure X-CD-Roast first, before other users can use it.

I searched and found that the root configuration was turned off in some versions and uninstalled, then found a good version at http://www.xcdroast.org/ but when I tried to install from a *.tar.gz and after I ran a ./config.I downloaded glib-2.24.0.tar.gz and got a successful install, and I still receive the GLIB error. If the problem is GLIB_CONFIG environment variable, I do not know how to change that. I cannot locate glib-config either.

View 1 Replies View Related

Programming :: GTK - GLIB Version Mismatch During Installation ATK?

Jul 28, 2010

I'm currently installing GTK+ under Fedora Core 13. Before you install GTK+ you have to install GLIB, Pango and ATK. When installing ATK it goes wrong. After giving the "./configure" I get following error:

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.25.8, but GLIB (2.24.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system

[Code]...

Apparently there is an old version of GLIB on my system bugging my installation process. Does anybody know how to get rid of this old version?

View 2 Replies View Related

Slackware :: Newer Version Of Glib - For Midori Install

Jul 5, 2010

How to update my version of glib in order to install the latest version of Midori on slackbuilds.org - [url]

Midori relies on WebKit.

When I try to install WebKit using the slackbuild script, I receive the following error:

I don't see a newer version of glib-2.xx on slackbuilds and I'm hesitant to install from source over the currently installed version.

If there's no updated package, can anyone provide guidance regarding installing new glib from source ---

[url]

View 14 Replies View Related

General :: Command Path Is In PATH But Bash Does Not Find The Command

Jul 12, 2011

kernel 2.6.21.5, slackware 12.0
GNU bash 3.1.17

Code:

As you can see, /usr/local/bin is in the path. However, bash does not look for nasm in /usr/local/bin.

If I am root, things go well:

Code:

View 16 Replies View Related

General :: Find Out Path Of Program?

May 20, 2011

On Unix I can call certain programs from everywhere, like sort, pwd or my_custom_script.sh. How can I find out, where on the system my_custom_script.sh really resides?

View 2 Replies View Related

Ubuntu :: GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: Ignoring No-arg, Optional-arg Or Filename Flags

Jun 15, 2011

Quote:

(gimp:4216): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags ( on option of type 0
segmentation fault

gimp stopped working on kubuntu after installing updates, any fix?

View 9 Replies View Related

General :: Find The Location Path On Server Via SSH?

Mar 7, 2010

How can I find the lynx location path on my server via SSH

View 2 Replies View Related

OpenSUSE Install :: FreeNX: Error: Could Not Find 1.5.0 Or 2.[01].0 Or 3.[01].0 Version String In Nxagent

Aug 9, 2010

Lasted repositories: Index of /repositories/X11:/RemoteDesktop/openSUSE_11.3/i586

FreeNX-0.7.2-28.1
NX-3.4.0-21.1

To day I try install on openSUSE 11.3 and SLES11-SP1, Not finish. Error: Could not find 1.5.0 or 2.[01].0 or 3.[01].0 version string in nxagent. NX 1.5.0 or 2.[01].0 or 3.[012].0 backend is needed for this version of FreeNX.

# nxsetup --install
Removing special user "nx" ...no crontab for nx
done
Removing session database ...done
Removing logfile ...done
sent invalidate(passwd) request, exiting
sent invalidate(group) request, exiting
Setting up /etc/nxserver ...done
[Code]...

View 1 Replies View Related

General :: Find The Installation Path Of Binutils, Gcc-3.4.4.tar.gz In Ubuntu?

Apr 5, 2011

I have ubuntu 8.10. In this I could find the binutils, gcc are installed. But when ever I try to know that glibc, glibc-linuxthreads are installed are not. It showing that no package is found. For that I have downloaded glibc-2.3.3.tar.gz, glibc-linuxthreads-2.3.3.tar.gz.I want to install these two package.i dont know where to install as am novice to linux.

View 1 Replies View Related

General :: Find Command To Search Wildcard In Path?

Dec 8, 2009

I need a command to search for any file in a directory like so:

/home/*/upload/* and then change permissions any file in that directory.

Find doesn't seem to match what I need.

View 12 Replies View Related

Slackware :: ERROR: Unable To Find File "slib/guile.init" In Load Path

Dec 3, 2010

trying to install gnucash 2.2.9 from SlackBuilds. I have the current versions of slib and guile installed (slib from slackbuilds and guile from slackware). when installing slib I get the following:

Executing install script for slib-3b2-i486-2_SBo.tgz.
ERROR: In procedure primitive-load-path:
ERROR: Unable to find file "slib/guile.init" in load path
Package slib-3b2-i486-2_SBo.tgz installed.

Slib is installed. Try to run gnucash and I get the following: gnc.bin-Message: main: binreloc relocation support was disabled at configure time.

ERROR: In procedure primitive-load-path: ERROR: Unable to find file "slib/guile.init" in load path guile.init is in usr/lib/slib as it should be. I'm lost - where should I look next?

View 13 Replies View Related

Ubuntu :: Error "cannot Find Fltk-config"

Jul 1, 2011

While running the command cmake ..in the Build directory within stage-4.0.0, I got an error msg "cannot find fltk-config" aborting, Don't know what to do?

View 1 Replies View Related

Ubuntu :: Lib Packages Not Found In Config Search Path

Aug 16, 2011

I just installed Netsurf, but I was confronted with "libnsbmp is not installed". So I installed libnsbmp.
The error "libnsgif is not installed" appeared when installing libnsbmp.
The error "libpng is not installed" appearded when installing libpnf.
...
I installed all that I was asked to install. However, when I was installing libcss, it said that "Package libparserutils was not found in the pkg-config search path. Perhaps you should add the directory containing 'libparserutils.pc' to the PKG_CONFIG_PATH environment variable". I have already installed libparsercutils but not in the /usr/lib dir.

What should I do to continue my installation? And anyone could tell me what are those lib stuff? I installed zlib with the apt-get install command.Can I get other lib stuff with the same command?

View 2 Replies View Related

OpenSUSE :: 11.4: Zypper GLib-GIO:ERROR?

Apr 7, 2011

On my openSuSE 11.4 with GNome, zypper throws lots of errors when used on the command line.However, zypper does it's work correctly, but the error messages are annoying.Does anybody know what the problem is ?The error messages:

Code:
**
GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error ==

[code]....

View 6 Replies View Related

Ubuntu :: Glib Error During Login?

Aug 29, 2010

I'm getting this error when I try to login: GLib can't find the user in list [0] or something like that. This happens when I try to login using the graphical method. It logins properly when in failsafe mode. I'm using Lucid, and this happens after the hard drive load is shown in the splash screen following the login screen. It just jumps back to the login screen after this.

View 1 Replies View Related

Ubuntu :: Error: Could Not Find Expat.h, Check Config.log For Failed Attempts So I Downloaded Te Expat Library Sources I Cross Compiled

Feb 13, 2010

I am getting some error when i compile cross compile "dbus-1.2.20". error Code: checking for XML_ParserCreate_MM in -lexpat... no configure: error: Could not find expat.h, check config.log for failed attempts so i downloaded te expat library sources i cross compiled. But again i am getting same error. I think i have to add "-lexpat" in LDFLAG. But i dont know how to do that.

View 1 Replies View Related

Ubuntu :: Editing Variable Or Config File With Path To Browser?

May 14, 2010

I installed Chrome straight from the Google webpage. But, it kept crashing. So I've uninstalled it to go back to Firefox, which I never uninstalled. Problem is, now, links in Evolution and Gwibber no longer work! It's still trying to open Chrome. Presumably I have to edit a variable or config file with the path to the browser in it? Where would I find this?

View 2 Replies View Related

General :: Unable To Find Iptables Config File In Ubuntu Lucid

Jun 1, 2011

let me know where is iptables rules stored?

View 2 Replies View Related

Debian :: Iceweasel GLib - Critical Error

Oct 31, 2015

I have been having problems with Iceweasel. It freezes and freezes the entire computer too. I have to manually restart the computer.

I ran it from the terminal and right away I got this error:

GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

I am wondering if this has to do with it freezing.

View 5 Replies View Related

Ubuntu :: Installing Curlftpfs Get Glib Error?

Dec 2, 2010

Im trying to install cUrlFtpFs. I get an error when run the configure file though, it says:************************************************** *checking for GLIB... configure: error: Package requirements (glib-2.0) were not met:No package 'glib-2.0' foundConsider adjusting the PKG_CONFIG_PATH environment variable if youinstalled software in a non-standard prefix.Alternatively, you may set the environment variables GLIB_CFLAGSand GLIB_LIBS to avoid the need to call pkg-config.See the pkg-config man page for more details.***********************************************echo $PKG_CONFIG_PATHecho $GLIB_LIBSecho $GLIB_CFLAGS

View 1 Replies View Related

Programming :: Error Message 'You Must Have Glib Installed'?

Feb 15, 2010

My level is starter with Ubuntu. Moderate experience with C.Problem starting with programming in C under Ubuntu.I have installed Anjuta IDE and made this classical program.

#include "stdio.h"
main()
{

[code]....

View 2 Replies View Related

General :: Difference Between PATH=$PATH:$1 & PATH=$1:$PATH?

Jan 16, 2011

I found the following function in /etc/profile file.

[Code]...

1. I dont undestand what "if ! echo $PATH | /bin/grep -qE "(^|:)$1($|:)"" this if statement actually comapres??

2. Also what is the difference between PATH=$PATH:$1 & PATH=$1:$PATH

View 14 Replies View Related

Software :: Compiling Glib PKG_CONFIG_PATH Environment Error?

Feb 23, 2010

In my CentOS5.4 I need to install gtk+-2.12.2, it demands glib-2.22.3, and system has only glib-2.13.5I download and install glib-2.22.3 with command ./configure --prefix=/opt/glib-2.22.3 && make && make installDownloaded gtk+-2.12.2 and compiling like ./configure --prefix=/opt/gtk+-2.12.2 --with-glib=/opt/glib-2.22.3gives error:Requested 'glib-2.0 >= 2.13.5' but version of GLib is 2.12.3Consider adjusting the PKG_CONFIG_PATH environment variable if youinstalled software in a non-standard prefixI made $ export PKG_CONFIG_PATH=/opt/glib-2.22.3/bin:$PKG_CONFIG_PATHAnd please specify if here I have to write /opt/glib-2.22.3/bin or /opt/glib-2.22.3?and echo $PKG_CONFIG_PATH - I see my lib in $PKG_CONFIG_PATH

View 2 Replies View Related

CentOS 5 :: Compiling Glib PKG_CONFIG_PATH Environment Error

Feb 23, 2010

In my CentOS5.4 I need to install gtk+-2.12.2, it demands glib-2.22.3, and system has only glib-2.13.5

I download and install glib-2.22.3 with command ./configure --prefix=/opt/glib-2.22.3 && make && make install

Downloaded gtk+-2.12.2 and compiling like ./configure --prefix=/opt/gtk+-2.12.2 --with-glib=/opt/glib-2.22.3
gives error:

I made $ export PKG_CONFIG_PATH=/opt/glib-2.22.3/bin:$PKG_CONFIG_PATH

And please specify if here I have to write /opt/glib-2.22.3/bin or /opt/glib-2.22.3?

And echo $PKG_CONFIG_PATH - I see my lib in $PKG_CONFIG_PATH

But still the same error.

View 2 Replies View Related

CentOS 5 :: Error: Glib-compile-schemas Not Found

Apr 14, 2011

checking what language compliance flags to pass to the C compiler...
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.16... yes
configure: error: glib-compile-schemas not found. < ---

1. How to determine what package glib-compile-schemas belongs to ?

2. Where to get the package ?

I'm basically trying to install Anjuta 3.0 and getting this error when I run ./configure

View 2 Replies View Related

General :: How To Find Out Which Version I Have

Jan 12, 2011

RedHat, Ubuntu, Fedora, cowpat, urinestain, papsmear. Who is the bureaucrat behind this mess? I believe it is a conspiracy to keep it exclusive.

View 11 Replies View Related

General :: ERROR: Source Object Libxml2.so Has EABI Version 0 But Target Turbine Has EABI Version 4

Apr 2, 2010

When I compile my application, I received following error: ERROR: Source object libxml2.so has EABI version 0, but target turbine has EABI version 4. So I need a libxml2 file with ARM EABI version 4. Can I find one from the internet? or does anyone know how to create one?

View 1 Replies View Related







Copyrights 2005-15 www.BigResource.com, All rights reserved