Ubuntu Servers :: MDADM Not Acting As Expected On Latest Version?

May 31, 2011

All, This is a x-post from the Linuxmint forums. I did this testing on Mint 11 install - but also tried the exact same thing on an Ubuntu 11.04 release and had the exact same output to deal with..Follow along: I'm having trouble with MDADM.... It's not acting like I expect it to.... hopefully someone can enlighten me.


Code:
MintRAID aaron # mdadm --create --verbose /dev/md0 --level=5 --raid-devices=3 /dev/sdb /dev/sdc /dev/sdd
MintRAID aaron # mkfs.ext3 /dev/md0
Added this line to /etc/fstab:[code]...........

I update my fstab with /dev/md127 instead of /dev/md0 and it seems to be working ok.What in the heck is going on? Why all of the naming descrepencies? Can someone help me understand what's going on? I have used the same steps on other (and older) distros and haven't had these troubles. (Ubuntu 9 or 10 something and Cent/RHEL 5.5) I've always named the first array md0, and it's always stayed md0 through reboots, etc etc etc...

View 9 Replies


ADVERTISEMENT

Ubuntu Servers :: New Mdadm Version - Worth Upgrading?

Jul 12, 2010

I'm just about to commence a full reinstall of my home media server. Planning on using 1x 1tb and 7x 1.5TB drives in raid 6. I notice the version of mdadm distributed in Ubuntu is 2.6.7.1, but versions exist up to 2.6.9 (excluding all the 3.X ones) Is it worth using a later version? Or is 2.6.7.1 used for a particular reason?

View 2 Replies View Related

Server :: Mdadm Acting Oddly With RAID 5 Array?

Dec 21, 2010

I have been having some odd issues over the last day or so while trying to get a raid 5 array running in software under Kubuntu. I installed 3 1TB drives and started up, my sd* order got all messed up( sda was now sdc and so on). This wasn't entirely unexpected, so I fixed up fstab and booted again. I found all three of the drives I installed, set them to raid auto-detect and used mdadm to create /dev/md0. I then created mdadm.conf by piping the output of mdadm --detail --scan --verbose into /etc/mdadm.conf.At this point, everything was still going swimmingly. I copied over a few hundred GB of data from another failing drive and everything seemed ok. I went to reboot once the copy was done and everything just went weird. All of the sd* drives went back to the original. Of course, this meant that the mdadm.conf was wrong. I tried to just change the device list, but that didn't work. I then deleted mdadm.conf and rebooted. The drive list stayed in the original order this time, so I just tried manually starting the array.

By erasing the partition table of the 3rd drive, I've been able to get it to the status of spare, but it says it is busy when I try to add it to the array. A grep through dmesg makes me think that md has a lock on it. I'm not sure where to go with it now. If anyone has any pointers, I would like to hear them.

Device List(original):
/dev/sda => boot drive, /home /
/dev/sdb => 1.5TB media storage, failing

[code]...

View 1 Replies View Related

Ubuntu Servers :: Use Apt-get To Install Samba The Latest Version Is 3.0.26?

Feb 19, 2010

When I use apt-get to install Samba the latest version is 3.0.26??????. The current stable version is 3.4.5 and 3.5 is about ready to be released. Is there anywhere I can get a deb package any newer that the one in APT? or will I have to compile from source?

View 4 Replies View Related

Slackware :: Latest Mdadm Hasn't Escaped The Attention Of The Gurus For -current?

Dec 25, 2010

I just wanted to make sure the latest mdadm hasn't escaped the attention of the Slackware gurus for -current. I bet it hasn't I'm basically in the same situation as described here:[URL]...

View 2 Replies View Related

Fedora :: Upgrade Version From 10 To Latest Version 13

Mar 10, 2010

I am using Nagios 3.2.4 monitoring tool on a Linux box with Fedora 10 installed on it and Apache version is 2.2.10. I would like to upgrade my Fedora version from 10 to latest version Fedora 13.

View 9 Replies View Related

Server :: Multiple Servers Acting Like One?

Jan 26, 2010

by now I have 10 servers for hpc, power computing oriented. My users need to launch several processes using qmake. The users are used to work with ubuntu 9.10, and the software from the repositories is switable for them. I've deployed ubuntu 9.10 to all 10 servers (pxe rocks). By now we work with parallel-ssh and cluster-ssh, which allows as to launch the same process to all servers. With this tools this tools the servers remain as independent but with the same software and the same launched command. Now we would like to go to next step and see all the servers as a single one with all the resources from the other 9 as if was its resources. The difference would be substantial in time to process and also time to design the command to launch.

View 13 Replies View Related

Ubuntu Servers :: Is 10.04lts Acting As Internetserver Secure?

Apr 3, 2011

On a windows system I installed xampp, and let web applications on the computer be acceseable via internet . On a forum I was firmly instructed that it was an unsecure pracsis.Now I saw on utube, that it is possible to install apache and php on ubuntu 10.04 lts desktop edition.

q1: What shall I install to get apache and php and sql databases?

q2: Is runnings web applications that are acceseable via internet on a ubuntu desktop edition with the above descripted software also unacceptable in terms of security, or is it a productive secure platform. I was told that productive platforms are ok to connect to the internet.

View 2 Replies View Related

Ubuntu Servers :: Postfix+dovecot Not Working As Expected?

Nov 9, 2010

I have tried to find solution in existing posts but could not specifically find any with my kind of issues and hence a new post on oft repeated subject !! -- and apologies for a long long post here.Here is where I am ..On a AMD 64bit machine - I have ubuntu 10.10 desktop installed. I want this development machine to support virtual mailboxes so that I can use them from multiple apps and create real life deployment situations.I installed postfix + dovecot following the tutorials available here and current state is - I can send mails using telnet sessions and I see that the mail files are getting created in /Maildir form as I have directed in the conf files. I have configured Thunderbird mail client as well.

Issue #1: Mail sending works from Thunderbird but it always responds back with 'No mail on server' message when I try to receive mails. SMTP is configured with STARTTLS and POP3 with None (i.e. plain text password)Issue #2: Also, while going thru conf, logs and during testing - I found a few things which defer in this installation for authentication. I have given the session transcripts here.Issue #3: That being major issue - I also want to configure my virtual users to use TB client to access their mails - I did not find any tutorials or pointers towards that in my search for past few days. If I send mails to a non-Unix virtual user - the mail gets stored into /home/vmail/<domain>/<user>/new directory.Here are the conf files.main.cf for postfix

Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version
# Debian specific: Specifying a file name will cause the first

[code]....

View 1 Replies View Related

General :: Enable High Availability Between Two Squid Proxy Servers Acting As One?

Sep 29, 2010

I have setup proxy server as squid Now i would like to enable High Availability between two squid proxy servers acting as one.

View 6 Replies View Related

Ubuntu Servers :: Varnish Configuration - Expected Return Action Name

Nov 29, 2010

I have to configure the varnish cache for the varnish 2.1 from the already configured varnish.conf(version 2.07)

When i run the new varnish file which resolves the error

Message from vcc compiler ""Expected return Action name.(Input line 120 pos 12) return discard ""

May i clear about switching the configuration from varnish 2.1 to varnish 2.07?

View 1 Replies View Related

Ubuntu :: How To Get Latest Version Of Wine

Mar 26, 2010

I have wine 1.0.1 , I don't know how to install the latest version ? should i remove the one I currently have?

View 9 Replies View Related

Ubuntu :: Get The Latest Version Of Winff In 10.10?

Jun 17, 2011

I downgraded from 11.04 to 10.10 due the problems, one thing I don't like is that Ubuntu dosen't give the latest updates of most software if the OS isn't the latest, such as LibreOffice, Firefox, WinFF etc. is there a way to get the updates to do that?

View 2 Replies View Related

Ubuntu Servers :: Why Behind LVM Over Mdadm

Apr 2, 2010

I'm setting up a DIY NAS system, running Ubuntu server from a CF and using 2 SATA drives. I only need RAID1. so that should do. Setting up RAID1 with mdadm is straightforward, and all of my tests with failure/recover scenario work fine in VirtualBox. Most of the tutorials on the net are talking about using mdadm in conjunction with LVM2. What is the reasoning behind LVM2 over mdadm?

View 2 Replies View Related

General :: Install The Latest Git Version On Ubuntu 10.10?

Nov 10, 2010

Synaptic just gives me version 1.7.1, but I want version 1.7.3 without the need to download and build from sources.

View 3 Replies View Related

Ubuntu :: Update To The Latest Java Version?

Jan 2, 2010

How do I update to the latest java version?

View 9 Replies View Related

Ubuntu Multimedia :: Get Latest Version Of K9Copy?

Feb 17, 2010

Using the Synaptec route, I can only install version 2.3.3, which is backlevel (latest is 2.3.5)

I have tried updating Synaptec, tried downloading directly from the website, but cannot figure out how to compile, etc.

how I get the latest version available in Synaptec, or another way to get the latest?

View 2 Replies View Related

Ubuntu Installation :: Latest Version Of Samba ?

Feb 25, 2010

From what I can see it looks like I need to install Samba before I can share files between my Ubuntu 9.10 and Win7. I went to samba.org and they report the latest version of Samba as 3.4.6. When I searched for Samba in the Ubuntu software center, they report the Samba version as Version: 1.2.63-0ubuntu4 (system-config-samba).

Version 1.2.63 seems really old. Am I missing something? How can I install the latest version of Samba?

View 3 Replies View Related

Ubuntu Installation :: Latest Version Of Gimp

Mar 7, 2010

I have 2.47 installed and I want to upgrade to the newest version 2.67 yet when I try to upgrade, I am being told that I have the latest version. Is 2.47 the latest version in debian?

View 3 Replies View Related

Ubuntu :: Clue To Get To The Latest Version Of Rhythmbox?

Mar 12, 2010

I have no clue how to get to the latest version of Rhythmbox. All my songs have the cover art embedded in the ID3 tags and the .12.6 reads these, but I have .12.5. .7 is actually out now but I have no clue how to upgrade my Rhythmbox. Apt upgrade didn't do anything of course nor doing it through the GUI.

View 3 Replies View Related

Ubuntu Installation :: What Is The Latest Kernel Version

Sep 1, 2010

Twice now I have received update notices informing me of header upgrades which I installed, both required a restart of the system. Usually when this happens there is an additional item in the grub menu. The last two times this has happened I didn't get an additional menu item. What is the latest stable version? I am currently running:

2.6.32-24-generic #42-Ubuntu SMP Fri Aug 20 14:21:58 UTC 2010 x86_64 GNU/Linux

I did try a "sudo update-grub2" and the menu didn't change.

View 5 Replies View Related

Ubuntu :: Latest Desktop Version Of Maverick?

Sep 5, 2010

Where would I find the very latest (daily build) of the desktop version of Maverick ?

View 1 Replies View Related

Ubuntu :: Does 10.10 Work With Latest Version Of Wubi?

Nov 6, 2010

Has anyone tried edubuntu 10.10 with the latest version of wubi?

View 3 Replies View Related

Ubuntu :: Get The Latest Version Of Software Centre In 10.04?

Dec 9, 2010

I currently have version 2.0.7 installed. How do I get the latest version of software centre (3.0.7) or later on ubuntu 10.04?

View 4 Replies View Related

Ubuntu :: Firefox Not Using Latest Flash Version?

Dec 18, 2010

I run Ubuntu 8.04 on my Sony laptop and Firefox 3.6.13 and have installed via synaptic Flash 10.1.102.65-2 but Firefox uses Flash version 9. How come? By the way this is on a fresh reinstall of both Firefox and Flash and a newly created profile.

View 7 Replies View Related

Ubuntu Installation :: How To Upgrade 9.10 To Latest 11.04 Version

May 8, 2011

I have ubuntu 9.10 how to make it or upgrade it to latest 11.04? I don't want to do new installation?

View 1 Replies View Related

Ubuntu Multimedia :: Can Get The Latest Version Of Shotwell In 10.04

May 9, 2011

I'm running ubuntu 10.04 on one computer, 10.10 on another two and kubuntu 10.04 on a 4th computer.

I'd like to get the latest version of shotwell installed on each of those computers. That way I can share libraries among the computers and keep my pictures in sync with tags and events.

How would I go about doing that other than upgrading all the computers to 10.10. Is this something ubuntu can do or is this a downside of ubuntu?

View 3 Replies View Related

Ubuntu Installation :: Upgrading To The Latest Version From 9.04?

May 25, 2011

I've not really need the computer for much for a while and have let the updates slip! I've got 9.04 and obviously need a newer version. I read that it's best to upgrade to 9.10 first then go from there, but my version is so old all the information is using update manager (just click this button blah blah) but of course this isn't supported now so can't use that method.

I don't really know any other way to upgrade other than following the links in update manager

ps forgot to say my cd coping sometimes messes up, don't know if it's software or hardware so was looking for methods to avoid downloading onto cds then upgrading from that! but will have to try this if no other way

View 9 Replies View Related

Ubuntu :: Install The Latest Version Of GNOME 3?

Jul 23, 2011

#1 : Open synaptic package manager and add the PPA (Settings -> Repositories -> Other Softwares, then add the PPA given below ) for GNOME 3.

ppa:ubuntu-desktop/gnome3-builds

#2 : Then, update the repository packages (using Reload button).

#3 : Now search for gnome 3 package and install it.

sudo add-apt-repository ppa:ubuntu-desktop/gnome3-builds
sudo apt-get update && sudo apt-get install gnome-desktop3

But This does not work with Lucid 10.04 as the software repository for Lucid (referenced above) does not exist.

View 2 Replies View Related

Ubuntu Installation :: Upgrading From 8.04 To Latest Version

Aug 8, 2011

I have a Dell Mini 10V running Ubuntu Linux 8.04 LTS. I need to upgrade to the latest version of Linux. Which of the latest versions I can upgrade to and exactly which download to use (a reference to the actual download and page it is on) to be able to upgrade. I have looked at the many different versions and types of downloads and have no idea which to choose to be able to use the correct one.

View 8 Replies View Related







Copyrights 2005-15 www.BigResource.com, All rights reserved