Ubuntu :: Recurring Failure To Resolve Openoffice Dependencies - Possibly Due To Held Packages

Feb 16, 2011

Distro: Ubuntu 9.10 (partially upgraded to 10.04)

Terminal log below:

In addition, I was unable to uninstall libreadline5 (since I already have libreadline6 installed).

It appears that libreadline5 may be the source of this problem with dependencies.

View 2 Replies


Ubuntu Installation :: Update - Error - PkgProblemResolver:Resolve Generated Breaks - This May Be Caused By Held Packages

Oct 10, 2010

I'm trying to update my Ubuntu 10.04 to 10.10... But I get this error message:pkgProblemResolver:Resolve generated breaks, this may be caused by held packages

I tried to disable all the repositories, and also "sudo apt-get -f"... But still having this error message...

View 8 Replies View Related

Debian :: Can't Upgrade - All Packages Held

Mar 30, 2015

Since I upgraded Gnash: viewtopic.php?f=30&t=115357 I can't upgrade anything. At least I think that's when it started.

In Aptitude, I have 176 "packages being automatically held in their current state", and 47 "packages being held back". When I updated the package list, there was a dozen or so lines that were yellow instead of green, but it ran too fast for me to read. I doubt that is important, but I try to give as much info as possible.

I'm running Debian Wheezy, 7.1.

View 8 Replies View Related

Ubuntu Servers :: Packages Held Back In Upgrade?

May 16, 2010

I recently upgraded to 10.04 (clean install) and when I run apt-get upgrade, I get:

The following packages have been kept back: linux-headers-server linux-image-server linux-server

0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded. why these updates have been held back?

View 1 Replies View Related

Ubuntu Installation :: Error When Upgrading - You Have Held Broken Packages

May 10, 2010

I tried to upgrade to 10.04, but did not succeed. Error: You have held broken packages.

View 2 Replies View Related

Ubuntu :: Install My ATI Propertary Driver - Held Broken Packages

Jan 17, 2011

I tried to install my ATI propertary driver and it says

E:Unable to correct problems, you have held broken packages

I have held broken packages and it wont download/install the driver :S what should i do?

I have had a similar problem before i think, also when i used peppermint i couldnt install my driver, but forget it i like ubuntu the best....could this happen because i clicked skip during some parts of the installation of ubuntu?

View 3 Replies View Related

Ubuntu Installation :: Upgrade Wants To Remove Lots Of Packages (possibly Depending On Plymouth)?

Oct 5, 2010

last week I encountered the following problem: The update manager suggests a distribution upgrade (strange enough since I already have 10.4 and 10.10 is not released yet). The even worse part is that 24 packages shall be removed from my system, including acpi, cryptsetup, network-manager, nvidia-current, plymouth-x11, samba and wine. About 5 weeks ago I experimented (without success) with disabling plymouth because I wanted textmode during booting. I found some warnings that one should not completly remove plymouth because lots of dependencies including cryptsetup (which is vital to my system). So I did not remove plymouth (a look in Synaptic confirms this), but I may have changed some settings concerning plymouth.I am not sure what this upgrade is about.

View 3 Replies View Related

OpenSUSE :: Run "zypper Up" Get Recurring Updates For Same Packages?

Mar 19, 2010

I noticed that when i run "zypper up" i get recurring updates for the same packages. these are mainly KDE packages, but also virtualbox and vlc. I understand that at least with KDE 4.4 - the version i now have, it is under constant development, but it looks to me like i keep getting the same updates all the time. i'm talking about several times a week. running zypper lr yields this:


my guess is that i might have repositories that contain the same packages, and i'm upgrading downgrading all the time.

View 5 Replies View Related

Ubuntu Installation :: Upgrades Held Back - Two Packages - Grayed Out And Do Not Upgrade In Upgrade-manager

Mar 29, 2010

I'm running 10.04 and for several days now I get two packages that are grayed out and do not upgrade in upgrade-manager.

If I use the shell and apt-get I get the following message: The following packages have been kept back: firefox-gnome-support update-manager

The system is functioning well, but these 2 packages just linger as I process probably hundreds of lucid upgraded packages.

View 1 Replies View Related

Ubuntu :: Can't Install Kde3 - Openoffice Dependencies

Aug 20, 2010

I tried to install kubuntu-desktop-kde3 but could not:


Other threads indicate that kde3 can be installed alongside kde4, but not here, evidently.

View 1 Replies View Related

Ubuntu Installation :: Package Dependencies / OpenOffice.org-core Broken?

May 17, 2010

So i upgraded from 9.10 to 10.04. when i ran update manager after the install, it had some stuff for OpenOffice and during the update it hung. I powered off the laptop and turned it back on, booted into ubuntu and tried over but it didn't list the updates again.

View 8 Replies View Related

Red Hat / Fedora :: Failed Dependencies While Installing Openoffice Version 3.3

Jun 8, 2011

I have installed Redhat 5.5 and when I try to install Openoffice v 3.3, I get dependencies error. I successfully run "tar -xzvf" command. But when I run next command I get this error.

# rpm -Uivh *.rpm
error: Failed dependencies:
libfreetype.so.6()(64bit) is needed by ooobasis3.3-core04-3.3.0-9567.x86_64
libgnomevfs-2.so.0()(64bit) is needed by ooobasis3.3-gnome-integration-3.3.0-9567.x86_64
libgconf-2.so.4()(64bit) is needed by ooobasis3.3-gnome-integration-3.3.0-9567.x86_64

View 1 Replies View Related

General :: Way To Resolve Dependencies Automatically?

Aug 13, 2009

Is there a way to resolve these dependencies automatically?

View 2 Replies View Related

Ubuntu :: Reinstall Openoffice Error - " Package Dependencies Cannot Be Resolved

Jan 12, 2011

So I tried out Libreoffice and want to revert back to Openoffice for the time being. I uninstalled Libreoffice from ubuntu software center and now I can't reinstall openoffice from USC. i get this error:

" Package dependencies cannot be resolved: This error could be caused by required additional software packages which are missing or not installable. Furthermore there could be a conflict between software packages which are not allowed to be installed at the same time. " does anyone have a way of fixing this? edit: i've tried sudo apt-get install openoffice.org in terminal but it didn't work as well (i'm total noob)

View 4 Replies View Related

Server :: Skipping Failed Dependencies Error / Rpm -u /packages Recieve A Failed Dependencies Error?

Nov 2, 2010

I am currently trying to upgrade over 100 rpms on multiple Red Hat servers. Whenever I try to do a rpm -u /packages/*.rpm i recieve a failed dependencies error on the very first rpm. I know that I can go though each rpm one by one and trace each dependency but that will take forever. Is there a way to skip these errors? I know the -nodeps command for rpm but I dont want to screw something up but running all of these rpms on -nodeps

View 10 Replies View Related

OpenSUSE :: Kmail Install Fails - Dependencies Issues / Resolve This?

Dec 18, 2010

I originally uninstalled KMail but now i would like to try it out again and get more familiar with it.
Problem is, since i upgraded to KDE 4.5 i can't.
There is always some dependencies issue. code...

View 3 Replies View Related

Fedora Installation :: Can't Open Openoffice 3.2 In Gnome / Resolve This?

Nov 11, 2010

I have installed open office using yum install.

To install OpenOffice you can use yum like:
connect to the internet
open a console
su -
root password
yum install openoffice.org-base openoffice.org-calc openoffice.org-calc openoffice.org-draw openoffice.org-draw openoffice.org-writer
(all on one line)

This will install the man packages for Openoffice. To see all packages available for OpenOffice use:

yum list openoffice*

I am running fedora 14.

I have no openoffice icons on the desktop, or items in the menus.

View 5 Replies View Related

Debian :: G++ Packages Dependencies Are Ok?

Jun 22, 2011

i'm can't install the g++ compiler. I've got the packages to install with the command "dpkg -i xxxx.deb", but i see a cross dependence between g++-4.3 and libstdc++6-4.3-dev. Or am I missing something?


View 4 Replies View Related

Ubuntu :: 10.04 Java - Packages Have Unmet Dependencies

Nov 3, 2010

I have the following error in 10.04. I've tried several times to uninstall, resolve, install these dependencies and am at my wits end now. This morning I gave up on OpenJDK and installed Sun JDK, hence the sun versions below. But this error is stopping me from installing anything else.

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `apt-get -f install' to correct these:

The following packages have unmet dependencies:
default-jre-headless: Depends: openjdk-6-jre-headless (>= 6b14) but it is not going to be installed
icedtea-6-jre-cacao: Depends: openjdk-6-jre-headless (= 6b18-1.8.2-4ubuntu2) but it is not going to be installed
latexdraw: Depends: libjiu-java but it is not going to be installed
Depends: libjlibeps-java but it is not going to be installed
openjdk-6-jre: Depends: openjdk-6-jre-headless (>= 6b18-1.8.2-4ubuntu2) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

me@andromeda:~/private$ java -version
java version "1.6.0_22"
Java(TM) SE Runtime Environment (build 1.6.0_22-b04)
Java HotSpot(TM) Server VM (build 17.1-b03, mixed mode)
me@andromeda:~/private$ javac -version
javac 1.6.0_22

View 5 Replies View Related

Ubuntu :: Removing Packages With Dpkg - Dependencies?

Jan 26, 2011

I want to remove Evolution and install Thunderbird. I have a general question. WRT any given package, how can I determine if that package is required by any other packages so that I wouldn't want to remove it?

View 9 Replies View Related

Slackware :: Trackinstall Failure / Resolve This?

Jan 8, 2010

This post was originally placed in the src2pkg thread, just below.
But to avoid it being overlooked I am placing it in a new thread here.

I am using src2pkg v.2.0 with Slack 13.0 running kernel

In the past I used trackinstall to run 'make install' after configuration and compilation (using a makefile). Here's an example
of what happens when I use the current trackinstall that comes bundled
with src2pkg code...

View 1 Replies View Related

Ubuntu :: Window Manager General Failure / Resolve This?

Jul 28, 2011

I installed Xubuntu 11.04 a few days ago, and everything's been more or less fine since then. But I installed some updates last night, paying no attention to what they were, and this morning I logged in to find problems.

Open windows do not get registered with window listings (like in the top panel, for instance). All windows open above desktop panels, and cannot be moved behind them. Some windows open with their title bars above the top frame of the screen, but Alt + Click/Drag doesn't grab the window. Maximizing and minimizing windows do not work. There is simply no reaction to clicking them. I logged out and also restarted the system to see if it was a fluke, but it's not.

Otherwise, everything still seems to be functional. I'm writing this post from the laptop that's having the problem. I'm going to try uninstalling the crappy ATI video drivers and see if that resolves the problem.

View 2 Replies View Related

Ubuntu :: Gnome Won't Install - Following Packages Have Unmet Dependencies

Jun 2, 2010

So recently I've been exploring my options in terms of a desktop environment. trying out different options (Blackbox, Enlightenment ect..) and somehow in the process i managed to uninstall Gnome.

Normally I would just re-install it but whenever I try I get this:


The following packages have unmet dependencies:

So I go through synaptic and it tells me, to install 'swfdec-mozilla' i need to uninstall 'epiphany-extensions' so I do that. and then the terminal gives me the same error as before.. only it say that 'epiphany-extensions' is not going to be installed.

I'm running 10.04.

View 4 Replies View Related

Ubuntu :: Package Dependencies From Manual Compiled Packages

Jun 29, 2010

I have compiled FFMPEG (and also mplayer and x264) from scratch to always run the latest version. I install ffmpeg using "checkinstall". When compiling FFMPEG manual and installing with checkinstall ffmpeg provides the following libraries: libavutil49, libavcodec52, libavdevice52, libavformat52, libavfilter0, libpostproc51, libswscale0

These can NOT be installed via apt-get (or similar) or the checkinstall will fail. So I have not installed them. The problem now is when I need to install a package (.dep or from Synaptic) that requires one of these a prerequisite. Then it is not "registered" by Synaptic that these are already provided through the FFMPEG build. I have tried to use the --provides flag on checkinstall and I can also see in Synaptic that on the ffmpeg package I installed with checkinstall that it says it provides said packages. I even have tried to modify the checkinstall script and add:

Replaces: libavutil49, libavcodec52, libavdevice52, libavformat52, libavfilter0, libpostproc51, libswscale0

This also triggers Synaptic to list that ffmpeg replaces the packages. But still when I try to install anything that needs these packages it is not recongnized that they are provided by FFMPEG and when I install one of them (e.g. apt-get install libavformat52) then it replaces the FFMPEG library and FFMPEG stops working. So what is going wrong? Is this a bug in Synaptic? How is it possible under ubuntu to install manual compiled packages and have them "act" as correct dependencies for others?

View 2 Replies View Related

Ubuntu Installation :: Update Packages / Install New Ones With Their Dependencies

Dec 6, 2010

I'd like to update /etc/apt/sources.list with all the packages available on packages.debian.org and packages.ubuntu.com without apt-get, aptitude, and synaptic then trashing my system by trying to update all the obsolete packages. (I'm stuck with 8.04) I only want to update the packages / install new ones with their dependencies as I request them. How do I do that?

View 9 Replies View Related

Ubuntu :: Packages Update Errors - Broken Dependencies

Mar 12, 2011

I have a computer with 128 ko of RAM (a very old one). I installed yesterday ubuntu 8 because ubuntu 9 requires 512 ko of RAM and was very slow. Now, I have problems to update packages and to install every thing. I changed the sources.list because it seems that links are no more available according to the error messages. (I have put many adresses for ubuntu 9 because I think the kernel is the same not as the kernel for ubuntu 10). But new problems have occurred like "broken dependencies". Now I want to correct, and I don't know how? I'm still a beginner with this OS.

View 2 Replies View Related

Ubuntu :: Git Packages Install Error - Unmet Dependencies

Apr 15, 2011

I try to install git packages, when I type ./configure it gives me the error:
C compiler cannot create executable
Search around, and I find a solution, install the g++ packages, simply type:

apt-get install g++
But it gives me another error

The following packages have unmet dependencies:
G++ : Depends: g++-4.4 (>= 4.4.3-1) but it is not going to be installed
E: Broken packages
I also tried

apt-get install build-essential
But I get another error

The following packages have unmet dependencies:
build-essential : Depends: libc6-dev but it is not going to be installed or
libc-dev : Depends: g++ (>= 4:4.3.1) but it is not going to be installed
E: Broken packages

View 9 Replies View Related

Ubuntu Installation :: 11.04 Upgrade - Packages Have Unmet Dependencies

Apr 29, 2011

I am trying to upgrade to ubuntu 11.04 from my current 10.10 system. If I try to upgrade with Upgrade Manager it stops at calculating upgrade step and I can see red circle at top left corner, hovering over this gives message -
An unresolvable problem occurred while calculating the upgrade.
Please report this bug against the 'update-manager' package and include the following error message:
'E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.'

If I run
sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Failed

The following packages have unmet dependencies:
libappindicator1 : Depends: libdbusmenu-gtk3 but it is not going to be installed
Recommends: indicator-application (>= 0.2.93) but it is not going to be installed
overlay-scrollbar : Depends: liboverlay-scrollbar-0.1-0 but it is not going to be installed
python-aptdaemon-gtk : Depends: python-aptdaemon.gtk3widgets (= 0.41+bzr646-0ubuntu2) but it is not going to be installed
python-couchdb : Breaks: desktopcouch (< 1.0) but 0.6.9b-0ubuntu1 is to be installed
python-desktopcouch-records : Conflicts: desktopcouch (< 1.0.7-0ubuntu2) but 0.6.9b-0ubuntu1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

View 5 Replies View Related

Debian :: Broken Packages / Dependencies

Aug 27, 2015

seems like after a recent upgrade of stretch, i get a message (in italian)

Code: Select all
$ sudo apt-get install kde-full
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:


View 2 Replies View Related

Debian :: Download Packages And Dependencies

Jun 15, 2010

I'm hitting my head against the wall trying to figure out (and find any information on) how to download a package and all its dependencies.I've tried to clean the cache,$ sudo apt-get clean and then download a package and its depednencies,but it doesn't download dependencies that are already installed.I need to do this to install a package on a machine that doesn't see the net.I remember doing this somehow ages ago, and I think I might have even combined the package and its dependencies into a single self-contained .deb using dpkg.

View 4 Replies View Related

Copyrights 2005-15 www.BigResource.com, All rights reserved