Ubuntu Installation :: Install Aptitude Using Apt-Get (Broken Packages)

Apr 23, 2011

I want to install aptitude using apt-get, but some problems happen like this:
The following packages have unmet dependencies:
aptitude : Depends: libapt-pkg-libc6.10-6-4.8
Depends: libept0 (>= 0.5.30) but it is not going to be installed
E: Broken packages
(before do this, I have used command apt-get update and apt-get upgrade)

View 6 Replies


Debian :: Force Aptitude To Ignore Broken Packages

Jul 26, 2010

I am just too tired and am missing something in the man pages for aptitude and not getting my search terms right but I can't seem to find a way to make aptitude ignore a couple of supposed broken packages (they work just fine by the way). The only way I can find to remidy the situation is to remove those couple of packages or upgrade several things to their Squeeze counter parts. I really don't want to try and do the upgrade as at home I am stuck on a 56k connection. Removing the broken packages I guess won't be too bad if I can find the debs again after I install a couple of things I want to add to my system. I would however just like to make aptitude ignore the state of my system and try to install what I want anyway.

View 14 Replies View Related

Ubuntu Installation :: Updater Says Error 'Fix Broken Packages First' But No Broken Packages

Apr 24, 2010

I've been trying to fix this problem for quite a few days now and have done a lot of searching on these forums, Linux Mint Forums and some others Google lead me to and have has some success, but am now stuck.I have posted a thread on this same topic on the Linux Mint Forums, but have had no success (if you want check it out at:URL...Originally I received error messages when trying to update involving certain repositories which couldn't be accessed (because they either didn't exist or had been moved) and I hunted these down and changed or removed them.

I have done much searching, etc. and cannot find any broken packages. I have tried many many different commands which have mostly done nothing.I seem to be in a similar boat to this person: URL...

View 2 Replies View Related

Debian Installation :: Aptitude Update And Aptitude Install Aptitude?

Jul 11, 2010

I am trying to upgrade an amd64 lenny system to squeeze.I've got a 2.6.32 kernel running, done aptitude update and aptitude install aptitude.When I try "aptitude safe-upgrade", it sits forever resolving dependencies.it seems to search with the resolver counting up more and more open/conflict/ whatever.I stopped it once it got over 100,000)Is it possible to get aptitude to do a safe-upgrade, perhaps using a command line option?

View 2 Replies View Related

Ubuntu :: Aptitude Install Attempts To Remove Core Packages

Aug 6, 2010

Im having an issue with sudo aptitude install. If i attempt to install anything, it says it will remove all of the packages below. On the other hand,if i use the Synaptic Package Manager, it doesn't remove any packages what is going on here? Any ideas? I have added some karmic repositories, but i dont think that should do anything?

sudo aptitude install libossp-uuid-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done


View 4 Replies View Related

Ubuntu Installation :: Aptitude Wants To Remove Many Packages Post Upgrade

May 13, 2010

Using Xubuntu,I have upgraded from Karmic to Lucid. Post upgrading when attempting to install a new package with aptitude, it is reported that cups is "BROKEN" and a host of packages are marked for removal.

View 1 Replies View Related

Debian Hardware :: Aptitude Install Libgl1-mesa-dri / Removes A Lot Of Packages?

May 17, 2011

Can anyone explain why aptitude install libgl1-mesa-dri actually removes a lot of packages? I just ran it without checking and the job was done...

aptitude install libgl1-mesa-dri
The following packages will be REMOVED:
bsh{u} bsh-gcj{u} gcj-4.4-jre{u} gcj-jre{u} libcolamd2.7.1{u}
libcommons-beanutils-java{u} libcommons-collections3-java{u}
libcommons-compress-java{u} libcommons-digester-java{u}
libcommons-logging-java{u} libdb-je-java{u} libdb4.7-java{u}
libdb4.7-java-gcj{u} libgcj10-awt{u} libgraphite3{u} libhsqldb-java{u}

View 1 Replies View Related

Debian Installation :: Packages (Security Sensitive) In Aptitude Safe Upgrade?

Feb 17, 2011

Today I ran
aptitude update && aptitude safe-upgrade
Like I regularly do, and I see these two packages need to be upgraded:
login passwd

Since these packages seem kinda security-sensitive I would like to know exactly why I would need to upgrade them. I checked Debian's security list but couldn't find anything relevant, and the links to the changelog for both packages are broken:
The requested URL /changelogs/pool/main/s/shadow/shadow_4.1.4.2+svn3283-2+squeeze1/changelog was not found on this server.
Where can I see what is changed in these packages so I can safely upgrade?

View 3 Replies View Related

Ubuntu Installation :: How To Fix Broken Packages

Apr 11, 2010

I have a broken package and can't seem to fix it. Now, nothing can be downloaded from synaptic. I get the following error message:

Processing triggers for software-center Setting up courier-mta (0.61.2-lubuntu3) * Starting Courier mail server. Starting Courier mail server. invoke-rc.d: initscript courier-mta, action "start" failed. dpkg: error processing courier-mta (--configure): subprocess installed post-installation script returned error exit status 1 Errors were encountered while processing: courier-mta E: Sub-process /usr/bin/dpkg returned an error code (1) How do I fix this?

View 1 Replies View Related

Ubuntu Installation :: Can't Fix Broken Packages?

Dec 13, 2010

I am trying run an update but I get an error "Fix broken package first".I then went into synaptic and fixed the broken packages and tried to the update but I had the same problem still.

View 9 Replies View Related

Ubuntu Installation :: Broken Packages In Synaptic

May 7, 2010

During my recent upgrade from 8.04 to 10.04, I got a few error messages concerning the flashplugin-nonfree not installing correctly. A user named carlee helped me get flash working over on the absolute beginner forum, but I've got a related problem still unresolved.Update manager is convinced that my perfectly working flash installation is broken, and insists I update it.However, the update fails every time, telling me E: flashplugin-nonfree: Package is in a very bad inconsistent state - you should reinstall it before attempting a removal.

Opening synaptic, I cannot select the reinstall option for the plugin. Removal and complete removal are my only options, and both give the above error. More problematic, I cannot de-select the flash plugin entirely. It MUST be part of any other package update through synaptic (if I wanted to re-install avant window navigator, for example). And since the flash removal operation fails, synaptic is effectively non-operational.How can I convince my update manager that my fully operational flash is just fine the way it is?

View 5 Replies View Related

Ubuntu Installation :: 10.04 Upgrade - Some Packages Are Broken

May 16, 2010

Am trying to upgrade from karmic 9.1 to lucid 10.04 and have the problem that as part of the upgrade I get a report that some packages are broken. As suggested posting the relevant files APT and MAIN Logs from the /var/log/dist-upgrade below.

View 4 Replies View Related

Ubuntu :: Install My ATI Propertary Driver - Held Broken Packages

Jan 17, 2011

I tried to install my ATI propertary driver and it says

E:Unable to correct problems, you have held broken packages

I have held broken packages and it wont download/install the driver :S what should i do?

I have had a similar problem before i think, also when i used peppermint i couldnt install my driver, but forget it i like ubuntu the best....could this happen because i clicked skip during some parts of the installation of ubuntu?

View 3 Replies View Related

Ubuntu Installation :: Can't Remove Broken Sun-java6 Packages

Mar 22, 2010

I installed java and my computer went off in the middle of the process and some packages didn't install correctly. I decided to reinstall them but it doesn't let me. I have tried to remove them using the synaptic manager, I also tried to remove them manually. I've tried: apt-get -f install also. I tried to re-install it using:

sudo apt-get install sun-java6-jre sun-java6-plugin sun-java6-fonts

but this error comes up

Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

View 7 Replies View Related

Ubuntu Multimedia :: Sopcast Installation Broken Packages?

Aug 23, 2010

I am tried to install Sopcast for Ubuntu Netbook remix but keep being told I have broken packages but I can't find any in synaptic or ubuntu tweak. I think I had a failed install before I found the frontend package on ubuntu tweak but I cannot find where the problem is.

I am running ubuntu on an Acer Aspire One as my sole operating system.

View 1 Replies View Related

Ubuntu Installation :: 10.04 To 10.10 Upgrade - Xorg Broken Packages

Oct 12, 2010

Here is the apt.log from running 'do-release-upgrade'. apt-get upgrade runs without issue and I have disabled all of the extra repos I had (opera, tor, lucid-propsed, chromium). My system is otherwise 100% up to date with apt-get dist-upgrade and apt-get upgrade. I have already purged all of my PPAs using 'ppa-purge', but it looks like there are remnants of xorg-edgers in there somewhere: [URL]

View 4 Replies View Related

Ubuntu Installation :: Broken Packages When Updating, Or Installing Anything?

Jan 7, 2011

When I try to update my packages, or install new packages, I get this error:"E: /var/cache/apt/archives/libglib2.0-0_2.26.1-0ubuntu1_amd64.deb: subprocess new post-removal script returned error exit status 1"I tried the "sudo apt-get install -f" but it didn't work.I'm running 10.10, on a Asus laptop

View 3 Replies View Related

Ubuntu Installation :: OpenOffice And QuickStarter - Broken Packages

Feb 5, 2011

Update Manager tells me it has updates. So I close what I am doing with VirtualBox and a Windows Client and I tell the Update Manager to go ahead. But it stops, says I've got OpenOffice and QuickStarter both running. Not so, at last not to my knowledge. I try again, and it tells me I have a broken package, and to use the 'Broken' filter to find it. Where is the 'Broken' filter? And even if I work that out, what should I do about a "broken" package? So I look online. Only references to "Broken" packages are with respect to Windows. Windows is a shut down client, and VirtualBox has been shut down.

So I try the recovery mode on a reboot. This reports I have 15 broken packages, all to do with OpenOffice. I select Fix Broken Packages, and it keep stopping to tell me that OpenOffice and QuickStarter are both running, and I need to deal with that. How? A restart and effort to fix broken packages did no good. I look online again, and this time I run down where someone writes you can follow a link, and what you get there will do the trick. Only the link goes nowhere, so it has been moved or deleted.

View 2 Replies View Related

Ubuntu Installation :: Could Not Determine The Upgrade/broken Packages?

Feb 27, 2011

I have been upgrading 10.4 to 10.10, but in the middle of the new package download my computer turned off (outage). Now Ubuntu won't restart the upgrade or install the packages already downloaded; it tells me it "Could not determine the upgrade" and that unresolvable problems occurred, caused by held packages. How can I reset things to restart the upgrade?

View 4 Replies View Related

Ubuntu Installation :: Broken Packages Required For Upgrade?

Mar 21, 2011

I keep on getting this red " - " icon on my panel and I try to perform the upgrade it prompts me to do. But it says that there are 3 broken packages i need to fix with the "broken filter". How do I fix this so I can upgrade?

View 2 Replies View Related

Ubuntu Installation :: Remove Broken Packages Only Without Affecting Others?

Jun 3, 2011

I was installing some packages using the generate download script in synaptic and 'sudo dpkg -i -R ...' because I don't have my own internet connection at home but somewhere else. I think I got carried away a little and installed some packages that have some dependency issues. Now I have three broken packages that need to be removed, but I don't want them to affect (remove) other packages which would be marked whenever I try to mark them for removal, for fear that their removal might affect other functions. I think my machine was just fine before I started to fumble with individual dependencies; that's why I don't what the other dependencies removed. My question is how do I remove those dependencies only using the terminal without removing the others?

View 3 Replies View Related

General :: Tell Aptitude To Ignore Broken Package?

Jan 13, 2010

I installed a Amsynth from Lucid in Karmic using:

dpkg --force-depends-version -i amsynth_1.2.2-1_i386.deb

The reason for installing the Lucid version is because Karmic version is 3 years old and crashes on my machine. The Lucid Amsynth package depends on newer versions of libatk1 and libjack0 than Karmic has, but I thought I would take a risk, and turns out Amsynth runs fine. However aptitude tries to uninstall Amsynth every time I do an upgrade. I think I've managed to put it on hold but now aptitude aborts. How can I tell aptitude to ignore the broken package and carry on.

View 3 Replies View Related

Ubuntu Installation :: Error When Upgrading - You Have Held Broken Packages

May 10, 2010

I tried to upgrade to 10.04, but did not succeed. Error: You have held broken packages.

View 2 Replies View Related

Debian :: Proftpd Install - Unmet Dependencies And Broken Packages

Oct 23, 2015

I am attempting to setup an ftp server as a first project to get me going in the world of Linux however when I run the command apt-get install proftpd-basic ....

View 14 Replies View Related

Debian Multimedia :: Install Gnome On Testing - Broken Packages

Sep 12, 2015

I'm on Debian testing and every time I try to install Gnome I get this:

Code: Select all# alexandernst at stupidbox in ~ [18:51:07]
$ LC_ALL=C sudo tasksel install gnome-desktop --new-install
tasksel: apt-get failed (100)

I tried installing it manually:

Code: Select all# alexandernst at stupidbox in ~ [18:51:35]
$ LC_ALL=C sudo apt-get install gnome                     
Reading package lists... Done
Building dependency tree       
Reading state information... Done

[Code] ....

Is this a problem in Debian repos (held packages) or I'm actually doing something wrong?

View 13 Replies View Related

Debian Installation :: Mixed Wheezy With Sid Now Have Broken Packages

May 6, 2015

Without knowing the consequences I added the Sid repository to Wheezy (installed version) in order to install some software. Only much later I discovered that this generated me some mess which does not allow now to install additional software due to library conflicts.

I tried to install some packages needed to build the PhantomJS but here is what I got:

Code: Select allReading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version.
g++ is already the newest version.
g++ set to manually installed.

[Code] ....

Is there a way to clean up the mess that Sid introduced and revert back to the Wheezy versions?

I have an old backup, so it would take me much more time to reinstall/reconfigure certain software, so I am looking to alternatives.

Is there a way to check all the packages and find all the potential conflicts and then a way to restore the original Wheezy content?

View 1 Replies View Related

Ubuntu :: Aptitude Forget New Packages?

Mar 11, 2011

Manual says: Forgets all internal information about what packages are �new�

What does it mean in plain English?

View 2 Replies View Related

Ubuntu :: Use Apt-get Or Aptitude To Tell Me What Updated Packages Are Available

May 25, 2011

How do I use apt-get or aptitude to tell me what updated packages are available for my system? I'm moving over from Gentoo where I had a cron job that would run a command whose output was a list of available updates. I had this and other system related info emailed to me. I'd like to duplicate that under Ubuntu, but I can't find a way get the available updates.

View 2 Replies View Related

Debian :: Aptitude Packages Not Listed?

Mar 6, 2016

How to find packages with aptitude. If I use the shell to type "aptitude search nethack" then I get a list of several nethack versions from which to choose. If I use the aptitude GUI and type Ctrl-T and then arrow over to the search option and type in "nethack" and hit Enter, the only option that I see is nethack-spoilers. Why do I not see all of the other nethack options?

View 2 Replies View Related

Software :: Force Synaptic/update Manager/aptitude To Accept A Broken Package?

Nov 9, 2010

I forced the install of graph-tool package [URL]. Now it is of course tagged as broken, so update manager wont do anything. But I want to accept it, I know it is not really broken. (In fact, graph-tool_xxx.deb asks for libcgal4. squeeze only has libcgal5, so I am betting this is not an issue, as far as graph-tool is concerned.)

View 2 Replies View Related

Copyrights 2005-15 www.BigResource.com, All rights reserved