Software :: Glib For GStreamer For Banshee Installation / Upgrade

Oct 9, 2010

I'm running Oracle Enterprise Linux 5.5 . I tried to compile banshee from source, which required gstreamer, which required glib >= 2.20. Of that, my system has glib 2.12.3. So I downloaded the source for glib 2.24.2 and I ran the ./configure, make and make install which seemed to run without issue. When I tried to run ./configure on gstreamer 0.10.30 after installing glib 2.24.2, however, it told me that my glib was 2.12.3. So I ran configure, make, and make install on glib 2.24.2 once again, rebooted, and then tried to configure gstreamer 0.10.30.

It still told me that my glib was not sufficient.
(configure: Requested 'glib-2.0 >= 2.20' but version of GLib is 2.12.3:
configure: error: This package requires GLib >= 2.20 to compile.)
I am doing all this in a terminal window, having SU'ed to root. So I'm lost. Any solution other than ditching OEL in favor of another distro?

View 2 Replies


Fedora :: GStreamer Base Plugins Install Needs Glib 2.20

Aug 3, 2010

I want to install "gst-plugin-base" but i get this error: "this version of gst-plugin-base needs glib 2.20 but installed version of glib is 2.18". I installed glib 2.20 and now I'm trying to install gst-plugin-base but i get that error again.

View 9 Replies View Related

Ubuntu Installation :: No Sound With Gstreamer Applications After Upgrade?

May 14, 2010

I installed OSSv4 replacing the default ALSA and everything worked just fine with some workarounds... until I upgraded to Lucid Lynx. Now apps like Totem and Rhythmbox which use the gstreamer framework have no sound. Does anybody know why?

View 1 Replies View Related

Ubuntu :: GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: Ignoring No-arg, Optional-arg Or Filename Flags

Jun 15, 2011


(gimp:4216): GLib-WARNING **: /build/buildd/glib2.0-2.28.6/./glib/goption.c:2132: ignoring no-arg, optional-arg or filename flags ( on option of type 0
segmentation fault

gimp stopped working on kubuntu after installing updates, any fix?

View 9 Replies View Related

OpenSUSE :: Songbird Will Not Play Music / GStreamer Error: Internal GStreamer?

Apr 3, 2010

Error: GStreamer error: Internal GStreamer error: negotiation problem. Please file a bug at url. Additional information: gsturidecodebin.c(1563): setup_source (): /GstPlayBin2layer/GstURIDecodeBin:uridecodebin0:
Can't link source to decoder element

i get this error when i look in the error console

View 3 Replies View Related

Ubuntu Multimedia :: No Sound With Gstreamer Applications After Upgrade?

May 14, 2010

I installed OSSv4 replacing the default ALSA and everything worked just fine with some workarounds... until I upgraded to Lucid Lynx.

Now apps like Totem and Rhythmbox which use the gstreamer framework have no sound. Does anybody know why?

Everything else works, like gnome-sound-recorder, even flash.

View 1 Replies View Related

OpenSUSE Install :: Glib Error - GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: Assertion Failed

Mar 31, 2011

As root, type "zypper update" and get several lines of the following error:

GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error == NULL)
Loading repository data...
Reading installed packages...

Nothing to do. Used zypper dup to upgrade from 11.3. Still have boot problems (will open another thread), but had major problems upgrading timezone. File downloads would reach some percentage of completion, then B/s would slowly reduce, to zero. Upgrade would halt until manually aborted. Solution was to manually download 5 timezone files and install them in a directory repository. File download did not specify just the timezone file, but also a part of the directory. Could this be part of the problem? example: ./rpm/i586/timezone-2011d-0.2.1.i586.rpm instead of just the file name.System is a Dell 3000 (Pentium 4, 512MB memory).

View 5 Replies View Related

OpenSUSE :: How To Upgrade Banshee In 11.2

Jul 16, 2010

I am using Banshee 1.6 (beta 2) 1.5.1. I'm actually interested in is getting the Amazon mp3 extension to work, and I don't see this extension in my current version of Banshee. I tried to upgrade & ended up wiping my whole hard drive & had to re-install 11.2 but I'm sure that was my inexperience more than anything else.

I'm not sure of the proper procedure to upgrade any particular package on 11.2 actually. I just leave them alone & it works great. I could add the Banshee repo (which I have not done) but even if I uninstall 1.6 which I have now, and then re-install the newer app from the repo, it will not work. It says it installs properly (I know this from yesterday) but the program doesn't show up in the menu.

View 2 Replies View Related

Ubuntu :: GStreamer Error: Gstreamer Encountered A General Stream Error (not All Flacs)

Mar 29, 2011

I was trying to convert a flac audio to mp3 using soundconverter & its failing with the error:


GStreamer error: Gstreamer encountered a general stream error.

I should note that the flac is a rip of an actual Mono Vinyl disc. Am not exactly sure how that was done but I was interested in converting some those files to ogg & mp3. OGG conversion doesn't give any error.

Below is the result when launching soundconverter from the terminal & trying to convert the flac file(s) to mp3 (i just tried ogg to mp3 & the same error occurs):

$ soundconverter
SoundConverter 1.4.4
using Gstreamer version: 0.10.28, Python binding version: 0.10.18
using gio


View 6 Replies View Related

OpenSUSE :: Can't Start Banshee Application After Upgrade It

Sep 11, 2010

After I upgrade the Banshee to 1.7.5-91 version, I can't start it. When try to start it, the window of it appears and close immediately.

Following is information I run it from console:

[Info 18:48:29.169] Running Banshee 1.7.5: [Banshee / openSUSE_11.3 (linux-gnu, x86_64) @ 2010-09-07 20:06:10 UTC]
[Warn 18:48:31.955] Hardware manager extension failed to load - System.InvalidOperationException: Type 'Banshee.Hardware.Gio.HardwareManager' not found in add-in 'Banshee.Gio,1.0' (in `Mono.Addins')


View 3 Replies View Related

Ubuntu Multimedia :: Banshee Crashing On Start Since Upgrade?

May 6, 2011

Since upgrading to 11.04, Banshee crashes as soon as it's launched. When run in terminal, I get the following: Quote:

[Info 12:37:35.878] Running Banshee 2.0.0: [Ubuntu Natty (development branch) (linux-gnu, i686) @ 2011-04-18 16:21:33 UTC] [Warn 12:37:36.571] Could not migrate album artwork cache directory - System.IO.DirectoryNotFoundException: Directory 'file:/home/laurie/.cache/album-art/32' not found. (in `mscorlib') at System.IO.Directory.GetFileSystemEntries (System.String path, System.String searchPattern, FileAttributes mask, FileAttributes attrs) [0x00000] in <filename unknown>:0


View 6 Replies View Related

Programming :: GTK - GLIB Version Mismatch During Installation ATK?

Jul 28, 2010

I'm currently installing GTK+ under Fedora Core 13. Before you install GTK+ you have to install GLIB, Pango and ATK. When installing ATK it goes wrong. After giving the "./configure" I get following error:

checking for GLIB - version >= 2.0.0...
*** 'pkg-config --modversion glib-2.0' returned 2.25.8, but GLIB (2.24.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system


Apparently there is an old version of GLIB on my system bugging my installation process. Does anybody know how to get rid of this old version?

View 2 Replies View Related

Ubuntu Installation :: Glib-2.0 And PKG_CONFIG_PATH Environment Variables?

Jul 29, 2010

I'm trying to install the latest version of tracker - 0.8.15. When I run ./configure, I come up with an error like this:

checking for getline... yes
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for GLIB2... configure: error: Package requirements (glib-2.0 >= 2.24.0) were not met:
No package 'glib-2.0' found


Surely the libglib2.0-0 package is some kind of replacement for glib-2.0? My understanding from the man page is that PKG_CONFIG_PATH is some way of linking to and checking requested packages... is this right? Can I change it to point at the libglib package instead?

View 1 Replies View Related

Ubuntu Installation :: Evolution Errors 11.04 GLib-GObject-CRITICAL

Apr 29, 2011

Just upgraded to ubuntu natty and evolution hangs.

Receive the following errors.allen@FA2096349:~/.evolution$ evolution(evolution:25316): GLib-GObject-CRITICAL **: Object class EMFolderTree doesn't implement property 'paste-target-list' from interface 'ESelectable' (evolution:25316): GLib-GObject-CRITICAL **: Object class EMFolderTree doesn't implement property 'copy-target-list' from interface 'ESelectable'

The evolution app starts, but all you get is Loading... for the folders in the side bay and the app is hung. Nothing is selectable and you have to CTRL-C out of it or use the kill app.

View 3 Replies View Related

Fedora :: Your GStreamer Installation Is Missing Plugin

Aug 16, 2010

I installed an MP3 plugin, and tried to play a podcast on Rhythmbox, and was presented with an error message, which said: Your GStreamer installation is missing a plugin. How can I remedy this?

View 1 Replies View Related

Fedora Installation :: Which RPM Contains Gstreamer Audioconvert And Videoscale

Feb 14, 2011

which RPM contains Gstreamer audioconvert and videoscale?, I discovered the 'yum provides *videoscale*' command. Turned out to be gstreamer-plugins-base.

View 1 Replies View Related

Fedora Installation :: F15 Gstreamer Cannot Handle Xvid

May 31, 2011

I pre-upgraded a working F14 system which was reading MPEG4 xvid (xvidcore rpm). Since the upgrade gstreamer refuses to handle that stream: ** Message: don't know how to handle video/x-xvid.It seems the codec is not registered with gstreamer.

View 1 Replies View Related

Ubuntu Installation :: Configure: Error: You Must Have GLib 2.4.0 Or Newer Development Headers Installed To Build

Oct 9, 2010

I am trying to build Pidgin on my Lucid install and on running configure, I get the following:


configure: error: You must have GLib 2.4.0 or newer development headers installed to build.

If you have these installed already you may need to install pkg-config so I can find them. I tried installing pkg-config, but it's already in its newest version. I then tried going to the following website


and downloaded and extracted glib on my computer. That changed nothing. I was hoping someone could tell me what's going on here. I just tried the this:


sudo apt-get install libgtk2.0-0

and got


libgtk2.0-0 is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

View 8 Replies View Related

Ubuntu Installation :: Error - (process:325): GLib-WARNING **: Getpwuid_r(): Failed Due To Unknown User Id (0)

Apr 14, 2011

"(process:325): GLib-WARNING **: getpwuid_r(): failed due to unknown user id (0)"

It comes after choosing language, when the Ubuntu start-up logo shows with the 5 dut under it. I am trying to install Ubuntu Netbook on a little Compaq Mini.

View 1 Replies View Related

Ubuntu :: Installation - Warning (process 257): GLib-WARNING **: Getpwuid_(r) Failed Due To Unknown User Id (0)

Jul 6, 2010

i just tried to install Ubuntu Netbook 10.04 on my old Amilo Lifebook P Series. But after the boot screen and the choice to install Ubuntu i get stuck at the Ubuntu screen with the little dots on the bottom If I hit esc i can see the warning (process 257): GLib-WARNING **: getpwuid_(r) failed due to unknown user id (0)

View 2 Replies View Related

Ubuntu Installation :: Glib2 Depends On Gettext Which Depends On Glib 2

Jan 17, 2010

I'm trying to compile gettext 0.17 but it is dependent on glib2. the problem is that when i try to compile glib2 i get the error that says i must have gettext support in my c library or use the GNU gettext library. what should i do?

View 2 Replies View Related

Ubuntu :: Error. "your Gstreamer Installation Is Missing A Plug-in"

Apr 14, 2011

installed radio tray. entered url for radio station but getting error. "your gstreamer installation is missing a plug-in." How do I find out which plug-in?

View 4 Replies View Related

Fedora Installation :: Gstreamer Streaming Media Framework "ugly" Plug-ins?

Oct 25, 2009

I get the following message when I try to install the package:Gstreamer streaming media framework "ugly" plug-insPG key retrieval failed: [Errno 14] Could not open/read file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmfusion-free-fedora-11.92-x86_64I'm running the Fedora 12 beta.

View 14 Replies View Related

Fedora :: Use Rythmbox Id3 Demuxer Error "GStreamer Installation Is Missing A Plugin"

Jul 13, 2010

When I try to use Rythmbox, I got a message error saying that your "GStreamer installation is missing a plugin" and it says that is ID3 tag demuxer I already have this streamer plugins installed, so I don't know which one is missing


View 5 Replies View Related

Ubuntu Installation :: Upgrade From 10.04 To 10.10 Error "Could Not Calculate The Upgrade An Unresolvable Problem Occurred While Calculating The Upgrade"

Feb 12, 2011

I keep getting the following msg as I try to upgrade from 10.04 -> 10.10 ... "Could not calculate the upgrade An unresolvable problem occurred while calculating the upgrade: E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages. This can be caused by:

* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bug report." I don't think any of the issues above apply - can anyone offer advice on how to get around or "force " the upgrade

View 1 Replies View Related

Debian :: How To Update The Glib

Sep 1, 2010

Im running a stable lenny version and having a problem with mysql workbench. it needs newer libs. how do I install them ? Its a swedish system but I translated the first row.

mysql-workbench-oss is depending on libcairo2 (>= 1.7.2), but:
  Versionen av libcairo2 on systemet is 1.6.4-7.
mysql-workbench-oss beroende av libcairomm-1.0-1 (>= 1.6.4), men:
  Versionen av libcairomm-1.0-1 systemet 1.6.0-1.


View 5 Replies View Related

Ubuntu Servers :: What Is The Glib C

Mar 8, 2011

We are considering using Ubuntu server as a plat form for an erp software we are purchasing. The erp software company wants to know what the glib c is so that they can tell us if their sofware will work. Can anyone tell me what the glib c is? I have not downloaded it yet.

View 1 Replies View Related

Programming :: Looking For A C Programmer That Knows GTK/Glib?

Feb 28, 2011

I have posted this a couple of places - The Bodhi team and I are looking for some help from someone that knows their way around C and GTK/glib. Firstly - we are interested in having an extension written for the Midori webrowser that would allow it to open apt: protocol links with the command /usr/bin/apturl Second, I am interested in getting this and this added to the file manager PCManFM as features.

View 5 Replies View Related

Ubuntu Installation :: Upgrade Disaster - Warning "installation / Upgrade Should Not Be Interupted" - Computer Froze Up

Jun 1, 2010

While upgrading to a newer version of Ubuntu I noticed a warning saying that the installation/upgrade should not be interupted. Unfortunately though, during this process my computer froze up and I had to shut it down. Ubuntu no longer starts on my computer. I still have Windows though, which is what I'm using now.

View 3 Replies View Related

OpenSUSE :: 11.4: Zypper GLib-GIO:ERROR?

Apr 7, 2011

On my openSuSE 11.4 with GNome, zypper throws lots of errors when used on the command line.However, zypper does it's work correctly, but the error messages are annoying.Does anybody know what the problem is ?The error messages:

GLib-GIO:ERROR:gdbusconnection.c:2279:initable_init: assertion failed: (connection->initialization_error ==


View 6 Replies View Related

Copyrights 2005-15, All rights reserved