Slackware :: Error Compiling Php With Oci8 - Slackware64-13.37?

Jun 22, 2011

I tried to recompile php with support for oracle extensions oci8.so. Got the source and slackbuild script from slackware repo and just add the following line to the slackbuild script. "--with-oci8=shared,instantclient,/opt/instantclient_11_2". I use instant client from oracle Version 11.2.0.2.0 from this page

After I run the script I got this error message

Code:
/bin/sh /tmp/php-5.3.6/libtool --silent --preserve-dup-deps --mode=compile gcc -I/tmp/php-5.3.6/ext/fileinfo/libmagic -Iext/fileinfo/ -I/tmp/php-5.3.6/ext/fileinfo/ -DPHP_ATOM_INC -I/tmp/php-5.3.6/include -I/tmp/php-5.3.6/main -I/tmp/php-5.3.6 -I/tmp/php-5.3.6/ext/date/lib -I/tmp/php-5.3.6/ext/ereg/regex -I/usr/include/libxml2 -I/usr/include/enchant -I/usr/include/freetype2 -
code....

View 1 Replies


ADVERTISEMENT

Slackware :: Compiling 32 Bit On Slackware64?

May 19, 2010

I have a need to recompile mesa. The --enable-32-bit option falls over every header and basic 32 bit lib, and won't compile. But if I try to install 32 bit packages, I could slap a 32 bit binary straight on top of my 64 bit one. What's the accepted way of doing this? I can't seem to find a package in Slackware 13.0

View 9 Replies View Related

General :: Compiling Oci8 And Php 5.3.6 / Make Use Of Oracle-xe 10g?

Jul 14, 2011

How do I compile oci8 and php 5.3.6 in centos 5.5, I want to make use of oracle-xe 10g

View 1 Replies View Related

Slackware :: Error Compiling Apache Fop- 1.0 On 64 13.1

Mar 26, 2011

I em trying to compile fop-1.0 on Slackware64 13.1. I have ant 1.8.1 Slackware package.

Here is the output of ant build:

Code:

View 2 Replies View Related

Slackware :: Error Compiling Squidguard-1.4

Mar 27, 2011

I'm trying to install squidGuard-1.4, I have a minimal install. I have installed squid-3.2.0.5 without any problems, but squidGuard is driving me crazy

I can run the ./configure with no problems but when I run make, or make install I keep getting this error:

Code:
make: *** [y.tab.c] Error 141
And that is is all, no more verbosity or anything else.
Error suggests that YACC is missing but bison is present, also db4 (tried with db44 and db3, same story).

Just in case you can see anything I cannot I've attached the config.log

View 2 Replies View Related

General :: Php-oci8 Installation / Error: Failed Dependencies?

Dec 13, 2010

i am having a issue installing php-oci8. I am using a cesntos 5.5 OS

when i try installing php-oci8 i get this error
[root@web8 tmp]# rpm -ivh php-oci8-5.2.14-1.el5.remi.x86_64.rpm
warning: php-oci8-5.2.14-1.el5.remi.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 00f97f56
error: Failed dependencies:
php-common = 5.2.14-1.el5.remi is needed by php-oci8-5.2.14-1.el5.remi.x86_64

so then i checked whether i have php-common 5.2.14 installed it yielded this result

[root@web8 tmp]# rpm -qa php-common
php-common-5.2.14-jason.1

i dont understand why php-oci is not getting installed even though php-common is present.

View 1 Replies View Related

Slackware :: Error Compiling Virtualbox 3.2.10 On Current?

Dec 7, 2010

I'm trying to compile virtualbox 3.2.10 con slackware current 32bit through sbopkg

I get this error (I'll copy only the end part)

Code:
CXX VMMR3 - {C}/src/VBox/VMM/VMMAll/TMAllCpu.cpp
cc1plus: warnings being treated as errors
In file included from /tmp/SBo/VirtualBox-3.2.10_OSE/src/VBox/VMM/VMMAll/PGMAll.cpp:236:0:

[Code].....

View 4 Replies View Related

Slackware :: Error Compiling Blood Frontier Using Sbopkg?

Mar 8, 2010

I'm having a problem compiling Blood Frontier on Slackware64-current. I believe this problem is also related to why I can't use make xconfig as well. Here is a bit of the error.

Code:
g++ -O2 -fPIC -Wall -fsigned-char -DINTERFACE -DIRC -Ishared -Iengine -Igame -Ienet/include -I/usr/X11R6/include `sdl-config --cflags` -o shared/cube.h.gch.tmp shared/cube.h

[code]....

View 6 Replies View Related

Slackware :: Weird Error Compiling Enlightenment Slackbuild?

Jul 7, 2011

Been trying to get Enlightenment to install on my 13.37 multilib. Used sbo to install most of the libraries (ecore needed the LDFLAGS="-L/usr/lib${LIBDIRSUFFIX}" fix so I manually did that). All installed correctly. Then started enlightenment itself in sbopkg. It did the 'file in wrong format' thing, so I manually dled the slackbuild, added the LDFLAGS line, and ran it. It produced this error, and I have no idea what its telling me.

Code:
checking how to recognize dependent libraries... pass_all
checking for ar... ar
checking for strip... strip
checking for ranlib... ranlib
checking command to parse /usr/bin/nm -B output from gcc -std=gnu99 object... ok

[Code]...

View 9 Replies View Related

Slackware :: Pdfedit Compiling Since SlackBuild - Configure: Error: QTDIR Environment Variable Must Be Set

Dec 16, 2010

When I do #./pdfedit.SlackBuil I get the information in the terminal:

[Code]...

Whether we want to checking PDFedit prepare-core-dev package ... yes Whether we want to checking build PDFedit gui ... yes configure: error: QTDIR environment variable must Be Set

View 3 Replies View Related

Slackware :: Compiling Large Slackbuilds - Error-message - Not Enough Space Left On Device

Aug 20, 2010

I am currently running slackware 12.2 on a 25 GB partition. I like to use slackbuilds, but when I try to compile larger tarballs (like abiword, or a patched version of Ghostscript as I did today) I receive an error-message: 'Not enough space left on device'. I think the size of the partition must be big enough (I never got this message when compiling with Linux From Scratch). I think it has something to do with the size of my /tmp directory, but I don't know how to fix this. Is there a way to solve the problem, so that I could be able to use slackbuild-scripts?

View 4 Replies View Related

Slackware :: Libmp4v2-v1.5.0.2 In Slackware64-current?

Feb 13, 2010

I am having a hard time compiling libmp4v2-1.5.0.2 in slackware64-current. It always fails with:

PHP Code:

make[2]: *** [rtphint.lo] Error 1make[2]: Leaving directory `/home/Downloads/libmp4v2-1.5.0.1'make[1]: *** [all-recursive] Error 1make[1]: Leaving directory `/home/Downloads/libmp4v2-1.5.0.1make: *** [all] Error 2 

View 5 Replies View Related

Slackware :: Slackbuild For Netbeans 6.8 For Slackware64?

Apr 18, 2010

Anyone knows a slackbuild for netbeans 6.8 for slackware64?

View 5 Replies View Related

Slackware :: Does Font Rendering In Slackware64 13.37 Look Bad?

Apr 29, 2011

Is it just me or does the font rendering in Slackware64 13.37 look bad? It reminds me of the bad old days of having to recompile freetype with the then-patent-encumbered option to make the fonts look decent. When I print, everything looks normal. On screen it doesn't look right. I don't really know how to describe it other than it how things used to change after a freetype recompile. Is there anything major that changed between 13.1 and 13.37 WRT fonts in KDE, X, or freetype for that matter? FWIW, I did a clean install with a new .kde instead of using the old one.

View 14 Replies View Related

Slackware :: Slackware64 -current No Sound?

Mar 7, 2010

after this bug update, my laptop loose the sound, I have run alsaconf and nothing.If I run rc.alsa I get:Quote:Loading ALSA mixer settings: /usr/sbin/alsactl restore
/usr/sbin/alsactl: load_state:1608: No soundcards found...

View 1 Replies View Related

Slackware :: Slackware64 Won't Boot / Solve This?

Feb 20, 2011

I've tried reinstalling Slackware64 13.1 to my PC a number of times over the past couple of days and I still have not been able to get it to boot.

Once it's installed I reboot and it tells me it can't find the operating system.

I've tried fdisk, cfdisk and GParted to set up the disk by deleting partitions and recreating them.

When I install and get to the section about installing LILO it says I have an OS/2 or Partition Magic boot manager on the drive, but there isn't. It asks if I want to install LILO in a compatible way with the boot manager and I say no, and install to the MBR. When I reboot it says it can't find the OS.

When I try to boot from the install DVD and get to the boot: prompt, I'll enter /dev/sda1 and it says there is no kernel.

Is there something else I'm missing?

View 1 Replies View Related

Slackware :: Usbboot.img On Slackware64-current?

Apr 23, 2011

Regarding the latest update to -current, I decided to test installing it on a laptop from a usb stick (as I've done may times before). However this time the usb stick fails to boot as usual, hanging with the message "Could not find kernel image: linux". This isn't a problem with the usb stick, since if you mount the usbboot.img file as a loop device there is only 1 file on there, "ldlinux.sys", where you would usually find huge.s, initrd.img etc.

Have tried the 64-bit usbboot.img file from a couple of different mirrors and the result is the same. Have also looked in the usbboot.img from the 32-bit -current... this shows the usual set of files so looks to be OK.

View 6 Replies View Related

Slackware :: Can't Compile Tolua++ In Slackware64-current

Mar 22, 2010

I'm trying to compile tolua++ so that i can use lua in conky 1.7.2, however I am running into a problem. tolua++ defaults to looking for lua 5.0 libraries and I have lua 5.1 installed since that is what conky requires. According to the README tolua++ can use lua-5.1 but I not sure how to configure tulua++ to use those libraries since it uses scons. Here is a what the README says...

Compiling for lua 5.1

Starting from version 1.0.8pre1, tolua++ can be compiled with both lua 5.0 and
5.1. Both versions will output the same code, and the C API (tolua++.h) is the
same.

The build system is not yet ready to detect/decide when to compile for 5.1,
the easiest way right now is to add a file called 'custom.py' on the root of
the package, with the following:

## BEGIN custom.py
CCFLAGS = ['-I/usr/local/include/lua5.1', '-O2', '-ansi']
LIBPATH = ['/usr/local/lib']
LIBS = ['lua5.1', 'dl', 'm']
tolua_bin = 'tolua++5.1'

[Code]....

View 1 Replies View Related

Slackware :: Keeping Slackware64 Multilib Updated

Jul 19, 2010

I'm going to install Slackware 13.1 soon and I may also install the 32-bit compatibility libraries from Eric (Alien BoB).I'd like confirmation on the process of updating multilib Slackware when there's a security patch. I'm talking about running the -stable branch, by the way.Under the normal methods of updating (e.g. 'slackpkg upgrade-all' or using the script I developed to download a local mirror of the patches directory and install from there, or even doing it by hand), the regular 64-bit packages will get updated.However, the 32-bit compatibility versions of those files won't get updated. Right?So I'll need to download the new 32-bit patches, run the convertpkg-compat32 script on them, and then upgradepkg the new files.

View 8 Replies View Related

Slackware :: Slackware64 13.1: Odd Values In /usr/lib64/tclConfig.sh

Jul 14, 2010

While trying to compile itcl, one of the error messages caused me to look inside /usr/lib64/tclConfig.sh. I found many paths that were in /tmp, such as...

Code:

# String to pass to linker to pick up the Tcl library from its
# build directory.
TCL_BUILD_LIB_SPEC='-L/tmp/tcl8.5.8/unix -ltcl8.5'

[code]....

View 4 Replies View Related

Slackware :: Slackware64-current Don't Work Pm-suspend

Feb 27, 2010

after search and look at in vcar/log/pm-suspend.log I changed and quoted line to /usr/lib64/pm-utils/sleep.d/00logging who are reference to command free

[Code].....

View 4 Replies View Related

Slackware :: Another Laptop About To Loose Virginity To Slackware64 -current?

Mar 20, 2010

Just got a new toy!

Quote:

Compaq/HP CQ60-615DX Notebook @Best Buy $369.00

Intel Celeron 900 (2.2Ghz)
250GB(7200rpm) HDD
2GB DDR2 SDRAM
8x DVD +/- R/RW Double layer
Win7 Home Premium (for the time being)

[Code]...

I will keep Win7 for clients as this will be another laptop for that usage plus wanting to have a decent laptop for the rec room to do that style of work. Cheap way to service M$ clients without buying more personal license(s). So far no big deal with M$ Win7 but I need to have that pathway available to me.

My reason to buy this notebook rather then a netbook should be obvious, big enough for me to do what is necessary. I've got test beds to do the real work, netbooks just won't meet the needs as describe above. I purchased a Netbook for my wife. That one will be used while she's away to aid with the new Grandchild, a lot easier to carry than her old HP Laptop. If the Netbook is lost then no worry since it's cheaper than her HP.

View 3 Replies View Related

Slackware :: Rrdtool Configure Script Failure Slackware64-13?

Mar 25, 2010

I am having a problem trying to compile rrdtool on slackware64-13. The problem is that the configure script keeps failing when it gets to the third party checks:

Quote:
configure:30114: WARNING: * I found a copy of pkgconfig, but there is no pangocairo.pc file around. You may want to set the PKG_CONFIG_PATH variable to point to its

[Code]...

View 5 Replies View Related

Slackware :: Slackware64-13.1: A Minimal Multilib For Skype Required?

Nov 26, 2010

I am running Slackware64-13.1 on my laptop. I need to install skype on it. Searching this forum suggests that I install Alien Bob's multilib [URL] However, skype is the only 32-bit package I need and I will not need to compile any 32-bit software. So what is the minimal multilib install (the minimal set of 32-bit libraries) that make it possible for the 32-bit Skype to run on a 64-bit system? Will running

Code:

ldd /usr/bin/skype

on my 32-bit desktop machine provide me that minimal list of 32-bit packages? Also, will the installation of these libraries somehow interefere with the original 64-bit system?

View 2 Replies View Related

Slackware :: Slackware64 13.37 And ATI Radeon XPRESS 200M 5955

May 17, 2011

I've got an older HP Pavilion dv8000 laptop with ATI Radeon XPRESS 200M 5955 video. This worked fine out-of-the-box with 13.1. With 13.37 I can't get KDE desktop effects to work, glxgears reports about 50 fps, and the system can suspend but not resume. I have no xorg.conf at all. Here is the glxinfo and current Xorg log. Just to note, this is with Slackware64 13.37 with the multilib stuff installed.

View 4 Replies View Related

Slackware :: [slackware64-current] Cfdisk Setting Partition Type?

Jan 28, 2011

I've just synchronized my slackware64-current mirror, iso burned, booting, starting cfdisk, creating a partition, and I'm not able to set the partition type to `Linux Raid Autodetect` (FD) or any other, that needs 2 characters to be entered in cfdisk -> Type.Cfdisk alows only one character to be entered ("F" or any other).

View 3 Replies View Related

Slackware :: Hack A Slackbuild Of A Cmake Project To Comply With Slackware64?

Jan 13, 2010

There is this slackbuild in which I have changed the part in bold.

Code:
#!/bin/sh
# Packager GioPower, luca.gio.85~at~gmail~dot~com
# VTK (Visualization Toolkit)
#
# The Visualization Toolkit (VTK) is an open-source, freely available

[Code]...

This will still drop stuff into /usr/lib, which is clearly anti Slackware64... I do not know enough of cmake builds, which flag do I have to pass in the slackbuild for cmake to drop stuff in /usr/lib64...?

View 2 Replies View Related

Slackware :: Get Kmymoney Working With HBCI Support On Slackware64-13.37 System?

May 8, 2011

I am trying to get Kmymoney working with HBCI support on my Slackware64-13.37 system. My understanding is, that there are three dependencies for Kmymoney 4.5.3:

AqBanking 5.0.5
Gwenhyfwar 4.0.9
KMyMoney Plugin (kmm_kbanking) 1.0

I used to believe, that the plugin wasn't needed anymore in recent version of KMyMoney, but it seems, that I was wrong. With src2pkg I was able to compile AqBanking and Gwenhyfwar:

Code:

# src2pkg -e
'--with-openssl-includes=/usr/include
--with-openssl-libs=/usr/lib64
--with-qt4-includes=/usr/lib64/qt/include
--with-qt4-libs=/usr/lib64/qt/lib'

Then I used the SlackBuild script from SlackBuilds.org, modified the version to 4.5.3 and started it with ARCH=x86_64. Compilation ran through smooth, and I installed the package. However, HBCI support is disabled.
After some web research I came to the conclusion, that the KBanking module is still needed. So I grabbed it from the original source. Unfortunately I can't properly compile this one. Although I installed KDE3 and Qt3 compatibility packages from Slackware64-13.1 I get:

Code:

checking for Qt... configure:
error: Qt (>= Qt 3.2 and < 4.0)
(headers and libraries) not found.
check your installation!

Has anyone managed to get through the whole process and to activate HBCI support in KMyMoney?

View 2 Replies View Related

Slackware :: Qemu And Slackware64-current Windows 98SE As A Guest?

Apr 15, 2011

I used qemu (qemu-0.9.1-i386-2_SBo) with Windows98SE as a guest, but since the last Slackware-current update of this version of qemu no longer works ...more precisely after "Mon Apr 8 06:58:48 UTC 2011" Update

Then installed the version "qemu-0.12.5.tar.gz" of Slackbuils, but this If the mouse is not detected in Windows 98 I also installed the version of the Alien "qemu-0.10.0-i486-1alien" without success Windows 98SE worked very well with the version of qemu-0.9.1-i386-2_SBo!I know the mouse is not detectable in Windows 98SE is a Bug [URL].. ps: I also have not had success in Slack 32. I use on a daily 64-bit version of Slackware .

View 14 Replies View Related

Slackware :: Slackware64-13.0 Multilib Can Not Build Valid Initrd For Kernels 2.6.30

Feb 27, 2010

I've just installed a Slackware64-13.0 test machine with alienBOB's multilib packages. I'm running the stock kernel generic-2.6.29.6 with an initrd set up using mkinitrd.confEverything is fine except that I cannot build a right initrd for kernels 2.6.30, both the /testing one or a custom build: if I try, it will panic at boot with the "couldn't find a valid RAM disk image" error.On the same hardware, without multilib support, I was able to correctly build and boot 2.6.30 initrds.

View 11 Replies View Related







Copyrights 2005-15 www.BigResource.com, All rights reserved