Red Hat / Fedora :: Yum Install Git - Perl Error For Package

Dec 16, 2010

I've used yum (and rpm) for some time now, and have finally run into one of those dependency problem. I am trying to install git (among other programs), and I have reach an empass. Nothing I've tried has worked, and I just know there is a simple solution to this that I just don't know. It all started by skipping a dependency in the past (don't remember the package). I figured there would be something to clean that up, so I just continued.

Here is my output:
Code: # yum install git
Loaded plugins: fastestmirror, langpacks, presto, refresh-packagekit, security
Adding en_US to language list
Loading mirror speeds from cached hostfile
Excluding mirror: ftp-stud.fht-esslingen.de
Excluding mirror: wftp.tu-chemnitz.de
* livna: rpm.livna.org
* rpmfusion-free: mirror.hiwaay.net .....
--> Processing Dependency: perl(Error) for package: perl-Git-1.7.3.3-1.fc14.noarch
--> Finished Dependency Resolution
Error: Package: perl-Git-1.7.3.3-1.fc14.noarch (updates)
Requires: perl(Error)
Error: Package: git-1.7.3.3-1.fc14.i686 (updates)
Requires: perl(Error)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

If I need to, I could go and download the RPM package and install it that way, but I'd like to get YUM back working properly.

View 7 Replies


ADVERTISEMENT

Fedora Networking :: /usr/bin/perl: Symbol Lookup Error: /usr/bin/perl: Undefined Symbol: PL_use_safe_putenv

Apr 8, 2009

I am trying to setup the wlan access for my Fedora 9 system. I installed ndiswrapper. But when I run

Code:

ndiswrapper -l

i am getting the error

Code:

/usr/bin/perl: symbol lookup error: /usr/bin/perl: undefined symbol: PL_use_safe_putenv

View 11 Replies View Related

Ubuntu Servers :: Libnetpacket-perl Package For 9.10 Karmic - Functionality Present In Another 9.10 Package With A Different Name?

Jan 8, 2010

I need to install the following dependencies for synspam on Ubuntu 9.10 karmic server:

Code:
sudo aptitude install nfqueue-bindings-perl libsys-syslog-perl libappconfig-perl libnetpacket-perl libnetaddr-ip-perl
dpkg -i synspam_version_all.deb
Of these, only libnetpacket-perl is not packaged for Ubuntu 9.10 karmic.

Is this functionality present in another 9.10 package with a different name? 10.04 Lucid does have the package: [URL]

View 1 Replies View Related

Fedora :: Yum Installer - To Install A New Package - Gets Error

Nov 5, 2009

I have a problem with yum installer every time i want to install a new package it gets error:

View 2 Replies View Related

Fedora Installation :: Error "no Package Matched To Install"

Mar 11, 2009

i accidentally pulled the power while an upgrade was going on. I felt bad, so went to do "yum-complete-transaction" only it was going to remove my entire system. Bad idea. So, instead, I tried to do yum update on my own. Well, it says that i need a package (glib2-some version-already-installed) to upgrade the glib2-devel package. The problem is that the version needed is already installed. I tried getting yum to reinstall it, but that didn't fix anything. Mainly because it says that is installed and not available. So the final error is "no package matched to install." I know that this probably looks weird and disjointed, so I am happy to provide info to try and get this fixed.

View 6 Replies View Related

Programming :: Installing The Perl Third Party Package

Aug 12, 2010

am creating a perl third party package and using in my other program. If i install the package with standard 4 commands ie.,

1)perl Makefile.PL
2)make
3)make test
4)make install

package has not installed properly. If i try to copy the package to the threads generated by perl -V command, then am able to get install the package, but i want to install the package by the standard 4 commands. I am using 36 bits OS , perl version is v5.8.5 and OS am using is "Red Hat Enterprise Linux AS release 4 (Nahant Update 6)".

View 3 Replies View Related

Slackware :: Find Libgd Perl Package?

May 26, 2010

Where I can find libgd perl package for slackware?

View 1 Replies View Related

Fedora :: Download And Install A Package (zip Package)

Mar 15, 2009

Sometimes i have on some magazines or Internet Zip packages that are the answer of what i am looking for.


Wich tool and how can i do it? c Well, i am in position to say that i had downloaded from Internet or located the package in the Cd or DVD that comes with the magazine.

But now comes the big question. How can i put this package ( install) on my distro ???

Do i have to be a normal user or should it be root or su (superuser) ?

The packages that come with the distro is easy, because i select them and everything is done

As i told before, maybe this is a silly question, but i simple don't know how to install them and i need some of them to leave MS for good.

View 13 Replies View Related

Fedora :: Install *.tar.gz Package Package After Extraction?

Feb 6, 2010

Fedora 12 64bit. Is there an easy and reliable way to install *.tar.gz package after extraction? Instead of going through ./configure etc.

View 6 Replies View Related

Fedora Installation :: How To Install Perl Module At AWS?

Mar 15, 2010

I need to install the Perl DBI and DBI::mysql modules at Amazon Web Services. Perl 5.8.8 is installed there as part of the default Fedora linux that comes with an EC2 instance. I am not familiar with Fedora, but have been using Linux for a good while.If anyone could tell/show/direct me to the quickest way to do this.

View 1 Replies View Related

Fedora Installation :: How To Install Perl Libraries

Aug 11, 2010

I am a Fedora neophyte, upgrading a web server from Fedoras core 5 to Fedora 13. I finally got Apache and perl up and running, but my Perl scripts don't run because of the lack of Perl libraries.I have been able to use yum install thus far to get what I need which is a terrific tool when it works. I note there is a specific tool named 'cpan', and of course one can download libraries directly from the cpan.org website.Unfortunately, I have tried to download perl libaries from yum the cpan library from yum, and in each case I get:

[URL]

And it has tried maybe 20 mirrors, alway with the same result. What is the best way you experienced Fedora types have found to download and install perl libraries (like LWP for starters)?

View 6 Replies View Related

Fedora :: No More Mirrors To Try When Trying To Install Perl-cpan

Sep 29, 2010

My yum is not working. I need cpan in order to install a perl module net::ldap.

This is what I am see when I run the command yum install perl-CPAN

om updates:

I try running yum clear and yum update and nothing fixes the issue.

View 13 Replies View Related

Fedora :: Install Perl With No Internet Connection?

Mar 24, 2011

Fresh installed Fedora 14, I need to make install the NIC driver from source. I downloaded rpm files for kernel-headers, kernel-devel, perl and perl-libs. Trying to install them, Perl asks for perl-libs and a few other lib files. And perl-libs ask for perl D:

how to off-line install perl?

View 2 Replies View Related

Fedora :: Error: Package Requirements (cairo >= 1.6.0) Were Not Met: No Package 'cairo' Found

May 24, 2010

Today I was using Gchempaint (part of Gnome Chemistry Tools) and found that the F12 version fails miserably to correctly export H to xyz. So I decided to install the latest version I found (0.11). There are, however, some problems I must sort out during compilation.

Apparently it does not see my 'cairo' installation and so I get the following error message:

Code:

checking for cairo... configure: error: Package requirements (cairo >= 1.6.0) were not met: No package 'cairo' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you installed software in a non-standard prefix.Alternatively, you may set the environment variables cairo_CFLAGS and cairo_LIBS to avoid the need to call pkg-config. See the pkg-config man page for more details.

View 2 Replies View Related

Ubuntu :: E: Couldn't Find Package Libnet-ssleay-perl

Mar 3, 2010

I've been scratching my head on this one for a while.My level of knowledge of Linux isn't great. I know enough to be dangerous. I'm trying to get Webmin installed to give me an easier web front to Linux. I run the command to get the prereq's.

Quote:

sudo apt-get install perl libnet-ssleay-perl openssl libauthen-pam-perl libpam-runtime libio-pty-perl libmd5-perl
Reading package lists... Done

[code]....

So I can see that it can't find libnet-ssleay-perl I bit of searching around leads me to the sources.list file which tells apt-get where to get the packages I think. This is as follows.

Quote:

#
# deb cdrom:[Ubuntu-Server 8.04 _Hardy Heron_ - Release amd64 (20080423.2)]/ hardy main restricted
#deb cdrom:[Ubuntu-Server 8.04 _Hardy Heron_ - Release amd64 (20080423.2)]/ hardy main restricted

[code]....

View 4 Replies View Related

Software :: Error - Install Package Using Yum ?

Jul 26, 2011

I am try to install a package using yum,i got the following error:

I am using centos 5.5

View 7 Replies View Related

CentOS 5 :: Error When Install Rpm Package?

Jul 9, 2010

System os: CentOS 5.2 32 bitI installed squid and it is proxy server.Later, i install sarg to monitor web log of client...But when i install from rpm package, it show errorQuote: #rpm -ivh sarg-2.2.3-1.el5.rf.i386.rpm error: sarg-2.2.3-1.el5.rf.i386.rpm:pmReadSignature failed: region trailer: BAD, tag 15872 type 2047 offset 28672 count 4238 error: sarg-2.2.3-1.el5.rf.i386.rpm cannot be installed

View 7 Replies View Related

Debian :: 8.2 - Error Install Package With APPER

Apr 15, 2016

I have Debian 8.2 stable with kde, when I try install a new package *.deb with APPER, i have this error:

"MIME type 'application/vnd.debian.binary-package' not supported"

And i can't install any package; however if i use terminal with command dpkg -i, I can install packages.

View 2 Replies View Related

Ubuntu Servers :: Package Install Error In 10.04

Apr 26, 2011

I have installed Ubuntu 10.04 LTS server 32 Bit. Now have to install FTP package in my sever i dont have internet connection but i have downloaded the vsftpd_2.0.4-0ubuntu4.1_i386.deb file but while installing i get the following error.

# dpkg -i vsftpd_2.0.4-0ubuntu4.1_i386.deb
(Reading database ... 42228 files and directories currently installed.)
Unpacking vsftpd (from vsftpd_2.0.4-0ubuntu4.1_i386.deb) ...
dpkg: error processing vsftpd_2.0.4-0ubuntu4.1_i386.deb (--install):

[Code]....

View 9 Replies View Related

Software :: Error When Install Package Aptitude?

Apr 26, 2011

rosy84@rosy84:~$ apt-get install packagename aptitude

E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

View 7 Replies View Related

Fedora :: Error Gnome-desktop3-3.0.1-2.fc15.x86_64 When Choose A Minimal Install Then Add ONLY The Defaults Of The "GNOME Desktop" Package

May 3, 2011

I noticed that in Fedora 15 Beta when you choose a minimal install then add ONLY the defaults of the "GNOME Desktop" package, you will get this error: gnome-desktop3-3.0.1-2.fc15.x86_64 has a required package:

system-backgrounds-gnome

When I look for gnome-desktop3-3.0.1-2.fc15.x86_64 it is not on any installation menu list. I prefer gnome, but installed KDE and that worked. Any ideas of getting gnome to work?

View 3 Replies View Related

CentOS 5 :: Missing Dependency : Perl(LWP::UserAgent) Is Needed By Package Sblim-sfcb?

Aug 25, 2010

I'm trying to install Dell Openmanage, which requires sblim-sfcb.Normally this wouldn't be a problem but it requires LWP::UserAgent to be installed.However there are no RPMs for LWP::UserAgent. There are RPMs for perl-libwww-perl-5.805-1.1.1.noarch.rpm, which people say should work.However yum doesn't see anything with libwww as an option so that won't work either.Running CentOS 5.5

Note: I do have LWP::UserAgent installed via cpan, however the RPM won't compile without the actual LWP::UserAgent RPM installed.

View 9 Replies View Related

Ubuntu :: 'Bus Errordependency Error' Is Displayed / When Try To Install Package

Nov 28, 2010

Whenever I try to run the software centre or synaptic package manager, all the other programs that are currently running hang(reminiscent of the Vista days) and even if I try to install a package using terminal an error message "Bus dependency error" is displayed.

View 2 Replies View Related

Ubuntu :: Cant Install Anything - Reading Package Lists - Error

Aug 6, 2011

I always get these:

-Reading package lists... Error!

- when trying to install through Terminal.

And my Software Center doesnt work.

View 1 Replies View Related

Ubuntu :: Unknown Package Error On Fresh Install

Sep 4, 2010

Just did a clean install on my desktop of 10.04. Net was working fine, until I installed GIMP and restarted. A little "NO" symbol pops up next to my wireless indicator, and it tells me to either do an apt-get check from terminal or start the package manager to find out what the problem is...so, I do the apt-get check.

Here's what I get returned from the terminal:

E: Unable to write to /var/cache/apt/

E: The package lists or status file could not be parsed or opened.

View 9 Replies View Related

CentOS 5 :: Install X386 Package Keep Getting Error Bug Report?

Jan 29, 2011

Every time I selected addons and Mysql i got a notice of a bug report. So i gave in and only selected server and it is installing. I hope i can read enough to get it installed..

View 1 Replies View Related

Ubuntu :: Install Mono Error "Package Mono Is Not Available But Is Referred To By Another Package"

Mar 18, 2011

i first noticed when i tried to get mono via sudo apt-get install mono i got the error

[Code]...

E: Package 'mono' has no installation candidate then i tried to get it through the software center and i noticed the software center wasn't opening.... so i tried searching to find if someone else had the proroblem, they did, one solution was to reinstall python but if i open syapitic software i get the error

[Code]...

View 6 Replies View Related

Fedora :: Package Using Yum - Error

Jun 23, 2010

I'm trying to search for a package using yum:

Code:

And I get the following error:

Code:

View 5 Replies View Related

Ubuntu :: Keyserver Broken - Getting Timeout Error On Package Install

Mar 16, 2010

Is the ubuntu keyserver broken? I am trying to install a package and every time I try to install the key I get a time out error.

apt-update give me
Code:
W: GPG error: [URL karmic Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 932062C9CD30EE56

Then if I try to install the key I get this?
Code:
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys CD30EE56
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --keyserver keyserver.ubuntu.com --recv-keys CD30EE56
gpg: requesting key CD30EE56 from hkp server keyserver.ubuntu.com
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error

Can I tell ubuntu not to bother with the key. I know the package is good and safe to install. I should be the one to judge if its ok to install not ubuntu.

View 1 Replies View Related

Ubuntu Installation :: Cannot Install Package - Permissions Error While Using Sudo

Mar 17, 2010

tl;dr - sudo make -> operation not permitted, sudo chown -R 777
* -> operation not permitted on some of the files

I am trying to install a library. Sudo make is getting permission denied on file 1, while using regular make I am getting permission denied on file 2. I have noticed some of the directories in the library are under nobody:nogroup. I tried chown and sudo chown, both didn't work. Sudo chown got permission errors, while chown didn't change ALL the files. (operation not permitted once again) Tried sudo su, and working from there, that also did not work. (permission once again). Using lsattr returned "lsattr: Inappropriate ioctl for device While reading flags on".

Code:
sudo chmod -R 777 *
chmod: changing permissions of `Makefile': Operation not permitted
chmod: changing permissions of `Makefile.am': Operation not permitted
chmod: changing permissions of `Makefile.in': Operation not permitted
chmod: changing permissions of `queue.c': Operation not permitted
chmod: changing permissions of `queue.h': Operation not permitted
chmod: changing permissions of `ucutil.h': Operation not permitted
Note the .libs folder not having write permission....

Code:
chmod -R 777 *
constantin@Nadfadfo:~/network_home/constantin/libraries/unicap/libunicap-0.9.8/common$ ls -la
total 68
drwxrwxrwx 4 constantin constantin 4096 2010-03-17 11:31 .
drwxrwxrwx 8 constantin constantin 4096 2010-03-17 11:31 ..
drwxrwxrwx 2 constantin constantin 4096 2010-03-17 11:31 .deps
drwxr-xr-x 2 nobody nogroup 4096 2010-03-17 11:31 .libs
-rwxrwxrwx 1 constantin constantin 15295 2010-03-17 11:31 Makefile
-rwxrwxrwx 1 constantin constantin 130 2010-01-17 08:17 Makefile.am
-rwxrwxrwx 1 constantin constantin 15262 2010-01-17 08:17 Makefile.in
-rwxrwxrwx 1 constantin constantin 6101 2010-01-17 02:49 queue.c
-rwxrwxrwx 1 constantin constantin 1667 2010-01-17 02:49 queue.h
-rwxrwxrwx 1 constantin constantin 125 2010-01-17 02:49 ucutil.h
System: Karmic Koala 64-bit

View 1 Replies View Related







Copyrights 2005-15 www.BigResource.com, All rights reserved