General :: Rpm Spec File Conflicts Syntax Query - Not Keeping The Package Name

Mar 9, 2011

I have inherited our Linux packaging and as the number of versions increase, the number of conflicts is starting to get a bit unmanageable. I believe the easiest way would have been to keep the package names the same and just change the release in the spec file but unfortunately I am past that as a lot of these packages are rolled out to our estate. (I am told there were reasons for not keeping the package name the same and incrementing the version/release)

Is it possible to wildcard conflicts so I don't need to keep adding as new versions are created. For example, instead of using all the conflicts below, have something along the lines of AAtest45* <= 1.4 & BBtest45* <= 1.4 Meaning that all I would need to do was change this to 1.5 at the next release (the packages below version matched the release in the spec file)

[Code]....

View 2 Replies


ADVERTISEMENT

Fedora :: Conflicts With File From Package Wireshark

May 12, 2010

I run into this error while trying to install wireshark. I am sure there is a quick fix. I can see the files are different I just don't know how to resolve the error.

Test Transaction Errors: file /usr/lib/python2.6/site-packages/wireshark_be.pyc from install of wireshark-1.2.6-2.fc12.x86_64 conflicts with file from package wireshark-1.2.6-2.fc12.i686
file /usr/lib/python2.6/site-packages/wireshark_be.pyo from install of wireshark-1.2.6-2.fc12.x86_64 conflicts with file from package wireshark-1.2.6-2.fc12.i686
file /usr/lib/python2.6/site-packages/wireshark_gen.pyc from install of wireshark-1.2.6-2.fc12.x86_64 conflicts with file from package wireshark-1.2.6-2.fc12.i686
file /usr/lib/python2.6/site-packages/wireshark_gen.pyo from install of wireshark-1.2.6-2.fc12.x86_64 conflicts with file from package wireshark-1.2.6-2.fc12.i686

View 2 Replies View Related

Fedora :: Yum Update - Conflicts With File From Package

Apr 25, 2011

I am a Debian User, now I have decided to install Fedora 14 x86_64 on my Acer Aspire computer, mainly to develop C++/Java software. Due to this, I have installed a lot of development packages. Shortly after installation, I have encountered problems updating some packages.

Below 'yum update' output:
file /usr/lib64/ghc-6.12.3/bin-package-db-0.0.0.0/libHSbin-package-db-0.0.0.0.a from install of ghc-ghc-devel-6.12.3-8.3.fc14.x86_64 conflicts with file from package ghc-6.12.3-5.fc14.x86_64

file /usr/lib64/ghc-6.12.3/ghc-binary-0.5.0.2/libHSghc-binary-0.5.0.2.a from install of ghc-ghc-devel-6.12.3-8.3.fc14.x86_64 conflicts with file from package ghc-6.12.3-5.fc14.x86_64

file /usr/lib64/qt4/plugins/designer/libqwebview.so from install of qt-webkit-1:4.7.2-8.fc14.x86_64 conflicts with file from package qt-x11-1:4.7.0-3.fc14.x86_64

file /usr/lib64/libusrp.so.0.0.0 from install of usrp-3.2.2-9.fc14.x86_64 conflicts with file from package gnuradio-3.2.2-7.fc14.x86_64

REPOs ENABLED:
Fedora 14 -x86_64,
Fedora 14 - x86_64 - Updates only.
Can't be a problem of multiple repos.

View 5 Replies View Related

Fedora :: Update Fails - Conflicts With File From Package

Jun 14, 2011

Code:
$ su -c 'yum update'
Password:
Loaded plugins: presto, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package libva-freeworld.x86_64 0:1.0.12-1.fc15 will be updated
---> Package libva-freeworld.x86_64 0:1.0.13-1.fc15 will be an update
--> Finished Dependency Resolution .....

View 2 Replies View Related

General :: NVIDIA Installation Encountered Error "conflicts With File From Package XFree86-server-4.3.0.1-21"

Apr 28, 2010

I'm installing a NVIDIA driver and encountered some error message. Please see below the sequence (I've set runlevel to init 3);

linux:~/SuSe # rpm -ivh NVIDIA_GLX-1.0-4191.suse81:i586.rpm Preparing... ############################ [100%])file /usr/X11R6/lib/modules/drivers/nvidia-drv.o from install of NVIDIA_GLX-1.0-4191 conflicts with file from package XFree86-server-4.3.0.1-21

View 3 Replies View Related

General :: Can't Open File/abcd/configFiles/vim/syntax/syntax.vim?

Mar 7, 2011

When ever i open vim, i get the error that the following error: E484: Can't open file/abcd/configFiles/vim/syntax/syntax.vim There was a .vimrc file in my home folder that i have removed.

Still i keep getting the same error. Presently in my home folder there is no .gvimrc or .vimrc file.

But still i keep getting the same error. I am not too sure where this file is mentioned.

Background info: The SHELL has been changed from tcsh to bash Earlier i had created a .vimrc file in tcsh, i have removed the .vimrc in bash SHELL.

View 1 Replies View Related

Ubuntu :: Sqlite Query Syntax ?

Feb 27, 2010

With this sqlite query ? I have these tables:

what is the query to list all cities and its neighboring cities like this?

View 5 Replies View Related

General :: Mysql Query With Unix Timestamp Error "check The Syntax Near The Between"

Jun 28, 2010

Quote: select * from s_transaction Where between UNIX_TIMESTAMP('2010-06-28 15:40:00') and UNIX_TIMESTAMP('2010-06-28 16:00:00') and user_id = '15545941';

Is this the syntax correct to retrieve a particular user transaction between given time period? because "its return error check the syntax near the between"

View 3 Replies View Related

Fedora Installation :: Yum Error KDE4 : "conflicts With File From Package"

Feb 14, 2009

It seems to me that I've got a dual package somewhere.

Quote:

Transaction Check Error:
file /usr/lib/libakonadi-kabc.so.4 from install of kdepimlibs-4.2.0-1.fc10.i386 conflicts with file from package kdepim-libs-6:4.1.4-1.fc10.i386
file /usr/share/config/plasmoids.knsrc from install of kdelibs-6:4.2.0-10.fc10.i386 conflicts with file from package kdebase-workspace-4.1.4-1.fc10.i386
file /usr/share/kde4/servicetypes/plasma-animator.desktop from install of kdelibs-6:4.2.0-10.fc10.i386 conflicts with file from package kdebase-workspace-4.1.4-1.fc10.i386

[Code]....

View 4 Replies View Related

General :: RPM + Writing Script In The Spec File?

Feb 23, 2011

is it possible to write ksh script in the spec file? the target is after I perform rpm -i my_rpm.rpm according to the spec file , ksh script will do some installation & configuration for example run other script and edit some files

View 5 Replies View Related

Software :: Package Building Spec Files?

Jan 12, 2011

I am interested in package building rpms, just stumped on how packagers such as remi and atomic rocket get their spec files. Are these written from other packagers or do you need to write each spec file yourself to be considered as a "packager".

View 1 Replies View Related

OpenSUSE :: Package Conflicts Updating KDE SC 4.6.5

Jul 16, 2011

OpenSUSE 11.4, 64 bits, with
Index of /repositories/KDE:/Release:/46/openSUSE_11.4
and
Index of /repositories/KDE:/Extra/KDE_Release_46_openSUSE_11.4
repositories enabled. Since some days, if I go to YaST2 Package "Update packages if a new version is available" (I'm translating from Spanish) I get a warning that plasma-addons-4.6.5-9.3.x86_64 needs akonadi-runtime < 1.5.40, but that that requirement cannot be match because there are eliminated providers: akonadi-runtime-1.5.3-91.1.x86_64
and non instalable providers: akonadi-runtime-1.5.0-3.3.1.x86_64[openSUSE-11.4-11.4-0]
As "solution" it offers me to not install akonadi-runtime-1.6.0.93.1.x86_64 and libakonadiprotocolinternals1-1.6.0.93.1.x86_64 (which I selected) or to uninstall plasma-addons and kadressbook, which I do not think it is a good idea...

View 7 Replies View Related

Ubuntu :: Package Conflicts / Trying To Install Pidgin

May 25, 2010

Running Ubuntu 10.04 64bit on a Gateway md7818u.When trying to install Pidgin today, I found that I could not do so in the software center due to to a "Software Dependencies Cannot Be Resolved" error. So I went to Synaptic and attempted there. One package after another kept saying "dependent on (insert package name here) but will not be installed" so I went to manually install these packages, with the same results, leading me to "libdirac-encoder0" which would install but conflicted with many of my installed programs it said that all had to be removed to install this package, which will allow me to install all of these other packages, which will allow me to install Pidgin.

View 5 Replies View Related

Fedora :: Package Conflicts On Update (32bit / 64bit)

Aug 14, 2009

I've tried the "yum clean all" option to no avail. When I update either with the GUI or command line, I get this error:

[root@joshhardman ~]# yum update
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package anacron.x86_64 0:2.3-78.fc11 set to be updated
---> Package binutils.x86_64 0:2.19.51.0.14-1.fc11 set to be updated
---> Package crontabs.noarch 0:1.10-30.fc11 set to be updated
---> Package genisoimage.x86_64 0:1.1.9-6.fc11 set to be updated
---> Package icedax.x86_64 0:1.1.9-6.fc11 set to be updated
---> Package shadow-utils.x86_64 2:4.1.4.1-5.fc11 set to be updated
---> Package wodim.x86_64 0:1.1.9-6.fc11 set to be updated
--> Finished Dependency Resolution .....

Can I not have the 64 bit and 32 bit packages installed at the same time?

View 1 Replies View Related

Fedora Installation :: DHCP Conflicts With DHClient Package

Feb 24, 2010

I am trying to install dhcp server on F12 with yum, but at the time I issue yum install dhcp, I got the following message:

Transaction Summary:
Install 1 Package(s)
Upgrade 0 Package(s)

Total size: 821 k
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test

Transaction Check Error:
file /usr/share/man/man5/dhcp-eval.5.gz from install of dhcp-12:4.1.1-5.fc12.i686 conflicts with file from package dhclient-12:4.1.0p1-17.fc12.i686
file /usr/share/man/man5/dhcp-options.5.gz from install of dhcp-12:4.1.1-5.fc12.i686 conflicts with file from package dhclient-12:4.1.0p1-17.fc12.i686

And I see that if I uninstall the dhclient package, I will lose my networkmanager, which I also need, is there a way to have a dhcp server as well as dhclient utility on fedora as it is possible on rhel?

View 1 Replies View Related

General :: Assigning Query Result Into A Variable/file?

May 25, 2011

I am connecting to MySQL DataBase using shellscript and writing a select statement like select attachmentid from attachments where pageid=10175 I want to store the output of the select statement into a shellvariable or a file. How can i do it using shellscript.

View 4 Replies View Related

General :: Keeping A Constant Space Between 2 Words In A File?

Oct 6, 2010

I have a text file that gets produced at the end of the script being run.

For this example the text file will produce the following:

Quote:

THE COW
THE DOG
THE CAT
THE HORSE

In the script I am using either echo or printf to print on the screen each line and then it is doing a test and produces a good or bad result.

Another example:

Quote:

THE COW -- IS HOME
THE DOG -- IS HOME

Each whitespace between the -- are 5 spaces. How can I get them to be in-line and formatted when it gets to more words, when THE HORSE arrives.

Example:

Quote:

THE COW -- IS HOME
THE DOG -- IS HOME
THE CAT -- IS HOME
THE HORSE -- IS HOME <-- This has only 3 whitespaces but is still formatted.

View 8 Replies View Related

CentOS 5 :: Rpm Won't Query An Installed Package

Oct 27, 2009

I'm running Centos 5 and have recently done a yum update. I'm trying to query a package:

% rpm -q xxx.rpm
package xxx.rpm is not installed

OK, so I'll just go ahead and install the package, right?

% rpm -i xxx.rpm
package xxx.rpm is already installed

View 8 Replies View Related

Software :: How To Get Spec File From Existing Rpm?

Jan 10, 2009

I want to change some thing inside the post install script of an existing rpm.there is any way to create a nearest spec file of this rpm, in order to change a bit the post install script inside this spec and then create again the rpm with the fixed spec file? no body wrote any program that can create spec file(99% identical from the orig spec file?)?

View 4 Replies View Related

Debian :: Keeping A Removed Package (hypermail) Around

Nov 11, 2010

Unless I am mistaken, the 'hypermail' package has recently been removed from unstable.

I don't know if this is permanent or if it is just in preparation for the upcoming release.

In case it might be permanent, I thought that I'd download the deb from stable and stick it in a new directory '/var/local/apt'. Then I ran 'dpkg-scanpackages' in that directory and sent the output to '/var/local/apt/Packages'.

Unfortunately, when I run 'aptitude', 'hypermail' still shows up under the 'obsolete' section, even after I do a package update.

Have I done anything obviously wrong?

View 1 Replies View Related

Fedora :: Keeping Multiple Versions Of A Package?

Jan 1, 2010

Some times i need the older version of some packages in my system...side by side with the new one.i.e mostly i found older version openssl package for supporting dependency of some programs Can I keep the following libraries at the same time in my system by installing multiple versions of openssl?

[Code]...

View 3 Replies View Related

Ubuntu Installation :: Erro: Conflicts Qith The Installed Package 'libsound2-plugins'

Dec 8, 2010

i want to install Skype, there is a dependency problem with libsound2. When i tried to install it, this eroor had appeared to me:

Code:

Erro: Conflicts qith the installed package 'libsound2-plugins'

when i tried to install that package (libsound2-plugins), this error appeared (the same dependency problem as with skype ==> so, i am in cycle

View 9 Replies View Related

Fedora :: Building A Rpm From A Tarball Not Containing The Spec File?

Jun 29, 2011

I found that "autospec" can construct a spec file. But autospec-0.8-1 is not compatible with python 2.7.1 Moreover autospec seems to be considered as deprecated. Is there a more recent version or some other equivalent utility?

View 3 Replies View Related

Software :: Rpmbuild A Spec File When A BuildRequires Is Not Installed

Dec 8, 2008

I'm trying to create a set of rpm files to install the requirements for a program.I found a great utility named cpanspec that will create a spec file for perl modules and have started building rpm files. I was able to create an rpm file for Business::CreditCard as a regular user. Now I'm trying to build another module that requires B::CC, and rpmbuild -ba fails saying that I am missing B::CC. I don't want to install it just to create another rpm file.Is there a way to make rpmbuild "think" that B::CC is installed in the build environment without installing it on the system?

View 1 Replies View Related

Programming :: Rpm Spec File To Overwrite Service Script?

May 5, 2010

I have written a spec file for packaging my application in an rpm, but it reports a conflict when I am trying to update my service script in /etc/init.d/. This is a file that I do need to update/replace so how might I force the rpm to do that?

Code:

Summary: A program that increases WAN performance.
Name: packetsqueezer
Version: 0.3.05
Release: 1

[code]...

View 3 Replies View Related

General :: Send A File Using The Sftp Syntax

Mar 24, 2011

I understand how to get a file from an another computer using the sftp syntax

So i can get the file abc from comp2 to comp1

But how can I send a file cba from comp1 to comp2 using the sftp(I am still using comp1)

View 2 Replies View Related

General :: Sudoers File: Syntax Error?

Jul 11, 2010

Recently I edited sudoers file and did typing error. Now neither I can do sudo nor change it.

Code:
sudo visudo -c
>>> sudoers file: syntax error, line 8 <<<
How I can get correct the sudoers file?

View 5 Replies View Related

Software :: How To Force Required 32bit Library On Spec File?

Apr 8, 2010

is there a way to specify that I need a 32bit version of a certain library on the "Requires" line of a SPEC file?Since my software contain (a lot of) binaries from other sources (not always RPM compatible) I had to do "AutoReqProv: No" so I can do it manually.Is there a way to explicid say that I need the 32bit version of some library?

View 1 Replies View Related

General :: Configuration File For Vi Or Vim Editor For Syntax Highlighting?

Sep 10, 2010

On this Red Hat Box that I am using there is no .vimrc file for the user root. So, I created one and entered only one line to highlight syntax with colors when I am writing scripts in PHP and Bash. But it is not working.

Code:
[root@localhost ~]# cat ~/.vimrc
syntax on

[code]....

View 6 Replies View Related

General :: Syntax Error Near Unexpected Token `for File In

Jan 19, 2011

I have been trying to get the following code to run.


Code:

However I am getting the following error:

Is there something that I am missing in the script? I have it as a unix file and tried to make sure that I did not have any extra characters.

View 7 Replies View Related







Copyrights 2005-15 www.BigResource.com, All rights reserved