Debian Multimedia :: X Broke After Dist-upgrade

Mar 20, 2011

After yesterday's apt-get dist-upgrade, I lost my higher screen resolutions. Only had 800x600 and 640x480. After trying to re-install the Nvidia drivers several different ways without success, I ended up purging xorg and xserver and then starting from scratch, re-installing the drivers. In doing so, I either found the problem, or created another, ha.I think part of the problem was that I mixed Nvidia proprietary and debian installations and the update broke the drivers.I am now unable to install xorg or xserver because I can not remove/purge libgl1-nvidia-alternatives.

View 2 Replies


ADVERTISEMENT

Debian :: Dist-upgrade Broke Dependencies In Testing

Jun 23, 2015

I'm running debian testing on my laptop. This morning when I ran apt-get update && apt-get dist-upgrade, I was greeted by the following errors:

Code: Select all

Calculating upgrade... Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information to resolve the situation:

The following packages have unmet dependencies:

 libcurl3-gnutls : Depends: librtmp1 (>= 2.4+20131018.git79459a2-3~) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

A quick search found out that package librtmp1(2:2.4~20150315.gita107cef9b-dmo1) is already installed.

I do have some packages set on hold, however I don't think that's the problem:

Code: Select all$ dpkg --get-selections | grep hold
hostapd                         hold
libgcrypt11:amd64               hold
linux-image-amd64               hold

My sources.list on which I haven't touched for a very long time:

Code: Select alldeb http://mirrors.163.com/debian/ testing main non-free contrib
deb-src http://mirrors.163.com/debian/ testing main non-free contrib

deb http://mirrors.163.com/debian-security/ testing/updates main contrib non-free
deb-src http://mirrors.163.com/debian-security/ testing/updates main contrib non-free

deb http://mirrors.163.com/debian/ testing-updates main contrib non-free
deb-src http://mirrors.163.com/debian/ testing-updates main contrib non-free

View 2 Replies View Related

Debian Multimedia :: Gnome Was HOSED In Dist-upgrade To Sid

Apr 20, 2011

Last night I tried updating from Testing to Sid. Big mistake. Not sure what I did wrong... I changed my repos to sid, and did the usual update / dist-upgrade / autoclean / autoremove. I did not see any significant error messages during the update process. Now, I had fluxbox, gnome and openbox installed. The weird thing is after rebooting I could no longer boot into gnome or openbox as they had merged into something GNOME/Openbox, which was essentially the openbox panel, the nautilus menu on right click, and nothing else. So I purged them both but now when I try to reinstall gnome I get unresolvable dependencies (at least in the sense that both apt-get and aptitude fail to resolve them). fluxbox is still working fine, although it's missing a few things as I was using many gnome apps inside fluxbox.

[Code]....

View 6 Replies View Related

Debian Multimedia :: After The Last Aptitude Dist-upgrade The Keyboard Does Not Work

Apr 30, 2011

I have got Debian SID (2.6.38-2-amd64) (lenovo x61s) after the last aptitude dist-upgrade the keyboard does not work (udev 168-1) after boot. The USB keyboard and the usb mouse work fine. Have you got any idea on how to fix it? I have google it but I have not found any similar issue.

debian:/home/andrea# lsmod
Module Size Used by
acpi_cpufreq 12849 1

[code]....

View 2 Replies View Related

Debian Multimedia :: Wireless Mouse Stopped Working After Dist-upgrade

Sep 30, 2014

I have used a quite obscure device called Cideko AK0b [URL] .... for quite some time now and it has worked perfectly for almost 2 years now, both in Wheezy and in Jessie. However since I made an dist-upgrade a while back the mouse has totally stopped working. The system works through wifi - strangely enough - but everything else works. Keyboard and gamepad buttons. The manufacture says the things doesn't work on linux and so far I have proved them wrong.

But now the mouse is just out right dead no matter what I do. Have looked into mouse autosuspend but no avail so far. My suspicion is systemd but that is as good as any guess.

Running 3.14-2-amd64.

This is my dmesg.

Code:
Select allroot@cryptserv:/home/dencrypt# dmesg | grep Cideko
[    3.158099] usb 6-3: Manufacturer: Cideko Inc.
[    3.469194] input: Cideko Inc. AK08b Device as /devices/pci0000:00/0000:00:12.1/usb6/6-3/6-3:1.0/0003:20E8:5860.0001/input/input2
[    3.469329] hid-generic 0003:20E8:5860.0001: input,hidraw0: USB HID v1.10 Keyboard [Cideko Inc. AK08b Device] on usb-0000:00:12.1-3/input0

[Code] ....

View 3 Replies View Related

Debian Multimedia :: Libgl1-mesa-dri Blocking Apt / "apt-get Dist-upgrade"?

Jul 24, 2011

I hadn't upgraded my multimedia Squeeze box in a month, so I ran a "apt-get dist-upgrade"; I think henceforth I'll stick to "apt-get upgrade" most of the time. Anywho, I got to the point that restarting PAM required me to restart KDM (I haven't seen that snafu on Ubuntu, it seems like there ought to be a way to upgrade without restarting X and running "dpkg --configure -a" and then continuing the upgrade). Anyway, after restarting my dist-upgrade I got part way through and got an error message. The gist of it seems to be this:

Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
xserver-xorg-core : Recommends: libgl1-mesa-dri (>= 7.10.2-4) but 7.10.2-3 is installed
code....

So apt is wedged and it seems like I have a partial upgrade, various little things are not working in Gnome, KDE & XFCE (like icons, plasma seems to be somewhat borked). Although I'm using the radeon driver this seems to be some variant of this bug from mid June: url

I'm not having the issue with my laptop (Intel) or desktop, both testing, although both of the machines do have issues, particularly the desktop (serves me right for buying newish hardware). But this box is pretty bog-standard.01:05.0 VGA compatible controller: ATI Technologies Inc RS880 [Radeon HD 4290]

Maybe I should just strip off xserver-xorg* and reinstall? Or I can wait libgl1-mesa-dri sorts itself out, but it seems like it has been causing problems for over a month.

View 4 Replies View Related

Debian :: KDE Not Working After Dist-upgrade

Jan 30, 2016

After running a dist-upgrade (from stable to testing) KDE stopped working, all I get (after login in with lightdm) are the modals you can see in the attachments [1]. I do not think it is an X issue, because I can login using lightdm (and MATE is working fine).

I suspect this is because I had KDE installed before running the upgrade. The things I tried so far are:

- Runing "apt-get remove kdelibs-bin kdelibs5-data" . Then "apt-get autoremove". I did it to remove every KDE related package, after that, I ran "aptitude purge '~c' " to clean all config files. And finally "apt-get install kde-standard" to get KDE again.
- Removed .cache, .config and .kde folders. Also removed .lock files in .config folder, as I saw somewhere.
- Looked for some log files, but I could not find anything (I don't even know where to look really )

This is almost a fresh debian install so I don't mind breaking things, but I would like to get KDE working.

[1]
[URL]
[URL]
[URL]

View 3 Replies View Related

Debian :: Power Off During Dist-upgrade

Feb 13, 2011

I was in the middle of upgrading from lenny to squeeze via ssh, when someone who was logged in as a user unknowingly rebooted the machine because it was lagging.

View 9 Replies View Related

Debian :: Uable To Run Dist-upgrade

Apr 13, 2010

Debian 5.0 32bit

On running "sudo aptitude dist-upgrade"

I encountered following problem;

Code:

The following actions will resolve these dependencies:

Keep the following packages at their current version:

Leave the following dependencies unresolved:

The following NEW packages will be installed: I was unable to upgrade the packages.

View 4 Replies View Related

Debian :: Maintenance Mode After Dist-upgrade

Sep 6, 2015

I have been using Debian for around two years now. I have a small home server running Debian stable i386 and keep it regularly updated (once or twice a week I perform apt-get update and afterwards apt-get dist-upgrade). The system was originally installed with Debian Wheezy and afterwards upgraded.

However, after entering dist-upgrade tonight, around 42 packages had to be updated. I agreed and afterwards got some errors. After apt-get install -f, the result is as follows:

Code:
Select allnickolay@tegulicium:$ sudo apt-get install -f
Reading package lists ... Done
Building dependency tree
Reading state information ... Done

[Code] ....

After rebooting the system, I am presented with the Debian Maintenance mode (root password for maintenance or Control-D to continue).

I tried dpkg --configure -a, apt-get install -f and aptitude install -f.

Unfortunately, still no resolution of the conflicts.

I assume this has to do something with the new Jessie 8.2 release ...

View 14 Replies View Related

Debian :: System Reboot And Cannot Boot After Dist-upgrade

Dec 12, 2015

I use Debian testing for six months and I started used it six months ago. I use apt-get distupgrade for long times , but today after apt-get update and apt-get dist-upgrade , my system reboot and can not boot and I see URL...and system can not , I see this errors after grub

View 14 Replies View Related

Debian :: Why Not Change Sources.list / Do Dist-upgrade

Feb 8, 2010

My friend has an ubuntu 810 machine and he wants to remove it and install debian on that.Instead of cleaning and installing, I thought why not change the sources.list and do a dist-upgrade to debian. In case it is required, I dont mind purging packages like x or desktop etc. from ubuntu to make it thin before upgrading to debian.Has anyone tried this approach instead of a clean install?

View 14 Replies View Related

Debian Configuration :: Errors During Recent Apt-get Dist-upgrade

Feb 15, 2016

This is on my AMD64 Testing box...A couple days ago during an apt-get dist-upgrade, near the end I saw the errors below.

I haven't noticed anything broken, yet. I usually only see dkms errors when VBox squawks after an update and I run /etc/init.d vboxdrv setup.

The section of the results containing the errors to the end of the output:

Code: Select allSetting up linux-image-4.3.0-1-amd64 (4.3.5-1) ...
/etc/kernel/postinst.d/dkms:
error: db5 error(-30969) from dbenv->open: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch
error: cannot open Packages index using db5 -  (-30969)
error: cannot open Packages database in /root/.rpmdb
error: db5 error(-30969) from dbenv->open: BDB0091 DB_VERSION_MISMATCH: Database environment version mismatch

[Code] ....

View 2 Replies View Related

Debian :: Aptitude Dist-upgrade Without Updating Openoffice.org And The Kernel?

Jun 30, 2010

I want to do aptitude dist-upgrade without updating openoffice.org and the kernel.How can i do this?

View 4 Replies View Related

Debian Configuration :: Jessie After Dist-upgrade / Password Not Working

Jul 13, 2015

updated my jessie by apt-get dist-upgrade and there was an error said there was something wrong with some database, and I needed to run some command, but after the upgrade I forgot to run the command. After I rebooted my system I found there was not any password needed for a normal user or the root. But if I change to the emergency mode, a root password is needed.

View 4 Replies View Related

Debian Configuration :: Cannot Dist-upgrade Errors Block Update

Mar 29, 2016

This is a redirect of the output of command apt-get update to a text file in /home/user

Code: Select allIgn:1 http://dl.google.com/linux/talkplugin/deb stable InRelease
Hit:2 http://ftp.us.debian.org/debian testing InRelease
Hit:3 http://dl.google.com/linux/talkplugin/deb stable Release
Ign:4 http://linux.dropbox.com/debian sid InRelease
Hit:5 http://deb.opera.com/opera sid InRelease

[Code] ...

They all refer to repos that cannot validate authenticity.

View 2 Replies View Related

Debian :: Dist-upgrade Giving Weird Feedback On DVDs

Mar 7, 2011

I use Squeeze. I just recently upgraded from Lenny. My sources.list is a combination of Debian DVDs and some http repos (for multimedia, non-free, and security updates). I rely largely on DVDs because I use dial-up.

When I tried to run apt-get dist-upgrade for the multimedia packages on my system, it told me to insert Debian DVD disc #1, and from that attempted to install the following programs: librtmp0 libdirac-decoder0 libggiwmh0 libggiwmh0-target-x libvdpau1 twolame. But, it then told me:

[Code]....

View 5 Replies View Related

Debian Installation :: Dist-upgrade From Wheezy (using Systemd) To Jessie Hangs

Nov 19, 2014

I have done on previous releases, but this time it hangs on me. It's "only" a Virtualbox, so I can reproduce it.

The wheezy already runs systemd, and is fully updated to to latest packages. Does not run any graphical.

Edits the source.list and does
$ apt-get update
$ apt-get upgrade # Did on one upgrade
$ apt-get dist-upgrade

It starts to upgrade (complains about missing version in libpgp-error), libc is installed, but at some point the systemd is running at high CPU and a dpkg seems to be stalled.

Should I disable systemd on wheezy before? This might not have been tested so much.

View 10 Replies View Related

Debian Installation :: Squeeze Dist-upgrade Exited With Error Continue From?

Apr 21, 2011

I was upgrading from lenny to squeeze. At the apt-get dist-upgrade step, at some point (after upgrading and configuring) it tried to create a new certificate for my mail server but creation of the certificate failed, dpkg reported an error and the whole process exited with error. So I rebooted the machine and issued again apt-get dist-upgrade but now the certificate was created successfully . After that it upgraded mysql-client and the process finished.

But I don't know if configuring of the upgraded packages has stopped at the point where dpkg stopped. I suppose so, because very few packages were configured at that point. Is the solution to run dpkg-reconfingure -a (or -u ?) or dpkg --confingure -a or something else ? (dpkg has the PACKAGE STATES)

dpkg --configure --pending gives me no package for configuration.PS: At least I hope that all packages were upgraded and a few were not configured. Is there a way to confirm that all packages were upgraded ?

View 2 Replies View Related

Ubuntu Multimedia :: Natty Upgrade Broke Mpd?

May 11, 2011

So after my Natty upgrade, mpd stopped working. All I can see in the logs are the following lines:

No protocol specifiedxcb_connection_has_error() returned true The Pulse Audio wiki suggests that this might be an access rights problem: [URL]...hts_are_broken I tried that, but with no success.

Anyone else had this problem? And any ideas about how I can diagnose and fix this?

View 1 Replies View Related

Debian :: Squeeze Kernel Upgrade Broke Suspend To Ram

Dec 12, 2014

Yesterday, I ran a security update that upgraded my Squeeze kernel from 2.6.32-48squeeze8 to 2.6.32-48squeeze9.

Ever since then, my suspend to ram (STR) function is broken.

The machine will suspend normally, but will not resume. When I try to awaken the machine, I can hear the fan in the tower start up (the subject machine is a desktop computer, please see below for specifics), but the machine seems to be otherwise dead (e.g. the monitor stays blank, pressing the "caps lock" key on my keyboard does not activate said keyboard's "caps lock" led, Ctrl-Alt-F[x] has no effect, etc). My only recourse at that point is a hardware reset (ouch!).

I tried running Code: Select allpm-suspend from a terminal, with no joy. Same result running Code: Select allecho -n "mem" > /sys/power/state from a terminal.

I checked the /var/log/pm-suspend.log file and noticed that each Code: Select all...performing suspend line used to (before said kernel upgrade) be directly followed by a Code: Select all...Awake. line, but, now, all said Code: Select all...performing suspend lines are followed by an Code: Select allInitial commandline parameters... line.

Before this, STR has worked well ever since I first loaded Squeeze on this machine back in 2012.

Code: Select allSqueeze 6.0.10; 2.6.32-5-amd64

Intel i7-980 Gulftown CPU
Asus P6X58D Premium Motherboard
EVGA GeForce GTS-450 Graphics Card
G.SKILL Ripjaw DDR3-1600, PC3-12800, 1.5v RAM (6x4GB sticks, 24GB total)
Crucial RealSSD C300 128GB SSD
Western Digital Caviar Black 1TB HDD
Corsair HX850 PSU

[CODE]

View 14 Replies View Related

Debian Hardware :: Upgrade To Jessie Broke Sound

Jun 22, 2015

I upgraded from Wheezy to Jessie yesterday and no longer have sound. I don't think anything is muted. I checked alsamixer and everything is on. MOC, VLC, speaker-test and aplay are all giving me errors. MOC refuses to load.

Code: Select allccc@de:~$ speaker-test

speaker-test 1.0.28

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
Playback open error: -2,No such file or directory
Code: Select allaplay /usr/share/sounds/alsa/Front_Center.wav
ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
aplay: main:722: audio open error: No such file or directory

Code: Select allccc@de:~$ mocp
Running the server...
Trying JACK...
Trying ALSA...
ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
Trying OSS...

[CODE]....

Should I have a normal alsa-base.conf file?

View 3 Replies View Related

Debian Configuration :: Jessie Upgrade Broke NTFS Drive

Sep 22, 2015

I had a Linux server with Wheezy, I have 2 internal drive, one for linux OS, the other our Video On Demand drive that must be accessible to Windows and online. (That's why I chose NTFS, with our large video files, FAT will not work, and EXT isn't compatible with windows sharing, and I haven't gotten FTP to work right .

So I upgraded to Jessie today, and everything went smoothly until I tried to access my NTFS drive. (Named WowzaStorage)

I used FSTAB to auto-mount the drive (/dev/sdb1) to /media/ntfs/ on boot. All of this worked swimmingly on Wheezy, but since the update, something got mucked up and I cannot figure it out.

When accessing the mounted NTFS folder in /media/ (if it even shows up) gives me a 'Cannot be found' 'Input/Output error'

When in gParted to examine the drive, I can select it and view all the correct info, but I keep getting "error informing the kernel about modifications to partition /dev/sdb1/ --invalid argument"

Now first I thought maybe the NTFS driver was faulty and I removed 'ntfs-3g' and reinstalled it.

Now when I am in Terminal, after i umount and mount sdb1, I can CD to the drive but not the folders on it... Also using the File Browser, I get errors, and missing folders.

I get "Unhandled error message: Error when getting information for file '/media/ntfs': Input/output error"

View 2 Replies View Related

Ubuntu Installation :: Update, Upgrade And/or Dist Upgrade?

Jan 18, 2010

I am begining on Ubuntu Server Management I would like to receive your on this doubt In order to have my Ubuntu Server up to date and with the last security patches, is it enough to do:

sudo apt-get update
sudo apt-get upgrade?

If not, please where I can find an easy guide in order to keep or mantain my server OK? Also, what are the risks when we do: sudo apt-get dist-upgrade?

View 3 Replies View Related

Ubuntu Installation :: Upgrade To 10.10 Using Commandsudo Apt-get Dist-upgrade?

Oct 13, 2010

When I tried to upgrade to Ubuntu 10.10 using commandsudo apt-get dist-upgrade the following error is thrown:Setting up netbase (4.35ubuntu3) Installing new version of config file /etc/services.

[Code]...

View 2 Replies View Related

Ubuntu Installation :: Dist-upgrade Won't Upgrade Me For 10.04 To 10.10?

Dec 4, 2010

I would like to install 10.10 preferably right now.But I'm having issues, dist-upgrade won't upgrade me for 10.04 to 10.10.I tried to go into my Update Manager, but it's not recognizing any new Ubuntu versions.I don't particularly want to wipe my system, so what should i do?

View 4 Replies View Related

Debian Multimedia :: Jessie KDE Broke After Log Out Session

Mar 2, 2015

A few weeks ago I have installed Debian Jessie on KDE Desktop Version. I have a problem with the Display Manager Kdm, if i log out session the monitor turns off (DVI No Signal), the only option that I have it's forced shutdown or reboot via power button. I try another DM lightdm and this works fine. But i liked to know why log out session crash on Kdm.

Adding : TerminateServer=true at the end of /etc/kde4/kdm/kdmrc (Section :[X-:*-Core], solve the issue.

View 2 Replies View Related

Debian Multimedia :: Xserver-common=2:1.11.0-1 Broke Nvidia Driver

Aug 30, 2011

xserver-common (2:1.10.4-1) was upgrade today in Sid to xserver-common (2:1.11.0-1) breaking my nvidia driver (NVIDIA-Linux-x86_64-280.13.run). There is a temporary fix as showen below.

Section "ServerFlags"

Option "IgnoreABI" "true"

EndSection

Some problems do exist and downgrading may be a better option.

I need to look at bugreports at nividia but not sure how. LOL guess it's time to google.

View 14 Replies View Related

Ubuntu Installation :: Change The Dist To Maverick Or Leave Them At Their Latest Dist?

Oct 16, 2010

A few of my software sources repositories do not have Maverick distributions. Should I untick them as a software source, change the dist to maverick or leave them at their latest dist?

View 4 Replies View Related

Ubuntu :: Will Menu Go Away With Dist-upgrade

Sep 1, 2011

i foolishly upgraded 9.1 with some experimental debian stuff there and now the menus are all screwed up. There's not clock, show desktop, notification area and other such applets. The gnome dependencies have been compromised. It says something about the python_gmenu (=2.28.0.1-0ubuntu1) but 3.0.1-1 is already installed.E: Unmet dependencies try using -f.Now I was going to upgrade my distribution to 10.04 seeing as 9.1 is not supported anymore and I wanted to play Quake 1 and was wondering would these problems still exist if I did or have i totally screwed up my ubuntu.I have since taken away the line in /etc/apt/sources.list which caused me to mess this up in the first place.

View 4 Replies View Related







Copyrights 2005-15 www.BigResource.com, All rights reserved