Debian :: Install Newer Version Of Library In Lenny?

Aug 31, 2010

to install a Python module I need a more recent version of a library (libcurl) that the one available in Lenny. How should I manage it? Shall I just install it manually? Won't it mess the system to have two versions of the same library in the system?

View 1 Replies


ADVERTISEMENT

Software :: Newer Library Version Doesn't Satisfy Dependency

Nov 29, 2010

I'm trying to install the Amazon MP3 downloader. They're a bit behind -- they have a downloader available for "Ubuntu 9.04" I downloaded it and tried to install -- but it says there's a dependency that can't be resolved: Dependency is not satisfiable: libboost-filesystem1.34.1 I installed libboost (and a bunch of other sub-items in the Boost library) using the Ubuntu Software Center, but the version of Libboost is higher now than it was in April of 2009 (surprise!) Why doesn't a NEWER version satisfy the dependency? Is there a way to override it?

View 4 Replies View Related

Debian :: How To Install Newer Version Of Software

Sep 25, 2010

I want to install libtorrent-rasterbar version 0.14 or greater.

I want to use apt-get to do this.

It seems to be available here: [url]

How can I do it? My current libtorrent-rasterbar package is version 0.13 (I've ran apt-get update).

I DON'T want to install anything else. The last time I added a 'sid' source to my sources.list, it installed the untested version of EVERYTHING. Due to this, I had to reinstall the OS. I don't want this to happen again.

How to install libtorrent-rasterbar version 0.14+ on Debian 5?

View 9 Replies View Related

Debian :: Install An I386 Library Onto Amd64 Lenny?

Jul 24, 2010

There's a certain program I'm trying to run that will only work with the 32-bit version of a certain library - the 64-bit version included in the repository won't work for it. I found an i386 .deb package online (made for ubuntu but it should work with regular debian), but when I try to install it, it says incorrect architecture, use amd64 version instead.

How can I force it to accept the i386 version of this package?

View 14 Replies View Related

Debian :: Install A Newer Version Of Curl And Libcurl Without Breaking System?

Jun 17, 2011

I am still running Debian Lenny and have found that the curl version 7.18 is just too outdated for my needs, I would rather not do an upgrade just yet to the stable release of squeeze. I was looking for some information on how I could install a newer version of curl and libcurl without breaking my system.

View 8 Replies View Related

Debian Configuration :: Update From Php 5.2.6 To Newer Version?

Dec 29, 2010

there seems to be a very important bug with php 5.2.6 (mb_send_mail, [URL]). Unfortunately this affects my php applications greatly. I am currently running debian 5.0.7, with the latest updates. how to upgrade my php.

View 1 Replies View Related

Debian Multimedia :: Update To Newer XFCE Version?

May 21, 2010

I recently installed a base Squeeze system and then did apt-get install xfce4 to get the XFCE DE. Is this XFCE 4.0 or is it the newer version? This is kind of a stupid question but I haven't been able to divine a concrete answer out of Google. If "apt-get install xfce4" indeed doesn't install the newest version of XFCE in Squeeze, then how can I get it?

View 10 Replies View Related

Ubuntu :: Install Package Meant For Older Version Of Ubuntu On Newer Version?

Jan 22, 2011

Specifically, I want Clementine player 0.6, but the guy that installed Ubuntu on my laptop put natty narwhal alpha 1 on it (don't ask me why. I wanted maverick since its stable but he never really asked. The whole thing was kinda a surprise), and Clementine only offers downloads for Ubuntu distros up to maverick. So. Can I/is there a way I can install it anyway? Or am I forced to just use Banshee until the official Update comes out and Clementine is updated in....

View 6 Replies View Related

General :: Install Flex Version 2.5.33 Or Newer

Mar 6, 2011

I have run the command ./wineinstall on redhat 5.2 machine and have got the error "conigure error: flex version installed is looking old.install flex 2.5.33 or newer version"

Solution for the above so that i can install wine on my linux machine.

View 1 Replies View Related

CentOS 5 :: Install A Newer Version Of ImageMagick?

Aug 13, 2009

I have ImageMagick 6.2.8 installed on my CentOS 5.3 (64bit) system. I want to upgrade it to a newer version, because it has nice new features I need to use in a PHP script I write for a website. I tried yum, but it did not help, it didn't have a newer version of ImageMagick. Maybe I have to use some other repositories (I use CentOS and RPMFprge repositories only) or use them some other way. I ended up with downloading ImageMagick 6.5.4 RPM from ImageMagick website (it was marked as Fedora package, there's no one for CentOS there) and tried to install it. I've got some absent dependencies, but installed them all, most from the CentOS and RPMForge repositories. Some were absent from those repositories (like jasper-libs and libtool-ltdl) and I installed them from other sources.Finally, when I tried to install ImageMagick I got this error:

-bash-3.2# rpm -Uvh --test ImageMagick-6.5.4-10.x86_64.rpm
error: Failed dependencies:
rpmlib(FileDigests) <= 4.6.0-1 is needed by ImageMagick-6.5.4-10.x86_64
rpmlib(PayloadIsXz) <= 5.2-1 is needed by ImageMagick-6.5.4-10.x86_64

I tried to install it using --nodeps, but got some "cpio: Bad magic" error. So, as far as I understand, I need to upgrade "rpm" package itself to make it working. Correct me if I'm wrong here. The current version of rpm is: bash-3.2# rpm --version RPM version 4.4.2.3

If I really have to upgrade rpm, then I'm not sure what to do. I have few questions:

1) First of all, what version of "rpm" package do I need? Because I don't want any conflicts. The latest version, as I can see on rpm.org, is 4.7.1. Will it work with CentOS 5.3?

2) Where do I get the right rpm for the rpm upgrade? If it's available at all. Rpm.org, as far as I can see, got source only, and I'm not sure CentOS uses their version of rpm. Where can I get the right rpm package, preferably as a plain .rpm file so I don't need to build it myself?

3) And after all, the most important. Wouldn't my system break at all if I upgrade rpm? I don't want to screw things up and end up with a broken system.

View 6 Replies View Related

CentOS 5 :: Easier Way To Install Newer Version Of Gcc?

Nov 18, 2009

An application I'm attempting to install URL...) requires a version of gcc above 4.3.2, however the only rpms available for CentOS I can find are 4.1.2.I began trying to install a newer version via compiling the latest one from the gcc GNU site, but I started running into problems. Especially in installing newer versions of gmp and mpfr (apparently upgrading from certain versions of gmp will write over the header files, but won't change path locations for the lib files?) After examining the problem a little closer, I got worried that I was going to end up making the system unstable, so I stopped fiddling.

So my question is, is there an easier way to install a newer version of gcc? I'm not completely new to Linux, but I'm far from a master at the system, if anyone knew an easier/slightly more fool proof way of upgrading gcc.

View 2 Replies View Related

Slackware :: Newer Version Of Glib - For Midori Install

Jul 5, 2010

How to update my version of glib in order to install the latest version of Midori on slackbuilds.org - [url]

Midori relies on WebKit.

When I try to install WebKit using the slackbuild script, I receive the following error:

I don't see a newer version of glib-2.xx on slackbuilds and I'm hesitant to install from source over the currently installed version.

If there's no updated package, can anyone provide guidance regarding installing new glib from source ---

[url]

View 14 Replies View Related

Ubuntu :: Install A Newer Version Of A Package Than Exists In The Repo?

Aug 13, 2010

I am running Ubuntu 9.04 at work and have a sudden need to install a newer version of python-support (> 0.9.0) than is currently available in the repo (0.8.7) for my Ubuntu version. Upgrading to 9.10 is not an option as we are planning to jump to 10.04 LTS in the next few months and I am unable (unwilling) to mess with a complete upgrade prior. Is it possible for me to upgrade to the newest version of python-support - or is this package OS version specific? Assuming it's possible, how might I go about the process of upgrading?

View 2 Replies View Related

Ubuntu Installation :: Install Current Daily Build Of 10.10 - Burn Newer Version?

Oct 3, 2010

If I were to install the current daily build of 10.10 (cd) will there be a live update that can be installed on Oct 10? Or do I need to burn the newer 10.10 version on that day and install again by cd?

View 2 Replies View Related

Debian Programming :: How To Include Version Information In SO Library

Oct 8, 2014

Suppose I have the library code in library.cpp. I found that to include the version information in the .so library, I had to use these command forms:

Code: Select allg++ -Wall -fPIC -c library.cpp
g++ -shared -Wl,-soname,library.so.0 -o liblibrary.so.0.1

The howto then continued to recommend creating symbolic links pointing at the newly compiled library. [URL] ....

The result is, during the booting sequence, I am receiving this error:

Code: Select alllibsystemd-login.so.1: no version information available (required by /usr/bin/dbus-daemon).

The library is the one I am working on.

View 5 Replies View Related

Debian :: Imagemagick On Lenny Up From The Lowly 6.3.9 Version Up To 6.4.9

May 2, 2010

I need to get imagemagick on a Debian Lenny up from the lowly 6.3.9 version up to 6.4.9, I have looked it up, but can't get brief details on this ... if I just apt-get install, well I get the older version. Do I have to come up with my own deb package?

View 3 Replies View Related

General :: Debian Lenny : How To Install Xfce 4.6 Instead Of Lenny's 4.4

Dec 14, 2009

i was trying to use gnome and kde but i don't like them. I tried xfce and it seem to fit my needs but.My computer is used to be powered on for a weeks. While time passes, a process xfdesktop begin to use more and more memory and to free RAM i need to log out and log in again.

I tried squeeze yesterday on my virtual machine and it has 4.6 and seem not to have that bug, RAM usage is static(yes it still works when i write this and have memory usage 34492k, which is not changing for an hours of usage already), also 4.6 is MUCH better than 4.4.

i already tried adding squeeze to "sources.list" but i can see too many dependencies which should be upgraded if i install 4.6, i'm beginning to afraid it can crash entire GUI(or entire system, i can see there is libc6 required to be updated).

View 14 Replies View Related

Debian Multimedia :: Getting Latest Version Of A Software On Lenny?

Jan 31, 2011

anyone knows how to get the lastest version of a software (Gcompris) on debian lenny using a specific repository via synaptics here are available version by distros release: but i want to stick with lenny for stability Debian Sid

* gcompris_9.3-1_amd64.deb Debian Main - Educational games for small children
* gcompris_9.3-1_i386.deb Debian Main - Educational games for small children
Debian Squeeze
* gcompris_9.3-1_amd64.deb Debian Main - Educational games for small children
* gcompris_9.3-1_i386.deb Debian Main - Educational games for small children

[Code]...

View 4 Replies View Related

Debian :: Version Lenny: Define A GW In The Interfaces File?

Jan 28, 2011

Do you have to define a Gateway in the interfaces file?

View 2 Replies View Related

Software :: Pidgin Stucked In Version 2.4.3 In Debian Lenny / Why Is So?

Jun 6, 2010

I am using Debian 5.0.4 + LXDE, and I just install pidgin with apt, but somehow, the repository seems only have version 2.4.3, but without the updated one.

Anybody know why?

View 4 Replies View Related

OpenSUSE Install :: Error 11.3: Wrong JPEG Library Version

Aug 10, 2010

Just installed OpenSUSE 11.3 64-bit. I have a program that uses libjpeg, so I installed libjpeg and the dev modules. It has both version 6 and 8 installed. When I run my prog and try to access the lib I get this error: Wrong JPEG library version: library is 80, caller expects 62 This seems a common problem elsewhere. Anyone know how to fix it in 11.3 ?

View 1 Replies View Related

Ubuntu :: MySQL Library Version X.x.x Differs From Server Version X.x.x

Jun 4, 2010

Installed Zend Server CE on 10.04 - install mostly fine. But phpmyadmin shows this error; "Your PHP MySQL library version 5.0.83 differs from your MySQL server version 5.1.41" I have followed the Zend online docs and used a DEB install. Why would these versions be different?how do I fix it so that the two are in sync?

View 3 Replies View Related

Debian Installation :: Upgrade Etch To Lenny: No Version Bump, Auto-start Services?

Feb 24, 2010

On my debian web server I curently have ImageMagick 6.3.7 08/07/09 Q16 since this is an old version of imagemagick i wanted to upgrade my system that still runs etch, and afterwards upgrade imagemagick. I can not see what version the current lenny imagemagick package has, but I assume it is newer then 6.3.7, no?

When i ugraded I found out that my apt-sources used stable rather than etch. So I already had a mix of lenny and etch I suppose. I then had > cat /etc/debian_version 4.0 Before I upgraded I changed my apt sources from stable to etch, updated the package-tools and did a dist-upgrade (for details, I followed these instructions). After restarting I have still 4.0 as debian version. Also uname -r is 2.6.17. How can I do a correct update?.

Also my services were not started (ftp,ssh, apache2), so I asked my hoster to start the ssh service. This morning everything was up again, but it seems like nobody there have had a look at this. How do I absolutely ensure that my ssh service is start at boot. It is a remote webserver, so I need at least this service to be running.

View 2 Replies View Related

Hardware :: Debian Lenny - Nvidia GTX280 - Driver Version 195 - Compiz Fusion - Shell-Caracters

Sep 8, 2010

I have installed Debian Lenny and the Driver for an NvidiaCard GTX280. As this card is not supported by the debian-repositories, i have installed the driver from the nvida-Site. It works ok, but there's one thing: When i have compiz fusion activated, the caracters in the shell are sometimes hidden (pls see attachment).

View 4 Replies View Related

Ubuntu :: Repository To Add To Get Newer Version?

Jul 9, 2010

Anyone know why Ubuntu has shipped with the same version of syslinux since 8.10 (Intrepid Ibex), or if there is a repository I can add to get a newer version of syslinux? The whole reason for switching from Gentoo to Ubuntu was to avoid the troubles with compiling different versions of things, but I'm needing a newer version.

View 2 Replies View Related

General :: Compiling Old Version Of GCC With Newer One

Jul 1, 2011

I am working on a university workstation and need to use an old version of gcc (either 4.0 or 4.1) and am currently using 4.4.2. I do not have admin rights nor can I get them so using aptitude is out of the question. I was told I should compile the old version with the current one. I am very new to this sort of thing and haven't a clue what to do or how to go about compiling my program once I have gotten the older version.

View 2 Replies View Related

General :: Gcc Compilation - Newer Version Of Glibc ?

Nov 13, 2010

In a chroot einvironment i am trying to compile gcc but is says that i need a newer version of glibc, but i have the newest version of it. i think somehow it trys to use the older glibc from the ubuntu install im makeing it on.

View 1 Replies View Related

General :: Upgrade Software To A Newer Version?

Jan 31, 2011

I want to upgrade my software to newer version. since i do not have a yum repository what should i do? should i just change the path to a new location of installed version if 'Yes'

View 8 Replies View Related

Fedora Servers :: Change The Respository To A Newer Version?

Oct 21, 2009

i have a new vServer with Fedora 6.So now i want to update my box. how can i get a full updated server??

i do this stepps:
yum install yum-fastestmirror
yum update << all installed
yum upgrade << no packages to update

is it a good idea to change the respository to a newer version? can I get a secure and good server with Fedora v6? if no, how can I upgrade to a newer version? is my box now updated or is this only a lightupdate of an old fedora version? ps: sorry for the very bad english

View 1 Replies View Related

Ubuntu Servers :: Get The Newer Version 1.4.5 Using Apt-get On Current Server?

Feb 9, 2011

I have Ubuntu Server 10.04 Lucid (LTS) installed on my server (EC2 instance). I'd like to install Memcached on it. When I type "sudo apt-get install memcached" I get version 1.4.2-1ubuntu3 installed.

I know there's a newer version 1.4.5 and looking at [URL]..I found it's available in the newer version of Ubuntu (Maverick). Question: is it possible to get the newer version 1.4.5 using apt-get on my current server?

View 1 Replies View Related







Copyrights 2005-15 www.BigResource.com, All rights reserved