Debian :: Force Aptitude To Ignore Broken Packages

Jul 26, 2010

I am just too tired and am missing something in the man pages for aptitude and not getting my search terms right but I can't seem to find a way to make aptitude ignore a couple of supposed broken packages (they work just fine by the way). The only way I can find to remidy the situation is to remove those couple of packages or upgrade several things to their Squeeze counter parts. I really don't want to try and do the upgrade as at home I am stuck on a 56k connection. Removing the broken packages I guess won't be too bad if I can find the debs again after I install a couple of things I want to add to my system. I would however just like to make aptitude ignore the state of my system and try to install what I want anyway.

View 14 Replies


ADVERTISEMENT

Debian :: Making Apt-get Ignore Broken Packages?

Apr 21, 2011

what should not be mentioned:

*disabling "Automatically fix broken packages before installing or removing" in aptitude -- because it does not work

*editing /var/lib/dkpg/status -- not related to apt-get really

* -m or -f options of apt-get -- because they do not help me in any way

* downloading the package manually and using dpkg --force-depends-version -i <package> -- again, not apt-get

I need the --just shut the fuck up and dl&install the darn package option immediately.

View 14 Replies View Related

General :: Tell Aptitude To Ignore Broken Package?

Jan 13, 2010

I installed a Amsynth from Lucid in Karmic using:

dpkg --force-depends-version -i amsynth_1.2.2-1_i386.deb

The reason for installing the Lucid version is because Karmic version is 3 years old and crashes on my machine. The Lucid Amsynth package depends on newer versions of libatk1 and libjack0 than Karmic has, but I thought I would take a risk, and turns out Amsynth runs fine. However aptitude tries to uninstall Amsynth every time I do an upgrade. I think I've managed to put it on hold but now aptitude aborts. How can I tell aptitude to ignore the broken package and carry on.

View 3 Replies View Related

Software :: Force Synaptic/update Manager/aptitude To Accept A Broken Package?

Nov 9, 2010

I forced the install of graph-tool package [URL]. Now it is of course tagged as broken, so update manager wont do anything. But I want to accept it, I know it is not really broken. (In fact, graph-tool_xxx.deb asks for libcgal4. squeeze only has libcgal5, so I am betting this is not an issue, as far as graph-tool is concerned.)

View 2 Replies View Related

Networking :: Make Apt-get Ignore Broken Packages And Missing Dependencies?

Mar 20, 2011

when I have a broken packages on the system and want to apt-get install something (completely unrelated to the broken package) apt-get starts giving me crap about the broken stuff and won't download and install the packages I'm asking for. How can I make it ignore the completely unrelated stuff about missing deps on my system and download what I want?

View 3 Replies View Related

Ubuntu Installation :: Install Aptitude Using Apt-Get (Broken Packages)

Apr 23, 2011

I want to install aptitude using apt-get, but some problems happen like this:
The following packages have unmet dependencies:
aptitude : Depends: libapt-pkg-libc6.10-6-4.8
Depends: libept0 (>= 0.5.30) but it is not going to be installed
E: Broken packages
(before do this, I have used command apt-get update and apt-get upgrade)

View 6 Replies View Related

Debian :: Debian Disobeying Instruction - Ignore Command And Fetched Packages

Jul 19, 2011

Upon installing Debian, it asked me if it can use a mirror to get updated packages. I said no, yet it ignored my command and fetched packages. Why did Debian disobey me?

View 12 Replies View Related

Debian :: Aptitude Packages Not Listed?

Mar 6, 2016

How to find packages with aptitude. If I use the shell to type "aptitude search nethack" then I get a list of several nethack versions from which to choose. If I use the aptitude GUI and type Ctrl-T and then arrow over to the search option and type in "nethack" and hit Enter, the only option that I see is nethack-spoilers. Why do I not see all of the other nethack options?

View 2 Replies View Related

Debian :: Aptitude Safe Upgrade Removed All KDE 4.3 Packages

Apr 13, 2010

KDE 4.3 squeeze-SID
I've got a strange problem with my last "aptitude safe-upgrade". It had removed all my kde 4.3 and packages I have installed, I don't know why!

This is what aptitude removed :
$ dpkg -l | grep ^rc |awk '{print $2}' | xargs echo .....

I reinstalled kde-full (kde 4) but now with an aptitude safe-upgrade or dist-upgrade. It wants to remove my debian-multimedia keyrings and my wine-unstable and others each time.

# aptitude -s safe-upgrade
Les NOUVEAUX paquets suivants vont etre installs:<<<<<<<<< #new packages will be installed
libparted0debian1{a} libva1{a} libx264-92{a} libxklavier16{a} mysql-server-core-5.1{a}
Les paquets suivants seront ENLEVES:<<<<<<<< # packages will be remove .....

Here is my pref list :
Package: *
Pin: release o=apt-build
Pin-Priority: 989
Package: *
Pin: release o=Unofficial Multimedia Packages,a=unstable,l=Unofficial Multimedia Packages
Pin-Priority: 988
Package: *
Pin: release o=Debian,a=unstable,l=Debian
Pin-Priority: 987
Package: *
Pin: release o=volatile.debian.org,a=stable,l=debian-volatile
Pin-Priority: 986
Package: *
Pin: release o=Debian,a=stable,l=Debian-Security
Pin-Priority: 985
Package: *
Pin: release o=Unofficial Multimedia Packages,a=stable,l=Unofficial Multimedia Packages
Pin-Priority: 984
Package: *
Pin: release o=Debian,a=stable,l=Debian
Pin-Priority: 983
Package: *
Pin: release o=Debian,a=testing,l=Debian-Security
Pin-Priority: 982
Package: *
Pin: release o=Unofficial Multimedia Packages,a=testing,l=Unofficial Multimedia Packages
Pin-Priority: 981
Package: *
Pin: release o=Debian,a=testing,l=Debian
Pin-Priority: 980

And my sources.list:
# SID [URL]

# LENNY [URL]

# SQUEEZE [URL]

View 6 Replies View Related

Debian :: Aptitude Safe Upgrade - Untrusted Packages

Jul 4, 2010

I am new to Debian (just used Gentoo until now), I run a little server for our company and clients. Unfortunately our hosting company switched us from a Gentoo system to a Debian Lenny box with Confixx and stopped maintaining it. So I will need to do the house keeping, which worries me a bit. Today I started and ran: aptitude update && aptitude safe-upgrade and got a huge list with packages to upgrade. Unfortunately, I am not confident, if I will break something upgrading (Confixx, apache) as I get the following warning message:

WARNING: untrusted versions of the following packages will be installed!
Untrusted packages could compromise your system's security.
You should only proceed with the installation if you are certain that this is what you want to do.
mysql-client mysql-server-5.1 mysql-client-5.1 mysql-common mysql-server-core-5.1 mysql-server libmysqlclient16
Do you want to ignore this warning and proceed anyway?
Is it safe to ignore it and upgrade the needed packages?

View 14 Replies View Related

Debian Configuration :: Aptitude Wants To Reinstall Uninstalled Packages

Nov 6, 2015

I use Jessie, with the Aptitude curses interface for package management. It seems that every time I successfully uninstall/purge a package (along with its dependencies), then the next time I try to install/uninstall anything else it wants to reinstall that package (and its dependencies). It takes several (I haven't counted) "don't install" instructions from me before it will forget about it.

View 3 Replies View Related

Debian Installation :: Aptitude Update And Aptitude Install Aptitude?

Jul 11, 2010

I am trying to upgrade an amd64 lenny system to squeeze.I've got a 2.6.32 kernel running, done aptitude update and aptitude install aptitude.When I try "aptitude safe-upgrade", it sits forever resolving dependencies.it seems to search with the resolver counting up more and more open/conflict/ whatever.I stopped it once it got over 100,000)Is it possible to get aptitude to do a safe-upgrade, perhaps using a command line option?

View 2 Replies View Related

Debian :: Aptitude Remove For All Packages Installed In Past Hour?

Nov 14, 2010

Is it possible to do an aptitude remove for all packages installed in, say, the past hour? I'm looking for an easy way to keep track of lots of installed packages without having to look through the logs and write them all down.

View 4 Replies View Related

Debian Configuration :: Clearing Aptitude State - Removal Of Packages

Mar 18, 2010

I had been doing some removal of packages, and things went well, or so I thought. Now whenever I try and install any package using aptitude, some old state is lingering around and wants me to install packages that I do not want, and remove some packages that I am not sure about removing (did I actually select those to be removed??) I removed libvirt etc, and now it wants to come back? Also, like I mentioned, why remove those other four packages?

The following NEW packages will be installed:
aqemu gtkrsync libvirt-doc libvirt0 python-libvirt qemu qemu-kvm qemu-system qemu-user qemu-utils virt-top virt-viewer virtinst
The following packages will be removed:
dnsmasq-base{u} netcat-openbsd{u} python-gtk-vnc{u} python-vte{u}
0 packages upgraded, 13 newly installed, 4 to remove and 176 not upgraded.
Need to get 2,210kB/24.3MB of archives. After unpacking 72.7MB will be used.
Do you want to continue? [Y/n/?] ^C

Running squeeze, and enjoying it so far, apart from a broken out of the box synergy (compiled my own synergy-plus to fix that issue) and a buggy samba client.

View 3 Replies View Related

Debian :: Export A List Of All Installed Packages In Aptitude Or Synaptic?

Feb 23, 2011

Can I keep the old 32bit_testing /home with all the hidden directories there when moving to 64bit_testing?

Is there a way to export a list of all installed packages in aptitude or synaptic, so that when reinstalling, it can be easily imported? (reinstalling the same system)

View 3 Replies View Related

Debian Installation :: Packages (Security Sensitive) In Aptitude Safe Upgrade?

Feb 17, 2011

Today I ran
aptitude update && aptitude safe-upgrade
Like I regularly do, and I see these two packages need to be upgraded:
login passwd

Since these packages seem kinda security-sensitive I would like to know exactly why I would need to upgrade them. I checked Debian's security list but couldn't find anything relevant, and the links to the changelog for both packages are broken:
The requested URL /changelogs/pool/main/s/shadow/shadow_4.1.4.2+svn3283-2+squeeze1/changelog was not found on this server.
Where can I see what is changed in these packages so I can safely upgrade?

View 3 Replies View Related

Debian Hardware :: Aptitude Install Libgl1-mesa-dri / Removes A Lot Of Packages?

May 17, 2011

Can anyone explain why aptitude install libgl1-mesa-dri actually removes a lot of packages? I just ran it without checking and the job was done...

aptitude install libgl1-mesa-dri
The following packages will be REMOVED:
bsh{u} bsh-gcj{u} gcj-4.4-jre{u} gcj-jre{u} libcolamd2.7.1{u}
libcommons-beanutils-java{u} libcommons-collections3-java{u}
libcommons-compress-java{u} libcommons-digester-java{u}
libcommons-logging-java{u} libdb-je-java{u} libdb4.7-java{u}
libdb4.7-java-gcj{u} libgcj10-awt{u} libgraphite3{u} libhsqldb-java{u}
code....

View 1 Replies View Related

Debian Configuration :: How To Force Remove Broken Keyring Package

Jun 17, 2011

I want to remove a keyring package I installed from a repository that I no longer want to use. However, I cannot remove it:

# apt-get remove -y --force-yes debian-xray-keyring
Reading package lists... Done
Building dependency tree
Reading state information... Done

The following packages will be removed:
debian-xray-keyring
0 upgraded, 0 newly installed, 1 to remove and 130 not upgraded.
After this operation, 49.2 kB disk space will be freed.
(Reading database ... 181076 files and directories currently installed.)

Removing debian-xray-keyring ...
gpg: key "AB8F901D" not found: eof
gpg: AB8F901D: delete key failed: eof
dpkg: error processing debian-xray-keyring (--remove):
subprocess installed pre-removal script returned error exit status 2
configured to not write apport reports
Errors were encountered while processing:
debian-xray-keyring
E: Sub-process /usr/bin/dpkg returned an error code (1)

View 4 Replies View Related

Ubuntu Installation :: Updater Says Error 'Fix Broken Packages First' But No Broken Packages

Apr 24, 2010

I've been trying to fix this problem for quite a few days now and have done a lot of searching on these forums, Linux Mint Forums and some others Google lead me to and have has some success, but am now stuck.I have posted a thread on this same topic on the Linux Mint Forums, but have had no success (if you want check it out at:URL...Originally I received error messages when trying to update involving certain repositories which couldn't be accessed (because they either didn't exist or had been moved) and I hunted these down and changed or removed them.

I have done much searching, etc. and cannot find any broken packages. I have tried many many different commands which have mostly done nothing.I seem to be in a similar boat to this person: URL...

View 2 Replies View Related

Ubuntu :: Force Grub To Ignore Specific Kernel Version?

Feb 7, 2011

I just upgraded my storage server to maverick and it seems the 2.6.35-25 kernel doestn like the hardware im using
since im pretty sure its a hardware related problem and the previous kernel hastn the issue im currently booting this old kernel everytime i need the server by hand (using Shift during boot for the grub menu to appear)

well, it narrows down to the following question:
how can i exclude a specific grub entry - in my case the current kernel 2.6.35-25 - so only previous kernels OR future kernels from the next updates will have a chance to boot?

View 4 Replies View Related

Debian :: Broken Packages / Dependencies

Aug 27, 2015

seems like after a recent upgrade of stretch, i get a message (in italian)

Code: Select all
$ sudo apt-get install kde-full
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Alcuni pacchetti non possono essere installati. Questo può voler dire
che è stata richiesta una situazione impossibile oppure, se si sta
usando una distribuzione in sviluppo, che alcuni pacchetti richiesti
non sono ancora stati creati o sono stati rimossi da Incoming.
Le seguenti informazioni possono aiutare a risolvere la situazione:

[CODE]..

View 2 Replies View Related

Ubuntu :: How To Ignore Certain Packages During Update

Aug 11, 2010

if there is a way to blacklist certain packages when updates come around. The reason for this is that I have two repositories that contain Smplayer and Mplayer. But one repository versions of this aren't VDPAU active (but the build is newer).

View 1 Replies View Related

Debian :: Lenny: Error On Fixing Broken Packages?

Aug 25, 2011

I have Lenny in a multi-boot system on a HP Pavilion DV-1000 laptop, and yesterday when I logged in, noticed the red (-) icon on the right of the top panel. Mouse over it gave the message: "An error occurred, please run Package Manager from the right-click menu to see what is ". On doing so, Synaptic came up with "You have 3 broken packages on your system! Use the "Broken" filter to locate them". Selecting "Broken dependencies" resulted in the "base-files", base-passwd", and "dpkg" being listed. All three had "Installed Version" the same as "Latest Version", but marked in red in the check boxes.

Did "Edit"->"Fix Broken Packages" which marked the packages green. Clicking "Apply" gave a summary list: coreutils, gawk, gcc-4.3-base, libacl1, libattr1, libc6, libgcc1, libselinux1, libstdc++6, and izma as the packages that needed to be installed. Clicked "Apply" and got: "E: Internal Error, Could not perform immediate configuration (2) on libc6" A Google search indicated several people had run into this problem, but I could not find one consistent solution that seemed to address the problem completely.

View 2 Replies View Related

Debian Installation :: Mixed Wheezy With Sid Now Have Broken Packages

May 6, 2015

Without knowing the consequences I added the Sid repository to Wheezy (installed version) in order to install some software. Only much later I discovered that this generated me some mess which does not allow now to install additional software due to library conflicts.

I tried to install some packages needed to build the PhantomJS but here is what I got:

Code: Select allReading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version.
g++ is already the newest version.
g++ set to manually installed.

[Code] ....

Is there a way to clean up the mess that Sid introduced and revert back to the Wheezy versions?

I have an old backup, so it would take me much more time to reinstall/reconfigure certain software, so I am looking to alternatives.

Is there a way to check all the packages and find all the potential conflicts and then a way to restore the original Wheezy content?

View 1 Replies View Related

Debian :: Repositories Not Installing - Broken Packages Error

Jun 4, 2015

I've been trying to install a few programs with the basic Debian repositories on my Jessie edition, but I keep getting a "broken packages" error and "cannot be installed" error, and the programs won't install.

I went to other repositories, e.g. Mint and Ubuntu, and with these included in my sources.list file, I was able to install the desired programs.

If the programs are listed in Debian and the dependecies as well, why would they not install?

View 9 Replies View Related

Debian :: Proftpd Install - Unmet Dependencies And Broken Packages

Oct 23, 2015

I am attempting to setup an ftp server as a first project to get me going in the world of Linux however when I run the command apt-get install proftpd-basic ....

View 14 Replies View Related

Debian Multimedia :: Install Gnome On Testing - Broken Packages

Sep 12, 2015

I'm on Debian testing and every time I try to install Gnome I get this:

Code: Select all# alexandernst at stupidbox in ~ [18:51:07]
$ LC_ALL=C sudo tasksel install gnome-desktop --new-install
tasksel: apt-get failed (100)

I tried installing it manually:

Code: Select all# alexandernst at stupidbox in ~ [18:51:35]
$ LC_ALL=C sudo apt-get install gnome                     
Reading package lists... Done
Building dependency tree       
Reading state information... Done

[Code] ....

Is this a problem in Debian repos (held packages) or I'm actually doing something wrong?

View 13 Replies View Related

Ubuntu :: Aptitude Forget New Packages?

Mar 11, 2011

Manual says: Forgets all internal information about what packages are �new�

What does it mean in plain English?

View 2 Replies View Related

Ubuntu :: Use Apt-get Or Aptitude To Tell Me What Updated Packages Are Available

May 25, 2011

How do I use apt-get or aptitude to tell me what updated packages are available for my system? I'm moving over from Gentoo where I had a cron job that would run a command whose output was a list of available updates. I had this and other system related info emailed to me. I'd like to duplicate that under Ubuntu, but I can't find a way get the available updates.

View 2 Replies View Related

General :: Pass List Of Packages To Aptitude And Resolve Conflicts?

Jun 20, 2011

How do I pass a list of packages to aptitude so that I can resolve the conflicts interactively?

View 1 Replies View Related







Copyrights 2005-15 www.BigResource.com, All rights reserved